6 Replies Latest reply on Jul 7, 2011 9:12 PM by John Hawkinson

    Punctuation on the mean line

    mraganyi

      Hi all,

       

      I just created a 28 page piece, and on some of the pages, but not all, the punctuation shows up on the mean line instead of on the base line. Does anyone know what I've done to make this occur?

       

      Thanks so much in advance!

        • 1. Re: Punctuation on the mean line
          Joel Cherney Adobe Community Professional & MVP

          It's remotely possible,I think,that you're actually using text in a traditional Chinese font,which has punctuation that is designed to appear in the middle of where a fullwidth Chinese character would appearWhat font are you using?

           

          It's a lot more likely that something about the font or document is corrupt, or that your punctuation has some baseline shift or something like that, but I thought I'd take a shot with the above guess. It might help if you were to take a screenshot (with hidden characters showing, Type -> Show Hidden Characters), or if you were to provide more information, like the name of the font, or if text behaves in this way no matter what page it's on, or if the punctuation goes funny when text is flowed onto the page, et cetera. Also: what version of ID are you using, and on which platform?

          • 2. Re: Punctuation on the mean line
            mraganyi Level 1

            Hi Joel,

             

            Thanks for your response! Here is a Screenshot of the problem.Screen shot 2011-07-07 at 12.00.56 PM.png

            On the second and fourth lines, the commas are on the median line. However, on the last line, the commas are on the baseline. I'm just using plain old Myriad Pro for this. I checked to see if perhaps my setting for fractions was effecting it, but that didn't seem to be it. It seems to be only on certain lines where it happens, but not on others, and I'm not spotting rhyme or reason to it.

             

            Thanks!

            • 3. Re: Punctuation on the mean line
              Joel Cherney Adobe Community Professional & MVP

              Bizarre. It's not superscript, either. I think it's an OpenType alternate of some sort. If I set a comma and apply superscript, the bottom of the comma does not line up with the bottom of the eye in the "e" - but if I go to Type -> Glyphs and find the comma in Myriad Pro, I can click and hold and get a bunch of OT alternates for the comma. One of them does match your bizarro comma perfectly.

               

              And, to muddy the waters further, I get that comma when I turn Fractions on in the OpenType menu, when you specifically say that this doesn't happen for you. Shot-in-the-dark no. 2: perhaps your document is becoming corrupt? Maybe it's time to export an IDML (or INX) and re-open in hopes of clearing corruption?

              1 person found this helpful
              • 4. Re: Punctuation on the mean line
                mraganyi Level 1

                After hearing you found similar issues with the Open Type and glyphs, I decided to retry the Fractions. When I highlighted only the weird commas, sure enough the Fractions came up! It looks like I'll have to just go through comma by comma, as it won't change anything when I try to go line by line.

                 

                Thank you SO MUCH for your help! Sometimes just hearing someone else go through the process can put me in the right direction. Very much appreciated!!

                • 5. Re: Punctuation on the mean line
                  mraganyi Level 1

                  I was having problems with punctuation showing up on the mean line in certain spots on a document. I originally tried to fix it by checking to see if my Fractions were active in the Open Type menu, and they were not. However, when I took it comma by comma, it turns out the Fractions were active, and I was able to fix it that way.

                  • 6. Re: Punctuation on the mean line
                    John Hawkinson Level 5

                    Keep in mind these checkboxes have 3 states: ON, OFF, and {mixed}. So try clicking the box 3 times ot make sure you know which state it is in. Sometimes you can confuse {mixed} with OFF.