15 Replies Latest reply on Jul 8, 2011 10:04 AM by Colin Brougham

    Cannot enable full resolution in Program Monitor

    Clint Porter Level 1

      Hi friends,

       

      I'm coming to Premiere from FCP, and this is one I just can't figure out. How do you view full resolution in the Program Monitor? I'm only seeing one field.

       

      I have a DV clip in a Blackmagic Uncompressed 720x480 sequence. It looks fine on my reference monitor (via BM Intensity Pro), but it only shows half resolution in the Program Monitor. I have several settings when I right-click in the Program Monitor (Top, bottom, both fields; play/paused resolution), but none of them seem to have any affect on what I see.

       

      The only way I can seem to see full res in the Program Monitor is if I switch to a non-Blackmagic timeline… but then I can't output it to the reference monitor. In FCP, I can see full-res in the Source, Program and external reference monitor. How does one do this in Premiere?

       

      Thanks!

       

      Clint

        • 1. Re: Cannot enable full resolution in Program Monitor
          lasvideo Level 4

          Right click on the Program Monitor. In the drop down, towards the bottom is an option to choose Screen Resolution. Im new to PrP from FCP as well. This one got my attention immediately.  ;-)

          • 2. Re: Cannot enable full resolution in Program Monitor
            Clint Porter Level 1

            Thanks for the reply. When I right-click, I don't have "Screen Resolution", but I do have "Fields", "Paused Resolution", and "Playback Resolution". None of those settings seem to do anything. It still just looks like half resolution blurred across both fields.

             

            When I set up an NTSC DV timeline (not a Blackmagic timeline), all of the above controls seem to do exactly what you'd expect and I can see full-res in the Program Monitor… but of course, I have no reference monitor output then. I'm using Premiere CS5 (.0).

             

            Is this just a known limitation that Premiere editors live with? Or am I missing something?

            • 3. Re: Cannot enable full resolution in Program Monitor
              Colin Brougham Level 6

              First, you say "CS5" but do you mean "CS5.5"? If this is a retail version of CS5, be sure to update to the latest version (5.0.3 Windows/5.0.4 Mac).

               

              Next, are you using the latest version of the BMD drivers?

               

              Finally (and not sure this applies as I don't have a BMD card), go to Edit > Preferences > Player Settings, and see if you have a different option other than Adobe Player. Try changing that.

              • 4. Re: Cannot enable full resolution in Program Monitor
                Clint Porter Level 1

                Also, I get a red render bar since my footage is DV, not Blackmagic. Is there any way I can setup a native timeline for my footage that I can also preview on my reference monitor, like FCP?

                • 5. Re: Cannot enable full resolution in Program Monitor
                  Colin Brougham Level 6

                  No, you must use a Blackmagic sequence preset to use the Blackmagic output. And don't sweat the red bar; if the footage plays back in realtime, you're fine. I can't imagine that DV footage would present any problems in this regard.

                   

                  If you haven't yet, check out this blog post: Red, yellow, and green render bars and what they mean « Premiere Pro work area

                  1 person found this helpful
                  • 6. Re: Cannot enable full resolution in Program Monitor
                    Clint Porter Level 1

                    Thanks, Colin. That clears up one question. Also thanks for the info on the color bars. With FCP, red/orange meant unrendered, which meant what you see isn't necessarily what you'll get. Nice to know that in Premiere, it only means a settings mismatch.

                    • 7. Re: Cannot enable full resolution in Program Monitor
                      Colin Brougham Level 6

                      You're welcome, Clint; in general, you can ignore the colored bars, and just go by feel. If playback is not smooth, you'll either need to render or kick down the playback resolution, but if you're not experiencing any choppiness, just go with it.

                       

                      Just found this in the Intensity manual:

                       

                      Player Settings
                      The default player should be switched from Adobe Player to Blackmagic Playback. The choice of player settings can be configured through Premiere Pro > Preferences > Player Settings.

                       

                      That's for Mac, obviously, which I'm assuming is what you're using.

                      • 8. Re: Cannot enable full resolution in Program Monitor
                        Clint Porter Level 1

                        I updated the BMD drivers last week to 8.0.1. I was on Premiere 5.0.3 (Mac), so I just downloaded 5.0.4. It seems to have the same issue.

                         

                        I have the Player Settings set to Adobe Player so that my footage displays correctly in the Source Monitor. (When I set it to Blackmagic, I have the same above issue in the Source Monitor) This doesn't seem to help the issue in the Program Monitor, however.

                         

                        When I load a DV clip from the Project panel into the Source window, I can set it to full res, including interlace lines. When I then stick it in a BM Uncompressed 720x480 Lower Field First timeline and play it in the Program window, or load it back into Source, I can't see it in full res no matter what my resolution or field settings are.

                        • 9. Re: Cannot enable full resolution in Program Monitor
                          Colin Brougham Level 6

                          Does the resolution appear to "shift" when you playback the Program Monitor? What I mean is whether the resolution is higher when the sequence is paused than when you playback, or does it appear low-res all the time?

                           

                          I'd suggest GPU drivers, but if you're getting full-resolution in an Adobe sequence, that wouldn't likely be the explanation. Might be a question for BMD... I'm sort out of suggestions as I don't have a BMD card.

                          • 10. Re: Cannot enable full resolution in Program Monitor
                            Clint Porter Level 1

                            I think I understand what you're describing, because that's exactly how I'd describe playback in a regular DV timeline. In the BM DV timeline, by comparison, no shift happens between playback and pause–it's low res all the time.

                             

                            I think you're right that it's a BMD issue. The Program Monitor is apparently always powered by the "Blackmagic Player" when using a Blackmagic sequence, which is why none of the menu settings do anything. This issue happens in the Source Monitor only when it is set to "Blackmagic Player" in Preferences.

                             

                            Hopefully someday Premiere will work around this the way FCP always has… by letting you set up whatever kind of native timeline you want, and then somehow sending the result out to the card for external monitoring. Thanks for your help!

                            • 11. Re: Cannot enable full resolution in Program Monitor
                              Colin Brougham Level 6

                              Hmm... wish there was a clearer resolution for you (pun partial intended ), but do contact BMD about it. I had a BMD Decklink in the past, and one driver version would work while the next would introduce a weird new bug. Fortunately, their releases are pretty rapid, so it might be something addressed sooner than later, especially if folks start making noise about it.

                               

                              Speaking of noise:

                              Hopefully someday Premiere will work around this the way FCP always has… by letting you set up whatever kind of native timeline you want, and then somehow sending the result out to the card for external monitoring.

                               

                              Absolutely; lend your voice to the din right here: Adobe Feature Request/Bug Report Form. That would be the best solution if we could get there!

                               

                              By the way: had you tried out any of the other BMD presets, e.g. an HD preset, to see if it has the same issue?

                              • 12. Re: Cannot enable full resolution in Program Monitor
                                Clint Porter Level 1

                                Thanks, I'll contact BM about it, and also submit a Premiere feature request for a workaround a lá FCP.

                                 

                                I tried a 1080i DVCPRO HD clip, and it has the same issue with the equivalent BM timeline. (I also tried a 1080i AIC clip, but I couldn't even get that to display full res/interlacing in a native timeline, which I guess I should chalk up to not knowing my way around Premiere yet)

                                • 13. Re: Cannot enable full resolution in Program Monitor
                                  Clint Porter Level 1

                                  I also noticed other tools like Title Safe cannot be used with Blackmagic timelines. If anyone out there is also using BM Intensity Pro with Premiere, I'd love to know more about your workflow.

                                  • 14. Re: Cannot enable full resolution in Program Monitor
                                    Colin Brougham Level 6

                                    I also noticed other tools like Title Safe cannot be used with Blackmagic timelines.

                                     

                                     

                                     

                                    Really? That seems strange. I guess that could be a function of the BMD Player. This makes me wonder, though: what is your Program Monitor scale set to?

                                     

                                    scale.png

                                     

                                    (This may explain the low-res display, too...)

                                    • 15. Re: Cannot enable full resolution in Program Monitor
                                      Clint Porter Level 1

                                      I've been checking to make sure it's at 100% in all my testing (In FCP, "Fit" always prevented both fields from displaying as well, so I learned to look out for this)