8 Replies Latest reply on Jul 10, 2011 12:22 PM by Todd_Kopriva

    Problems with rendering fractal noise.

    Bam Rees Level 1

      Hello,

       

      I have created a short clip and am having problems with rendering. I am using AVC HD video at 25fps.

       

      The clip uses fractal noise on a solid layer to generate TV noise and i have that above my video layer.

       

      The opacity is keyframed to show bits of the video underneath and flicks back and forth between 100 and 0.

       

      My render settings are ( AE - Windows -Uncompressed) then I use adobe media encoder to compress it using (WMV 1080 25 High Quality)

       

      This creates terrible pixelation on the render. I use the same preset for all my other video's and they are fine. I have even turned off the fractal noise layer in my composition to see if its any different and that also renders fine so it has to be something with the fractal noise layer.

       

      I just dont understand. Please could someone help...

        • 1. Re: Problems with rendering fractal noise.
          Mylenium Most Valuable Participant

          The wonderful world of compression..... Perfectly normal. The detail simply changes too rapidly to be captured by the temporal part of the compression, so multiple consecutive frames are averaged to the same blocks, mking the patterns appear. The only way to avoid it is not to use such stuff, otherwise an enforced keyframe interval might improve matters, but there wil lalways be some artifacting...

           

          Mylenium

          • 2. Re: Problems with rendering fractal noise.
            Todd_Kopriva Level 8

            Are you using OpenGL to render? If so, don't. The OpenGL preview renderer does an especially bad job with Factal Noise.

             

            A screenshot of what you're seeing would help with the diagnosis, as would more standard details like what version of After Effects, what OS, etc.

            • 3. Re: Problems with rendering fractal noise.
              Fuzzy Barsik Level 4

              And another one extra question.

              Do you tick 'Best visualisation quality' checkbox in AME settings dialog box while rendering from lossless to lossy format?

              (sometimes it helps...)

              • 4. Re: Problems with rendering fractal noise.
                Bam Rees Level 1

                No I am not using OpenGL

                I am running Adobe Master Suite CS4Also in reply to Fuzzy_Barsik - I cannot find a 'Best visualisation quality' checkbox in AME settings.Please find attached a screenshot of my horrible render.

                 

                Matthew Rees

                 

                Date: Sun, 10 Jul 2011 10:27:37 -0600

                From: forums@adobe.com

                To: cymruambyth@msn.com

                Subject: Problems with rendering fractal noise.

                 

                Are you using OpenGL to render? If so, don't. The OpenGL preview renderer does an especially bad job with Factal Noise.

                 

                A screenshot of what you're seeing would help with the diagnosis, as would more standard details like what version of After Effects, what OS, etc.

                >

                • 5. Re: Problems with rendering fractal noise.
                  Todd_Kopriva Level 8

                  Is the poor quality happening in the previews within After Effects or just on final output? If it's just happening on final output, is it happening when you use a lossless codec (say, AVI with no compression or QuickTime with Animation codec at 100% quality)?

                   

                  Actually, now that I reread your qestion, it says that you're beginning with an uncompressed movie. Does that look OK? Is it just your final encoded and comrpessed version that looks bad?

                   

                  Your attachment didn't work. I can't see what you tried to show.

                  • 6. Re: Problems with rendering fractal noise.
                    Bam Rees Level 1

                    Damn, im not sure how to use this forum, im just replying straight to the email. I cant find anywhere on the actual forum to type.

                    It is all fine during the preview inside AE and is fine in the Uncompressed version, it just goes really bad when converting to a compressed format.

                    I usually render out of AE as Uncompressed AVI and then use Adobe Media Encoder to compress it to WMV with the settings as written above.

                     

                     

                    Matthew Rees

                    • 7. Re: Problems with rendering fractal noise.
                      Todd_Kopriva Level 8

                      Your subject line was very misleading, then, but at least the problem is now understood.

                       

                      "Rendering" is the creation of the image from After Effects. The rendering is fine. It's the compression/encoding that is causing problems.

                       

                      ... which is what Mylenium said at the outset.

                       

                      The likely difference with the Fractal Noise effect is just that it cretaes a lot of extra detail for the encoder to try to compress---and it can't give the same quality at the same file size as when the fine detail in the image is less. This is one of the core principles of compression.

                      • 8. Re: Problems with rendering fractal noise.
                        Fuzzy Barsik Level 4

                        'Best Visualisation Quality' checkbox is in the lower right quarter of AME settings dialog box.

                        But it's available in CS5.5 (perhaps, in CS5 - don't remember exactly).

                        If you are on CS4, you don't have that one...