0 Replies Latest reply on Jul 16, 2011 9:37 AM by vovasurkov

    Design mode does't Displays children of DataGridColumn(sdk 3.5)

    vovasurkov

      I have

           public class DataGridColumnD extends DataGridColumn

       

      when I try to use it in code

       

      <mx:Application  xmlns:mx="http://www.adobe.com/2006/mxml"                           
                      minWidth="955" minHeight="600"
                     xmlns:dg="dg.comp.*" creationComplete="application1_creationCompleteHandler(event)">

       

          <mx:DataGrid id="gd" width="100%" height="100%" rowCount="5" dataProvider="{arr}">
                      <mx:columns>
                          <dg:DataGridColumnD showDataTips="true" dataTipField="uni_Codu" dataField="uni_Codu" headerText="Name"/>
                          <dg:DataGridColumnD showDataTips="true" dataTipField="uni_Description" dataField="uni_Description" headerText="Phone"/>                  
                      </mx:columns>
                  </mx:DataGrid>

       

      in design mod I see

       

       

      4.JPG

      but with code

       

      <mx:DataGrid id="gd" width="100%" height="100%" rowCount="5" dataProvider="{arr}">
                      <mx:columns>
                          <mx:DataGridColumn showDataTips="true" dataTipField="uni_Codu" dataField="uni_Codu" headerText="Name"/>
                          <mx:DataGridColumn showDataTips="true" dataTipField="uni_Description" dataField="uni_Description" headerText="Phone"/>                   
                      </mx:columns>
      </mx:DataGrid>

       

      i see

       

      3.JPG

       

      it is important that at runtime DataGridColumnD displays normal
      also problem resolves with 4.0 sdk using
      but our project uses 3.5