8 Replies Latest reply on Jul 20, 2011 9:21 AM by Dave LaRonde

    After Effects not rendering layer transitions

    adrian.jfl

      Dear Gurus,

       

      This is my first day with After Effects but i've done plenty of research and hopefully my main query here isn't a silly one.

      I have a composition (made from JPEG sequence) with a number of layers and finally managed to add a 'block dissolve' effect between them.

       

      My Setup:

      MBP 8GB RAM, After Effects CS4, OSX Lion (developer release).

       

      My Questions

       

      (1) When I preview the sequence everything looks great (albeit slow) and the block dissolves show up fine.  When I render it out, it also looks good except there is no block dissolve transitions - it just flicks from one layer to the other.   FYI - I don't have openGL enabled.  I am trying to render to quicktime format with H.264 encoding at 90% quality.

       

      (2) In iMovie (sorry for the comparison), it was really easy to just drop a transition between two sets of footage.  In After effects, I added the effect to the clip then had to click the timeclock icon and specify the duration etc etc..  Not a big deal but is there a easier way?

       

      (3) Also in iMovie there appeared to be a lot more normal/bland transitions effects like cross fades.  I'm sure they are possible in After Effects - could someone give me a quick pointer?

       

      Thanks!

        • 1. Re: After Effects not rendering layer transitions
          Mylenium Most Valuable Participant

          (2) In iMovie (sorry for the comparison), it was really easy to just drop a transition between two sets of footage.  In After effects, I added the effect to the clip then had to click the timeclock icon and specify the duration etc etc..  Not a big deal but is there a easier way?

           

          That's how AE works. It's simply a different paradigm.

           

          (3) Also in iMovie there appeared to be a lot more normal/bland transitions effects like cross fades.  I'm sure they are possible in After Effects - could someone give me a quick pointer?

           

          Of course there is - you stack and combine effects to produce new effects and unique looks which for all intents and purposes can be consecutive applications of transitions as well - one linear wipe from the right, one from the left, one from top, one from bottom and all with different timing - animated organic crop. Once animated, you can save this as an animation preset and re-apply it to otehr layers. Check the help for the gory details. Of course you can also get tons of extra plug-ins to add more and more such stuff, but if I may be so bold: If your sole intention is to produce slideshows with canned transitions, then you are using the wrong tool and on some level mis-using AE. As I already said above - you need to get into it if you realyl want to exploit its creative potential. AE is not an editing tool or any such thing, it is a versatile compositing tool and that power comes with a price. Even if you ever only use 0.5% of it, you need to adapt your workflow.

           

          As to why your effects don't render is an open question, but since you yourself mention that this is your first day with AE, chances are you have flipped some switch wrongly in teh render settings, aere using OpenGL or something silly like that. Perhaps you can provide screenshots or a detailed listing ofd your comp settings, timeleine and render settings to help unriddle this...

           

          Mylenium

          • 2. Re: After Effects not rendering layer transitions
            Dave LaRonde Level 6

            MBP 8GB RAM, After Effects CS4, OSX Lion (developer release).

             

            Beware -- you're trying to use AE in an OS environment of which Adobe software engineers had absolutely no knowledge when they wrote CS4.

             

            There's no telling for sure what works and what doesn't, and it's compounded by the fact that this is Day One In AE for you.

             

            You wouldn't even know if you're looking at an application/OS conflict or an operator error.

            • 3. Re: After Effects not rendering layer transitions
              adrian.jfl Level 1

              Hi Dave,

               

              So sorry - I actually have CS5, not CS4 - my mistake.  I've played around a fair bit more with different output modules and render settings and still can't get the transitions.  They look fine in preview, but don't come out in the render.  Any ideas?

               

              Thanks,

              Adrian.

              • 4. Re: After Effects not rendering layer transitions
                Mylenium Most Valuable Participant

                As I already said - provide screenshots and an exact description of your settings. You are just re-posting a "My car doesn't run!" question that is of no use to anyone in order to help you.

                 

                Mylenium

                • 5. Re: After Effects not rendering layer transitions
                  Dave LaRonde Level 6

                  I actually have CS5, not CS4

                   

                  In this case, there still isn't any difference; AE 10 was released long before Lion was even in Beta.  Since Lion isn't officially released yet, there aren't any updates to resolve OS issues.

                   

                  They look fine in preview, but don't come out in the render.  Any ideas?

                   

                  Using Open GL to accelerate rendering is the most common cause for this.  If you've got it on for rendering (not previewing), turn it off.

                   

                  And if you're a newbie, you really owe it to yourself to look this over:

                  http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.html

                  • 6. Re: After Effects not rendering layer transitions
                    adrian.jfl Level 1

                    Hi Mylenium,

                     

                    As I already said - provide screenshots and an exact description of your settings. You are just re-posting a "My car doesn't run!" question that is of no use to anyone in order to help you.

                     

                     

                    I didn't re-post the same question, and in my first post I told you what car model I had, what type of garage I keep it in, the precise problem I am having with it and even mentioned some of the things that I have tried already to fix the problem after doing some research  (e.g. turning OpenGL off).

                     

                    I thought I provided some useful information there but here some some screen captures which I hope will help more.

                     

                    https://skitch.com/ajfl/fk5qb/lillies.aep

                    https://skitch.com/ajfl/fk5ug/quicktime-options

                    https://skitch.com/ajfl/fk5wd/lillies.aep

                     

                    I appreciate your time.

                     

                    Thanks!

                    • 7. Re: After Effects not rendering layer transitions
                      adrian.jfl Level 1

                      hHi Dave,

                       

                      Using Open GL to accelerate rendering is the most common cause for this.  If you've got it on for rendering (not previewing), turn it off.

                       

                       

                      I read that in another thread so have made sure it's off but thanks for the tip.  Please see my screen captures.

                       

                      And if you're a newbie, you really owe it to yourself to look this over:

                      http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after- eff.html

                       

                      Thanks for the tip - I appreciate it.  I have been reading lots of great blogs and tutorials lately  I need to do some semi complex stuff eventually like making eveything except part of the footage B&W but I thought i'd start with the basics and just get to know how to do the easy stuff I was previously doing in iMovie...  That's when I ran into this problem.

                       

                      Really apprecaite your time.

                       

                      Thanks !

                      • 8. Re: After Effects not rendering layer transitions
                        Dave LaRonde Level 6

                        I thought i'd start with the basics and just get to know how to do the easy stuff I was previously doing in iMovie...  That's when I ran into this problem.

                         

                        I'm not surprised.  Trying to use AE to mimic the operation of an editing application is like trying to mow a football field with a push mower.  Yeah, you can do it, but it's going to take a long time and there are better tools for the job... like an editing application.

                         

                        Stick to what AE does best: effects and compositing, not editing.