0 Replies Latest reply on Jul 21, 2011 9:16 AM by flexstone

    Flex Builder 3 will not launch after restored backup

    flexstone Level 1

      I had to replace my HD on my iMac and since doing a full restore from an external backup drive my FB 3 app will not launch.

       

      It presents an error and tells me to check the log file which I pasted here:

       

      !SESSION 2011-07-21 11:29:55.487 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.6.0_26
      java.vendor=Apple Inc.
      BootLoader constants: OS=macosx, ARCH=x86, WS=carbon, NL=en_US
      Command-line arguments:  -os macosx -ws carbon -arch x86

       

      !ENTRY org.eclipse.core.runtime 4 0 2011-07-21 11:29:57.118
      !MESSAGE
      !STACK 0
      org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.preferences; bundle-version="[3.2.0,4.0.0)"
          at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
          at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
          at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
          at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManage r.java:634)
          at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java :508)
          at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelMana ger.java:282)
          at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManage r.java:468)
          at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
          at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

       

      Anyone have any ideas ?????