2 Replies Latest reply on Jul 21, 2011 1:53 PM by Rick Gerard

    Dynamic Link doesn't show 3D comp

    alvarogg19 Level 1

      Hi. I've been using Dynamic Link a log time ago, but now I have some problems.


      I'm working in a project in Premiere CS5, when I send it to After Effects, I'm converting this composition in a 3D layer and set some parameters in Transform. If I change Scale and Position works great and it shows it immediately in Premiere.
      But when I change Rotation or Orientation, it doesn't do anything in After Effects either.

      I thought it was a problem in the preview only, so I rendered the comp from AE and from Premiere and it went wrong.


      I attach a picture of what I'm doing. You can see the "Orientation" parameters in 328°, but the screen doesn't show it.


      What can I do? What I'm doing wrong?


      Thanks for your help.Test.jpg

        • 1. Re: Dynamic Link doesn't show 3D comp
          Rick Gerard Adobe Community Professional & MVP

          It looks like you've got collapse transformations turned on and that the Footage layer is a composition. I'd guess that the Maria Isabel.avi in the Maria Isabel.avi composition is 2D. With Collapse transformations turned on what you are seeing is normal behavior.


          What you want to do is to simply right click on the Maria avi in the Premiere timeline and select Replace with After Effects Composition. Once inside AE don't pre-compose the avi layer, just make it 3D.


          The other option would be to open up the Maria Isabel.avi composition and do your 3D transformations there.

          Yet another option wold be to turn off Collapse transformations.


          I'm not sure why the Maria Isabel.avi footage was Pre-comped. I can't see anytning in the screenshot that gives me a reason.

          • 2. Re: Dynamic Link doesn't show 3D comp
            alvarogg19 Level 1

            Thanks Rick!


            I had did it the way you mentioned. "Right click in Premiere Pro and Replace with After Effects Composition"

            I didn't make a precomp. It sends it to After Effects that way.


            But you turned on my light when you said that. I'd never thought about that was a "precomp", so I doubled click on it, and made 3D the original avi footage and that was all!


            It was easy to understand it! Maybe I was so slow today!


            Thank you very much!