3 Replies Latest reply on Jul 22, 2011 2:00 AM by RoboColum(n)

    Robohelp 9 crashing when generating Web Help

    MMartinJohnson

      Hi there, I have RH V 9.0.1.232 installed. I have a project with about 1000 files which was converted from RH 8 without issue until now.

       

      There are 3 Conditional Build Tags. I can publish the project to Web Help with layouts including tags #1 and #2, but when I include #3 in any layout, RH crashes at the same point every time, as shown below:

       

      7-21-2011 2-23-43 PM.png

       

      I have tried leaving it for over an hour without change. When I open Task Manager, RH is listed as "Not Responding." I do not get an error message at all. I have not generated this layout in several months, and possibly not since I have had RH 9.

       

      Tag #3 must be applied to hide content from a public audience. This tag is applied to several sections in every topic, and is also applied at the topic level for about 20% of the topics.

       

      Here is what I've tried to do:

       

      1. Create a test project with multiple tags and publish to WebHelp - no issue found.

      2. Rolled the project folder back to an earlier version from yesterday morning - problem still exists, could try an earlier version but a lot of work was done yesterday.

      3. Followed the instructions here, which have served me well in the past - problem still exists- http://www.techfuels.com/software-jargons/29202-repairing-corrupted-robohelp-project.html

       

      All of this leads me to think there is something wrong with the tag in particular. I could delete the tag, create a new one and reapply it, but that would be a major challenge considering the number of topics I'm dealing with, and I am the lone writer.

       

      Anyway, if anyone has any ideas or has had problems like this in the past, I would appreciate your time.

       

      Thanks,

       

      Michelle

        • 1. Re: Robohelp 9 crashing when generating Web Help
          RoboColum(n) Level 5

          Hi Michelle.

           

          I see you are generating to a P: drive. Can you try generating to a local drive (e.g. C:\Output) and see if this makes any difference. Another thing to try is to create a new WebHelp Single Source Layout. If none of this works, there has to be something in your project that is causing RH to choke. This may not be a tag but could be the actual content. Can you tell us what content has been added since your last compile? That may help narrow it down a bit, otherwise we'll have to take some other steps.

           

          Colum

          1 person found this helpful
          • 2. Re: Robohelp 9 crashing when generating Web Help
            MMartinJohnson Level 1

            Well thank you so much! Your question about what content has been added since my last compile got me thinking. What's changed is that we have a new format for all the topics, which is a number of tables nested inside a larger table. When I looked in Code View at how/where the Conditional Build Tags were placed in the table, the end tag was outside the close table tag for the larger table. I ran a couple of tests, and sure enough, when the tags capture the close table tag, it crashes when I try to generate. So now I need to go through all topics and move the tag. Phew! Thanks again. I always forget about this forum and should hang around here more to try help others and pay it forward. 

            • 3. Re: Robohelp 9 crashing when generating Web Help
              RoboColum(n) Level 5

              Michelle I think that whilst thanks are always welcome, in this case you should thank yourself. All I did you get you to question what had changed. You did all the hard graft. Glad you got it sorted.

               


                The RoboColum(n)   @robocolumn   Colum McAndrew