4 Replies Latest reply on Jul 22, 2011 10:01 AM by LaKisha1

    Search Tab in WebHelp Not Displaying Any Topics

    LaKisha1

      Let me preface this thread by saying that I JUST figured out the answer to my own problem. I tried to post this thread about 2 hours ago, but the forum was having issues...I got unexpected errors, and such. Although I figured out the answer a moment ago, I wanted to post the thread anyway, in case others come across the same problem, they will know how to fix it.

      ____________________________________________________________

       

      The Search tab in WebHelp doesn't work. No matter what I do, no topics will display when I enter search terms that I *know* are in the Help system. I have another project on the same computer, and the Search tab in that project works fine. I tried to attach screenshots, but keep getting an "unexpected error," so I gave up. But basically, if I enter a search term and click Go, "No topics found" displays.


      When the WebHelp is being generated for this project, the following displays in the Output View:

       

      "Processing Full-text-search data...
      .....................
      Finished processing Full-Text-Search data in 0 sec(s)"

       

      It looks like something that is needed in order to do the full-text-search is missing, but I have no idea what. I have read several threads in the forums regarding Search tab issues that others have had.

       

      I have:

       

          * Ensured that the itss.dll and itircl.dll are registered and in my C:\WINDOWS\system32 folder
          * Confirmed that I have keyhelp.ocx and hhctrl.ocx in my C:\WINDOWS\system32 folder
          * Used the same browser to view the WebHelp output for both projects (firefox 3.6.18)
          * Checked the project settings - they match
          * Checked everything in the WebHelp Settings window - General, Content Categories, Navigation, Search and Publish - everything matches in both projects
          * Tried creating a new webhelp layout, selecting a different skin...

      everything, to no avail.


      When the WebHelp is being generated for the project where the Search tab works, the following displays in the Output View:

       

      "Processing Full-text-search data...
      .......................................................................................... .......................................................................................... ............................................

      .......................................................................................... .......................................................................................... ............................................

      .......................................................................................... .......................................................................................... ............................................

      .......................................................................................... .......................................................................................... ............................................

      .......................................................................................... .......................................................................................... ............................................

      .........................................................................
      Finished processing Full-Text-Search data in 115 sec(s)

       

      I can't understand why the Search tab works in one project, but not the other project. See the diagnostic report below. According to the report, the only thing I don't have (and don't know how to get) is MS Help 2. But why would my search work in one project and not the other, despite not having MS Help 2? Both project have the same settings and I'm generating the same output - WebHelp. Any ideas why my Search tab works in one project, but not my other project?


      Thanks in advance for any assistance!

        • 1. Re: Search Tab in WebHelp Not Displaying Any Topics
          LaKisha1 Level 1

          The ANSWER was that I had checked the "Exclude From Search" checkbox in the Topic Properties window for all 8 topics that are in this project! Silly me. I thought that the checkbox was referring to excluding my name in the "Author" field, and possibly excluding the text I entered for "Keywords", but I didn't realize that the checkbox meant that the entire page would be excluded from the Search! This checkbox is a bit confusing...I think it should be labeled "Exclude Topic From Search" - just adding one word would have clearly indicated to me what the checkbox was for!

          • 2. Re: Search Tab in WebHelp Not Displaying Any Topics
            LaKisha1 Level 1

            NOTE: In my original post, I forgot to include the diagnostic report that was produced by using the diagnostics tool mentioned in other threads where forum members were having problems with the Search tab, so here it is (just so that this thread is complete)...

             

             

            MJ's Help Report

            A common problem with HTML Help 1.x is DLLs not correctly registered during installation. This utility checks all components and registers DLLs if required. We also report if the RoboHelp DLL is registered, and if MS Help 2 components are installed and registered.

             

            After running the report, try running your program again to see if the fault has cleared.

            General Info

            Report EXE:                C:\DOCUME~1\LMCKEN~1\LOCALS~1\Temp\Temporary Directory 1 for MJsDiag.zip\MJsDiag.exe
            Report Run Date:           7/21/2011 11:14:07 AM
            Report EXE Version:        2.7.2.0
            Download URL:              http://helpware.net/downloads/


            Operating System:           Windows NT 5.1.2600
            SysLocale.DefaultLCID:      0x0409 (1033)
            SysLocale.PriLangID:        0x0009 (9)
            SysLocale.SubLangID:        0x0001 (1)
            DecimalSeparator:           .


            HH Installed:               YES
            HH Version:                 5.2.3790.4110
            HH Friendly Version:        > 1.4a


            H2 Installed:               NO
            H2 Version:                 


            IE Installed:               YES
            IE Version:                 6.0.2900.5880
            IE Friendly Version:        Internet Explorer 6 (Windows XP SP2)

            NT Administrator

            NT Admin Check: Current user has full administor privileges: YES

            HTML Help Run-time Components

            File Registered OK: C:\WINDOWS\system32\hhctrl.ocx (Version: 5.2.3790.4110)
            File Registered OK: C:\WINDOWS\system32\itss.dll (Version: 5.2.3790.4186)
            File Registered OK: C:\WINDOWS\system32\itircl.dll (Version: 5.2.3790.2453)

            File Found: C:\WINDOWS\system32\hhctrl.ocx
                 Version = 5.2.3790.4110
                 Registry Info: {adb880a6-d8ff-11cf-9377-00aa003b7a11}
                   ClassName = HHCtrl Object
                   InProcServer32 = C:\WINDOWS\system32\hhctrl.ocx
                   ProgID = Internet.HHCtrl.1
                 DLL is Found and Registered OK = YES

            File Found: C:\WINDOWS\system32\itss.dll
                 Version = 5.2.3790.4186
                 Registry Info: {5D02926A-212E-11D0-9DF9-00A0C922E6EC}
                   ClassName = Microsoft InfoTech IStorage System
                   InProcServer32 = C:\WINDOWS\system32\itss.dll
                   ProgID = MSITFS1.0
                 DLL is Found and Registered OK = YES

            File Found: C:\WINDOWS\system32\itircl.dll
                 Version = 5.2.3790.2453
                 Registry Info: {4662DAA5-D393-11D0-9A56-00C04FB68BF7}
                   ClassName =
                   InProcServer32 = C:\WINDOWS\system32\itircl.dll
                   ProgID = ITIR.WordWheelBuild.4
                 DLL is Found and Registered OK = YES


            For HH Version Info See: http://helpware.net/htmlhelp/hh_info.htm

            HTML Help 1.x Registry Settings

            Description: If present this Key can disable HH Shortcuts and HH WinHelp commands on the local PC
            Reference: KB 810687, KB 323180

              Key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\
              Value: HelpQualifiedRootDir (string value) =
              -> Report: Policy is not enabled. HH Shortcuts are not restricted on local machine.

            Description: This key can be used to enable Hhctrl.ocx ActiveX Visual controls on servers
            Reference: KB 892675

              Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HHRestrictions
              Value: UrlAllowList (string value) =
              Value: MaxAllowedZone (string value) =
              -> Report: Settings reported for information only.

            Description: This key allows MS programs such as iexplore.exe to open ITS file that do not have a .CHM file extension
            Reference: KB 873343

              Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HelpRestrictions\AllowedExtensions
              -> Report: No special file extensions have been enabled on this PC.

            Description: This key can be used to allow access to remote ITS files
            Reference: Win 2003 SP1, KB 896054

              Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
              Value: UrlAllowList (string value) =
              Value: MaxAllowedZone (string value) =
              Value: NestedProtocolList (string value) =
              -> Report: Settings reported for information only.

            For HH Registry Info See: http://helpware.net/htmlhelp/hh_info.htm#hh14

            HTML Help 1.x Workshop Components

            *** HH Workshop not found or not installed correctly. Try reinstalling.

            File Registered OK: C:\Program Files\itcc.dll (Version: 4.72.7277.0)
            File Found: C:\WINDOWS\system32\hha.dll (Version: 4.74.8702.0)

            KeyHelp OCX by Keyworks.net - KeyHelp.ocx

                 Detecting KeyHelp.ocx by looking for the IKeyPopup interface
                 Registration Info: {1E57C6C4-B069-11D3-8D43-00104B138C8C}
                   Version = 1.1.2200.0
                   ClassName = KeyPopup Class
                   InProcServer32 = C:\WINDOWS\system32\Keyhelp.ocx
                   ProgID = KeyHelp.KeyPopup.1
                 Dll Found and Registered = YES

            For More Info See: http://keyworks.net/

            RoboHelp DLL by eHelp/Macromedia - HHActiveX.dll

                 Registration Info: {399CB6C4-7312-11D2-B4D9-00105A0422DF}
                   Version = 9.0.0.228
                   ClassName = HHComponentActivator Class
                   InProcServer32 = C:\Program Files\Adobe\Adobe RoboHelp 9\RoboHTML\HHActiveX.dll
                   ProgID = HHActiveX.HHComponentActivator.1
                 Dll Found and Registered = YES

            For More Info See: http://www.macromedia.com/

            MS Help 2 Run-time Components

                 *** MS Help 2 NOT installed on this PC
            • 3. Re: Search Tab in WebHelp Not Displaying Any Topics
              Captiv8r Adobe Community Professional & MVP

              Hi LaKisha

               

              Thanks for posting what the answer was. Hopefully it will help others down the road (assuming, of course, that we get the forums upgrade where search actually works).

               

              Just to note that the references to the dlls itss.dll and itircl.dll have nothing to do with WebHelp or the generating of WebHelp. Those are CHM specific.

               

              Cheers... Rick

               

               

              Helpful and Handy Links

              RoboHelp Wish Form/Bug Reporting Form

              Begin learning RoboHelp HTML 7, 8 or 9 within the day!

              Adobe Certified RoboHelp HTML Training

              SorcerStone Blog

              RoboHelp eBooks

              • 4. Re: Search Tab in WebHelp Not Displaying Any Topics
                LaKisha1 Level 1

                ahhhh, CHM-specific...OK, thanks