3 Replies Latest reply on Nov 9, 2012 2:28 PM by JeromyLewisCannon

    FlexUnit is working with FlashBuilder and not working with Build file

    pskamalnath

      Hi

       

      I have few flexunit test cases . When I am running those testcases from Flashbuilder FlexUnit plugin I am able to run all the testcases and when I run Build file to run those testcases , build file is launching my testrunner swf file and it is throwing follwoing  runtime error in flash player

       

       

      VerifyError: Error #1014: Class flash.events::NativeWindowBoundsEvent could not be found.

      at flash.display::MovieClip/nextFrame()

      at mx.managers::SystemManager/deferredNextFrame()

      at mx.managers::SystemManager/preloader_preloaderDocFrameReadyHandler()

      at flash.events::EventDispatcher/dispatchEventFunction()

      at flash.events::EventDispatcher/dispatchEvent()

      at mx.preloaders::Preloader/timerHandler()

      at flash.utils::Timer/_timerDispatch()

      at flash.utils::Timer/tick()

      here is the Build Console log
      [taskdef] Could not load definitions from resource flexTasks.tasks. It could not be found.
      test:
      [mxmlc] C:\Users\user\Documents\workspace\project\bin-debug\projectTestRunner.swf (1626331 bytes)
      [flexunit] Validating task attributes ...
      [flexunit] Generating default values ...
      [flexunit] Using the following settings for the test run:
      [flexunit] FLEX_HOME: [C:\Program Files\Adobe\Adobe Flash Builder for Force.com\sdks\4.5.1.21328]
      [flexunit] haltonfailure: [false]
      [flexunit] headless: [false]
      [flexunit] display: [99]
      [flexunit] localTrusted: [true]
      [flexunit] player: [flash]
      [flexunit] command: [C:\Program Files\Adobe\Adobe Flash Builder for Force.com\sdks\4.5.1.21328\runtimes\player\10.2\win\FlashPlayerDebugger.exe]
      [flexunit] port: [1024]
      [flexunit] swf: [C:\Users\user\Documents\workspace\project\bin-debug\projectTestRunner.swf]
      [flexunit] timeout: [60000ms]
      [flexunit] toDir: [C:\Users\user\Documents\workspace\project\report]
      [flexunit] Setting up server process ...
      [flexunit] Starting server ...
      [flexunit] Opening server socket on port [1024].
      [flexunit] Waiting for client connection ...
      [flexunit] Entry [C:\Users\user\Documents\workspace\project\bin-debug] already available in local trust file at [C:\Users\user\AppData\Roaming\Macromedia\Flash Player\#Security\FlashPlayerTrust\flexUnit.cfg].
      [flexunit] Executing 'C:\Program Files\Adobe\Adobe Flash Builder for Force.com\sdks\4.5.1.21328\runtimes\player\10.2\win\FlashPlayerDebugger.exe' with arguments:
      [flexunit] 'C:\Users\user\Documents\workspace\project\bin-debug\projectTestRunner.swf'
      [flexunit] The ' characters around the executable and arguments are
      [flexunit] not part of the command.
      [flexunit]
      [flexunit] Stopping server ...
      [flexunit] End of test data reached, sending acknowledgement to player ...
      [flexunit] Closing client connection ...
      [flexunit] Closing server on port [1024] ...
      BUILD FAILED
      C:\Users\user\Documents\workspace\project\build\build.xml:33: The following error occurred while executing this line:
      C:\Users\user\Documents\workspace\project\build\build.xml:175: java.util.concurrent.ExecutionException: Socket timeout waiting for flexunit report
      Many thanks for In advance for your help ..