5 Replies Latest reply on Jul 29, 2011 1:39 AM by John Hawkinson

    TOC Style Confusion

    Jack Level 1

      Some inscrutible force is interfering with the formatting of entries in my table of contents. I have defined unique styles for both the entry and the page number. When I update the TOC, the entry assumes the style of the title of the TOC, rather than the defined entry style.

       

      This is doubly strange, in that in my previous project, all aspects of the TOC behave quite normally.

       

      Know this is difficult to diagnose at a far remove, but any ideas would be welcomed.

        • 1. Re: TOC Style Confusion
          Peter Spier Most Valuable Participant (Moderator)

          The obvious first step is to be sure you really assigned the correct style to the listings.

           

          Assuming that's the case, one thing that will cause text not to look as you expect in a TOC is if character styles ot local formatting overrides have been applied to that text in the body of the document.

          • 2. Re: TOC Style Confusion
            Jack Level 1

            Thanks. Table of contents title has the style "TOC Title". Entry style is "TOC BodyText" and page number style is "TOC PgNr". Styles are not used elsewhere in the document, hence are not believed to have been overriden. The only paragraph style to be included is "Chapter Head", which is used only once so far in my document. Each new chapter will contain this heading. That is all that the TOC will contain; nothing else.

             

            Experimental changes in settings do not lead to expected results. Tried changing the entry style to "Page Number" (size 8 points). Nothing changes. Entry style remains the same as table title. If there has been an override, I have no idea where to look for it.

             

            Tried deleting and re-creating the table of contents. New table of contents is automatically formatted using exactly the same settings as the one just deleted.

            • 3. Re: TOC Style Confusion
              Peter Spier Most Valuable Participant (Moderator)

              The place to be looking for overrides is in the body of the document. your headings there should carry a paragraph style (required for inlusion in the TOC), but should not have any separately applied character styles or local overrides unless you want those overrrided to also appear in the TOC. Nested styles are OK.

               

              The other thing to check is that you are not applying some character style, in addition to the TOC listing paragraph style, in the listings. Many new users are confused about how to use character styles, especially if they have a background of Quark use. In ID character styles sshould be used ONLY to change the style of isolated special cases within a paragraph, not to style an entire paragraph. Basic text style for any paragraph is part of the paragraph style definition.

              1 person found this helpful
              • 4. Re: TOC Style Confusion
                Jack Level 1

                Thanks, and yes, I had defined some character styles, which I have now trashed. After some further updates, the TOC now appears normal.

                 

                BTW, FYI, my smtp mail responses to emailed copies of forum responses are being rejected by my server; reason given: " <clearspace-1722133726-170597-2-3825667@mail.forums.adobe.com> address unknown".

                 

                 

                Best,

                jwc

                • 5. Re: TOC Style Confusion
                  John Hawkinson Level 5
                  BTW, FYI, my smtp mail responses to emailed copies of forum responses are being rejected by my server; reason given: " <clearspace-1722133726-170597-2-3825667@mail.forums.adobe.com> address unknown".

                   

                   

                  Well, something is wrong with it (surprise!). That address is of the right sort, and the mail server certainly exists and works:

                   

                  ~> host -t mx mail.forums.adobe.com
                  mail.forums.adobe.com mail is handled by 10 mail.sgaur.hosted.jivesoftware.com.
                  ~> host mail.sgaur.hosted.jivesoftware.com.
                  mail.sgaur.hosted.jivesoftware.com has address 209.46.39.252
                  ~> telnet 209.46.39.252 25
                  Trying 209.46.39.252...
                  Encryption is verbose
                  Connected to mail.sgaur.hosted.jivesoftware.com (209.46.39.252).
                  Escape character is '^]'.
                  220 mail.sgaur.hosted.jivesoftware.com ESMTP Postfix
                  EHLO jhawk
                  250-mail.sgaur.hosted.jivesoftware.com
                  250-PIPELINING
                  250-SIZE 51200000
                  250-ETRN
                  250-ENHANCEDSTATUSCODES
                  250-8BITMIME
                  250 DSN
                  mail from: <>
                  250 2.1.0 Ok
                  rcpt to: <clearspace-1722133726-170597-2-3825667@mail.forums.adobe.com>
                  250 2.1.5 Ok
                  rset
                  250 2.0.0 Ok
                  QUIT
                  221 2.0.0 Bye
                  Connection closed by foreign host.