0 Replies Latest reply on Jul 29, 2011 2:01 PM by Jeffery Z

    I need Adobe Reader for an older Mac - OSX 10.4.11 (NOT intel)

    Jeffery Z

      I am trying to view bank statements online - they are in pdf form, and I cannot view them. The bank says I need Adobe Reader 9 or higher to view them, but I don't seem to be able to download it on my older operating system (Mac OSX 10.4.11 - NOT intel). Is there a file I can have sent to me that will help me update my current Adobe reader (7.0.5)? Or will I never get to view my statements on this computer? Help!