2 Replies Latest reply on Jul 10, 2012 5:51 AM by urbanapps

    Compile Errors After Upgrading to SDK 4.5!

    phaseblue Level 1

      Hello everyone,

       

      I am using Flash Builder version 4.0.0 and I just upgraded my SDK to 4.5.0 and I'm just getting the following 2 errors in a project, which I didn't get before installing the 4.5 SDK:

       

      1)  Can not resolve a multiname reference unambiguously. _class_embed_css_assets_black_start_icon_png_2045382513_738071692 (from _class_embed_css_assets_black_start_icon_png_2045382513_738071692) and components: _class_embed_css_assets_black_start_icon_png_2


      2)  Could not resolve <fx:FlexPaperViewer> to a component implementation.

       

      The first one is referring to an image stored in the "assets" directory which I use in a component.

      The second one is referring to a 3rd party component called FlexPaperViewer, which is used to view pdfs which have been converted to swfs.

       

      Any idea what might be causing this?  I hope the SDK hasn't changed so much that I have to recode the skin for the component in the first error.  As far as the second error, the FlexPaperViewer.swc is in the build path for the project.  This is very strange, but I don't know what to do to fix this!

       

      Thanks for any help or advice!

       

      Matt