4 Replies Latest reply on Aug 10, 2011 6:46 AM by cash75063

    VOB file is cutting short and audio doesn't match

    cash75063

      I am importing the files from a DVD.  There are two problems I am having.  The first is that the last file on the DVD is listed as being 2:45 long.

      When I pull it into Premiere and export it through AME, the length is short by about 15-20 seconds.

       

      The second problem is that as the files I've built plays, the audo is off by about qa minute or so by the end of the file.  I've played the files on the DVD, and the audio is in sync there.

       

      I've been rendering these out as H.264.  I thought maybe I could render them out as an uncompressed avi.  That seems to work, but them I get a file thats 234 gigs.  That takes up all my space on one of my hard drives.  Too large.  Is the problem with the sound possibly because it is a separate audio file?

      -Thanks

       

      PC 12gigs RAM


      -C

        • 1. Re: VOB file is cutting short and audio doesn't match
          Jim_Simon Level 8

          Despite PP's claimed compatibility with VOBs, I've never found it to work flawlessly with such.  I recommend conversion first.

           

          http://www.videohelp.com/tools/XviD4PSP

           

          DVD Convert.png

          • 2. Re: VOB file is cutting short and audio doesn't match
            Colin Brougham Level 6

            Shouldn't be any need to convert, but you may need to massage the video and audio streams a bit to get them to work. The following doesn't work with every broken MPEG2 file, but I've had a  pretty high rate of success with the following process (I'll assume  you're using Windows):

             

            1. Get ReJig and Restream (both are free and involve no installation).
            2. Open  ReJig, and click the File Mode button. Click the Add button, and then  the next Add button; navigate to and select your VOB file. Click Done.
            3. In  the "Stream List & Demuxing" pane, you'll see an MPEG Video Stream  and (probably) an AC3 Audio Stream; if the audio stream has an   "AudioDelay" tag, check the "Fix & Correct AC3 Delay" box.
            4. Select  the MPEG Video Stream, and click the Demux button; pick a save  location and file name, and hit Save. When the video is demuxed, do  the  same for the audio stream. When done, you can close ReJig.
            5. Sometimes  at this point, you can import the M2V file (that's the demuxed MPEG  Video Stream) into Premiere and the file will be correct; if so, just  import the AC3 file, sync-and-link them and edit away.
            6. If the file still shows the wrong duration, open Restream and load the demuxed M2V file into it.
            7. Under  the "Group of Pictures" section, check the "reset timestamps"  option;  this will usually fix the broken duration. Pick a save location  and  name (by default, Restream appends ".0" to the filename), and Save the  file. Try importing this file into Premiere and check its duration and  playback.

             

            You can mux the files together if you want, but I usually just import them separately and link them together in Premiere Pro. If you want to mux them, let me know and I'll add those details.

            • 3. Re: VOB file is cutting short and audio doesn't match
              cash75063 Level 1

              Giving this a try now.  I'll keep you posted-

              -C

              • 4. Re: VOB file is cutting short and audio doesn't match
                cash75063 Level 1

                This worked!  Aydio files are the correct length!

                Thanks-

                -C