9 Replies Latest reply on Aug 11, 2011 12:38 PM by jesmo71

    CUDA Drivers not loading properly after reboot - Mac

    jesmo71

      Mac Pro (2009)

      16Gb RAM

      OS X 10.6.8

      Quadro 4000 - Nvidia & CUDA drivers all current

       

       

      I'm  having problems with the CUDA drivers staying loaded after a reboot.  I  can install them and use hardware acceleration, but when I reboot and  open my project, it says hardware acceleration is not available and  switches to software mode.

       

       

      The NVIDA CUDA drivers are loaded in my System Prefs panel, and it even says "No new CUDA drivers available".

       

      If I reninstall them, the hardware acceleration works until I reboot. Any ideas?

       

      I posted this in the Hardware Discussion area, but I'm not 100% sure that was the right place. Maybe someone here has had some experience with this issue.

        • 1. Re: CUDA Drivers not loading properly after reboot - Mac
          RacerX2oo3 Level 1

          Jesmo,

           

          That's an unusal problem you're seeing.  I would recommend installing the latest Mac driver for the Quadro 4000 for Mac found here:http://www.nvidia.com/object/quadro-macosx-256.02.25f01-driver.html

           

          Once the drivers have been installed.  Go ahead and reinstall the CUDA drivers.  Then see if everything persists properly after a reboot.

           

          If not let me know and we can try to diagnose further.

           

          Sean Kilbride

          Technical Marketing, NVIDIA

          • 2. Re: CUDA Drivers not loading properly after reboot - Mac
            jesmo71 Level 1

            I'm already using this driver.

             

            Both are from Nvidia - The CUDA driver is the one that I'm having issues with.

             

            CUDA driver version: 4.0.31

            GPU Drvier version: 1.6.37.0 (256.02.25f01)

             

            This is persistent. I can install the CUDA driver. PPro will recognize it until I reboot. Next time I start PPro it says no Hardware acceleration, and switches to software only.

             

            Happens each time I re-install it.

             

             

            • 3. Re: CUDA Drivers not loading properly after reboot - Mac
              RacerX2oo3 Level 1

              Jesmo,

               

              The information on the CUDA driver and GPU driver, is that coming from the CUDA Preferences in the System Preferences?

               

              If so does the information change when Premiere complains that Hardware support isn't available?

               

              One thing you could try is to install the GPU Computing SDK and see if the CUDA samples run properly when Premiere complains about lack of CUDA support, my guess would be that they do and that Premiere is confused about the CUDA support, although I have to admit that I'm bewildered about why that would be the case.

               

              Sean

              • 4. Re: CUDA Drivers not loading properly after reboot - Mac
                jesmo71 Level 1

                RacerX2oo3 wrote:

                 

                Jesmo,

                 

                The information on the CUDA driver and GPU driver, is that coming from the CUDA Preferences in the System Preferences?

                 

                If so does the information change when Premiere complains that Hardware support isn't available?

                 

                Sean,

                 

                Yes this is from the System Prefs.  No, it does not change during the operation of Premiere.CUDA Grab.jpg

                 

                 


                 

                One thing you could try is to install the GPU Computing SDK and see if the CUDA samples run properly when Premiere complains about lack of CUDA support, my guess would be that they do and that Premiere is confused about the CUDA support, although I have to admit that I'm bewildered about why that would be the case.

                 

                Sean

                This is a little over my level of knowlege for this. What is the GPU Computing SDK, and where would I find it?

                 

                Thanks for your help with this.  This card has already cost me a few days. Upon original installation the logic board died, and had to be replaced by Apple. I also had them install the Quadro, since it was being difficult. Fortunately I paid for the Apple Care when I bought this machine, or this little upgrade would have cost me about $1200 more.

                • 5. Re: CUDA Drivers not loading properly after reboot - Mac
                  jesmo71 Level 1

                  JOY!   After spending some time on the phone with Adobe tech support, we were able to get to the "root" of the problem. Pun totally intended.

                   

                  The issue was occuring because, even though I was able to install the CUDA drivers as an administrator using my normal user account, the permissions were not correct. The simple solution was to enable the root user, and then log-in as the root, and install the CUDA drivers from there.

                   

                  Problem fixed.

                   

                   

                  I love it when things work!

                   

                   

                  Thanks for the help guys.

                  • 6. Re: CUDA Drivers not loading properly after reboot - Mac
                    jesmo71 Level 1

                    JOY!   After spending some time on the phone with Adobe tech support, we were able to get to the "root" of the problem. Pun totally intended.

                     

                    The issue was occuring because, even though I was able to install the CUDA drivers as an administrator using my normal user account, the permissions were not correct. The simple solution was to enable the root user, and then log-in as the root, and install the CUDA drivers from there.

                     

                    Problem fixed.

                     

                    I love it when things work!

                     

                    Thanks for the help guys.

                    • 7. Re: CUDA Drivers not loading properly after reboot - Mac
                      Todd_Kopriva Level 8

                      Thanks for writing back with what worked for you.

                      • 8. Re: CUDA Drivers not loading properly after reboot - Mac
                        cristtiah27

                        am having the same problem, can you tell me step by step how you fixed this! Am desperate! Thanks.

                        • 9. Re: CUDA Drivers not loading properly after reboot - Mac
                          jesmo71 Level 1

                          Go to your system hard drive.

                          > Select the System Folder

                          > Scroll down to Core Services

                          > Open Directory Utility

                          > You will probably have to hit the lock at the bottom, and type in the password

                          > Go to Edit (top of the screen on the menu bar)

                          > Select Enable Root User

                          > This should prompt you to create a password for the Root User

                          > After you enter the password, Lock the padlock icon at the bottom

                          > Close Directory Utility and reboot

                           

                          >Login using the new login. It will ask for username and password. Just use Root as username and the password you just set

                          > Once logged in, install the current CUDA driver version, and tell select "Install for all users of this machine" when prompted.

                          > After installation, reboot, restart PPro, and enjoy.