6 Replies Latest reply on Aug 12, 2011 11:50 PM by Peter Grainge

    RoboHelp HTML 9 - corrupt user-defined variable

    czaram Level 1

      I've been having problems most of the all day with RH crashing. I finally narrowed it down to a bad user defined variable that is in almost all of my pages. I've corrected the variable in the UDV pod, but RH still crashes anytime I try to open a topic that has that variable.  HELP!!!

       

      PS -- I think the problem was that I had applied a conditional tag to the variable. Just guessing.

        • 1. Re: RoboHelp HTML 9 - corrupt user-defined variable
          czaram Level 1

          You are out of luck if this happens to you. Adobe tech support had me delete the variable and all references to it. This is a fairly devastating solution for a variable that occurs on almost every page of out Help system.

           

          The darnest thing -- the variable was clean as could be in the rhvariable.apj file. Still the software would not work.

           

          Weirder still is that I haven't touch the var in days. It's embedded in a master page, so there's no need to bother with it.

           

          Has anyone else had a similar problem?  I am nervous and wondering about the reliability of RH user defined variables.

          • 2. Re: RoboHelp HTML 9 - corrupt user-defined variable
            Peter Grainge Adobe Community Professional

            Did they getting you to try deleting the CPD first? Doubtful it would make a difference but it is always the first thing to try when behaviour is wrong.

             

            Generally variables work fine so without seeing the rogue project, it's difficult to comment. What I am a bit puzzled about is you are now saying it is in the master page. Earlier you said it was in every topic. So it appears twice or it is only in the master page?

             

            Do you not backup daily to avoid catastrophic loss?

             


            See www.grainge.org for RoboHelp and Authoring tips

             

            @petergrainge

            • 3. Re: RoboHelp HTML 9 - corrupt user-defined variable
              czaram Level 1

              Hi Peter,

              No, Adobe did not suggest deleting CPD. I had tried it before calling them and it didn’t resolve the issue.

               

              Regarding my setup. I have the variable in a master page. So every topic based on that master page also has the variable. Which is just about every topic(page).

               

              I've had RH freeze on me three times today when resizing the floating UDV panel. Very buggy. I now have it just docked at the bottom. I'll see if that helps.

              I am now trying to back up more than once a day. Crazy.

               

              I've worked with a lot of Adobe products (mostly Flash and DW) and have to say RH seems like the ugly stepchild!

               

               

              • 4. Re: RoboHelp HTML 9 - corrupt user-defined variable
                Peter Grainge Adobe Community Professional

                I can understand your frustration but what you are experiencing is not normal.

                 

                I haven't asked but I hope Support did, is your project on your local drive?

                 

                Is the variable just plain text?

                 

                Do you have some time to play around with the supplied sample projects to see if you hit the same problem? Click Open on the RoboHelp Starter page and then click Samples in the ribbon on the left.

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                @petergrainge

                • 5. Re: RoboHelp HTML 9 - corrupt user-defined variable
                  czaram Level 1

                  Well, I agree it does not seem "normal."

                   

                  Yes, my project is on my local hard drive.

                   

                  Some of my variables are plain text; some are not. Snippets aren't appropriate since those create a div, and I need vars to appear "in line" with the rest of the text.

                   

                  I did spend some time playing with the samples and feel comfortable with using the software.  Well, except that I am backing up my work 2-3 times a day. Absurd.

                  • 6. Re: RoboHelp HTML 9 - corrupt user-defined variable
                    Peter Grainge Adobe Community Professional

                    My point about the samples was did you hit the same problem with them?

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                    @petergrainge