5 Replies Latest reply on Aug 13, 2011 8:58 AM by Aeschylus123123



      I'm using InDesign CS4. Using find and replace, I've changed all language codes within a document to English UK. Autocorrect is enabled and set to use English UK, but won't work.


      Can anyone explain how to get Autocorrect to work?

        • 1. Re: Auto-incorrect
          Peter Spier Most Valuable Participant (Moderator)

          What do you mean, "won't work"?


          I.m not a user of autocorrect, but my understanding of the functionality is that it only corrects words in the autocorrect list, and only as you are typing them. I don't believe it will retroactively change something or correct text you are placing or pasting.

          • 2. Re: Auto-incorrect
            Aeschylus123123 Level 1

            In the AutoCorrect list, I've set up 'aln' to be converted to 'alternatively'. When I type in 'aln' and press Return or space, nothing happens...


            No other Autocorrect entries work, either.

            • 3. Re: Auto-incorrect
              Peter Spier Most Valuable Participant (Moderator)

              Had a similar post this week about Autocorrect not working in Greek, but I think that was CS5.


              Is this probem in all files, i.e. it happens in every new file you create as well as in existing files you open, only in new files (old files still work), only old files, or only specific files?


              Does it work if you set the language to US English?

              • 4. Re: Auto-incorrect
                Aeschylus123123 Level 1

                The problem occurs in all files, and on two separate computers.


                However, setting the language to English USA does appear to make AutoCorrect work. But I need UK, not USA...

                • 5. Re: Auto-incorrect
                  Peter Spier Most Valuable Participant (Moderator)

                  I'm thinking this might actually be a bug, and it may be present in several, or all, versions. Working in US English, but not other languages is not a good sign.


                  There might be support files in a en_US folder that could be copied to a en_UK folder, or renaming the folder to US might work, if we knew which one, but I don't. That trick worked on missing help a couple of years back.