3 Replies Latest reply on Sep 22, 2011 8:24 AM by Jose Galdamez

    Losing Subversion Control

    Perlguy999

      I am working with the latest ColdFusion Builder on a Mac, with our project under subversion control.  I am not having any issues.

       

      My co-worker, is using the latest ColdFusion Builder on a Windows box and he is having problem after problem.

       

      He can create the new project, pulling it from the subversion server no problem.  However, seemingly intermittently, some of his files, or the entire project lose their version control.

       

      We've tried pulling it down again from subversion and it works for a bit, but then it happens again.

       

      This is extremely frustrating and wasting a lot of time.

       

      Has anyone else experienced this, and solved it?

       

      What can we do to fix this?

       

      Thank you.

        • 1. Re: Losing Subversion Control
          Jose Galdamez

          I have been having intermittent problems with Subclipse in ColdFusion Builder 2 on Windows XP. I still see the Subversion options under the Team sub-menu, but the version control information comes and goes.

           

          When the CFB2 starts up the Subclipse icons show for the root level folders but for none of the folders/files underneath. If I close the project and re-open it all the Subclipse icons go away.

           

          I didn't have this problem in ColdFusion Builder 1 originally, but now even CFB 1 is missing the icons.

           

          I'm guessing my SVN folders are corrupt.

          • 2. Re: Losing Subversion Control
            wallyrandall

            I was using the Subversive plugin which worked fine until this week.  I uninstalled it and installed the Subclipse client instead and it too cannot recognize the subversion projects.

             

            I then recalled that I had updated the Tortoise SVN client this week.  In researching this problem I came across an old issue between these clients where Tortoise made changes the SVN files that were not recognized by Subversive and this caused the Subversive client to fail.

             

            I suspect that the latest Tortoise release is not playing well with the ecplipse plugins.  Does anyone else have experience with this or other suggestions.

            • 3. Re: Losing Subversion Control
              Jose Galdamez Level 1

              Wally,

               

              At work my team is using TortoiseSVN 1.6.5 on Windows XP. I upgraded to 1.7.0 and started noticing a lot of problems over the last couple of days. Even though I only do my commits using Subclipse, something went awry and I started losing SVN information one project at a time. My Subclipse was hosed and so were all my icon overlays in Windows explorer.

               

              I tried multiple times to check out folders using 1.7.0 but nothing worked. Fortunately, we had the original MSI for TortoiseSVN 1.6.5 and downgrading was able to get me back to where I was earlier in the week.

               

              If you are using ColdFusion Builder/Eclipse with Subclipse my recommendation would be to not upgrade to TortoiseSVN 1.7.0.

               

              Jose