3 Replies Latest reply on Aug 18, 2011 5:38 AM by Anirudh Sasikumar

    Running debug on Device

    MikePotratz Level 1

      Flash Builder 4.5.1 Standard

      Windows 7 Ultimate & Home Premium

      Latest AIR 2.7.0.19530 on all devices

      Viewsonic GTablet, Android 2.3.3 Gingerbread

       

      Been developing an app for quite awhile and running the app on my tablet with no issues.  Then last week I updated AIR on on my devices (including the tablet) to the latest version.

       

      Now, when I select 'run on device' it compiles, installs the xxxxx-debug file on the tablet.  BUT as soon as it tries to run it I get an AIR error.  If I disconnect the USB and try to run the newly installed '-debug' file it errors out again and again.  BUT, if I reboot the tablet then all is fine in the world.  The debug file runs just fine.

       

      The only difference in my setup is the new AIR file cause the problems started right after I updated.

       

      I am open to any and all suggestions on what the heck to do about this.

        • 1. Re: Running debug on Device
          Anirudh Sasikumar Adobe Employee

          Can you post the exact error message shown on the tablet when running the app?

           

          Also, can you check if updating to AIR SDK 2.7 helps?

           

          To upgrade:

           

          1. Get the AIR SDK: http://www.adobe.com/products/air/sdk/.

           

          2. Make a backup your existing 4.5.1 SDK, it is usually found here: C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\sdks\4.5.1.


          3. Unzip the new AIR SDK  over the 4.5.1 SDK at the above path.

           

          (If you're on a mac, you'll have to merge the new AIR sdk over 4.5.1 SDK via the command line)

           

          • 2. Re: Running debug on Device
            MikePotratz Level 1

            Updating the SDK fixed the problem, and introduced another....

             

            When I "run on device", the build & install process runs.  Flash Builder then pops up an alert telling me:

            FB_upgrade_alert.jpg

            The problem is I just updated AIR on the tablet (8/17/2011, 9am Central time) and the latest version available is 2.7.1.1961 (Amazon App Store - no Google Marketplace access with the tablet)...

             

            If I select "Yes", the program compiles, installs and runs correctly on the tablet.  If I select "No", then I get this error on the tablet:  "The application Adobe AIR (process com.adobe.air) has stopped unexpectedly.  Please try again." with a "Force Close" button as the only option.  Clicking the FC button brings the same error message up again.  After the second click on the FC button, the screen goes black.  I then can hit the Home button to get back to my main screen.

             

            Then, like I originally posted, if I try to run the "xxxx-debug" file I get the same error messages and force closures.  But, if I reboot the tablet and then run the "xxxxx-debug" file which was installed, it works just fine.  No errors, no force closures.  AND it still only has AIR V2.7.1.1961 installed on the tablet.

             

            IF - the lack of upgrade process is because of lack of access to the Google Marketplace, then where can I get the V2.7.1.40 version of the AIR.apk to install on my tablet?  Next - if this is the case with all tablets without marketplace access, how do I include that with my project?  Or do I have to since it works just fine with the 2.7.1.1961 version????????

            • 3. Re: Running debug on Device
              Anirudh Sasikumar Adobe Employee

              Thank you for the detailed write-up.

               

              We're going to check this at our end, but to me it seems like that AIR version is unhappy with debug builds.

               

              Meanwhile, as a workaround, you may want to try uninstalling AIR and depending only on the one that gets installed from AIR 2.7 SDK (Till we figure things out).

               

              -Anirudh