15 Replies Latest reply on Oct 9, 2011 3:34 PM by beckynbart

    Problem with thumbnails in Bridge CS4

    beckynbart Level 1

      I was having a problem with Adobe Bridge crashing on me when I was looking at a large amount of images - like all my 2011 images. I'd read online that I needed to purge my cache and delete my preferences by holding down the ctrl key when starting Bridge and choosing all three options to "reset preferences", "purge entire thumbnail cache" and "reset standard workspace".

       

      I did this, but it really did not solve my problem. I'm still working on that. It did create a problem that all my raw files show up without thumbnails, and I can't for the life of me figure out how to regenerate these thumbnails. I've tried downloading the camera raw plugin and installing that again and it does not help.

       

      My raw files are from a Pentax K100d and are pef files.

       

      I went back to some old photos, in my 2010 folder.  When it first came up it showed the thumbnail for just a brief moment.  It then went blank and then up popped that stupid little flower icon that I seen when there is no thumbnail.

       

      Any help would be appreciated.

        • 1. Re: Problem with thumbnails in Bridge CS4
          beckynbart Level 1

          Any ideas??

           

          I've tried everything that I've found online and just can't get the thumbnails back.

           

          Should I reinstall Bridge?  Will that help?  Do I need to uninstall first?  I'm scarred to make this worse.

          • 2. Re: Problem with thumbnails in Bridge CS4
            Jeff Schewe Level 5

            Raw files need Camera Raw properly installed to render previews...sounds like your Camera Raw isn't properly installed...what version of Camera Raw do you have installed? What OS? Can you open the raw files into Photoshop CS4?

            1 person found this helpful
            • 3. Re: Problem with thumbnails in Bridge CS4
              beckynbart Level 1

              Thank you so much for your response.

               

              I am running 64 bit Vista. I have CS4 and found that the latest version of Camera Raw that I could install was version 5.7.  I found the install instructions on the Adobe site.  As it told me to do, I downloaded the zip file for version 5.7 and extracted.  I moved the Camera Raw.8bi file from the top directory into C:\Program Files (x86)\Common Files\Adobe\Plug-Ins\CS4\File Formats and moved the Camera Raw.8bi file from the Win64 folder into C:\Program Files\Common Files\Adobe\Plug-Ins\CS4\File Formats.

               

              Does this look right to you?

               

              I can double-click on any of my raw "pef" files and I can edit them in Camera Raw, no problem.  I can also look at the "about Camera Raw" and see that it shows version 5.7.

               

              It just won't generate thumbnails.

               

              This worked in the past.  What happened to mess things up is a long story.  I got a new camera, a Nikon D5100.  What I did not realize was that this camera was too new for CS4 to be able to recognize.  The updates that include this camera are only for CS5.  At some point after I got this camera and came home with a ton of vacation pictures - saved as Raw + Jpg (so I had a ton of photos) bridge started crashing.  I don't know if it was the size and or number of photos that I was trying to have visible in Bridge at one time or what.  I started Goggling what could be the problem.  I found one source say that I needed to reset the preferences and such and that I should start Bridge while holding the ctrl key and choose all three items to reset.  I did this and my thumbnails that were there for all my old photos shot with my Pentax k100d went away.  I just see a flower icon in their place.  I've not been able to get them back.  I have since moved all those big photo files to another folder and the crashing has stopped.  Now I just have the problem that I caused.

               

              What bothers me is that I saw a post here in this forum that says to never use the "purge cache" option from the edit > preferences box in Bridge.  I can't find this post again.  I have done this also before I saw that.  I have also moved my cache to another location so that it had to create a new one. Still this does not work.  I've restarted Bridge, rebooted, "purged the cache for the selection" and "generate high quality thumbnail".  Nothing I've tried works.

               

              Would reinstalling Bridge help?  Do I have to install all of Photoshop?  Do I have to uninstall first?

              • 4. Re: Problem with thumbnails in Bridge CS4
                beckynbart Level 1

                I also found the 5.7 Camera Raw installer and ran that.  I am still having the same problem.

                • 5. Re: Problem with thumbnails in Bridge CS4
                  Noel Carboni Level 7

                  Try out the options when you do the "Adobe 3 finger salute"...

                   

                  Press and hold Control - Shift - Alt when cold-starting Bridge from its menu item or shortcut.  If you're quick enough, it'll prompt you with this dialog:

                   

                  BridgePrefsReset.jpg

                   

                  I'd probably start with trying the Purge Entire Thumbnail Cache option then see if it generates thumbnails for you.

                   

                  Your camera IS one of the ones supported by Camera Raw 5.7, right?  Just double-checking.  Edit:  Answered my own question - yes, it's listed in the set of supported cameras for 5.7.

                   

                  -Noel

                  • 6. Re: Problem with thumbnails in Bridge CS4
                    beckynbart Level 1

                    Thanks so much for replying.  I think that is what I did to get myself in trouble in the first place.  I have tried that several times since and again just a few minutes ago and that did not help either.

                    • 7. Re: Problem with thumbnails in Bridge CS4
                      Noel Carboni Level 7

                      Ah, sorry about the circular advice, then.  I didn't read your original post carefully enough.

                       

                      I wonder if it is possible that perhaps there's an extra (outdated) copy of the Camera Raw plug-in somewhere on your system that's being picked up by Bridge instead of the one that knows about your camera...

                       

                      Here's a way to check:

                       

                      1.  Start a CMD window using Run As Administrator (on Vista or newer).

                      2.  Type the following command exactly as shown then press Enter:

                       

                      dir  "c:\Camera Raw.8bi"  /s

                       

                      The command may run for several minutes, as it's looking throughout your entire hard drive for Camera Raw plug-ins.  When it's done, note all the locations it has found copies of the plug-in.

                       

                      With Photoshop CS4, the locations in which you should normally expect to see copies are:

                       

                      Directory of c:\Program Files\Common Files\Adobe\Plug-Ins\CS4\File Formats

                      04/04/2011  02:02 PM        14,228,432 Camera Raw.8bi

                       

                      Directory of c:\Program Files (x86)\Common Files\Adobe\Plug-Ins\CS4\File Formats

                      04/04/2011  02:02 PM        11,632,592 Camera Raw.8bi

                       

                       

                      -Noel

                      • 8. Re: Problem with thumbnails in Bridge CS4
                        beckynbart Level 1

                        Thank you very much for replying

                         

                        Looks like I have the two versions that are associated with CS4 and two that are associated with an old version of Photoshop Elements that i used to use.  They are not new.

                         

                        Volume in drive C has no label.

                        Volume Serial Number is AC76-58A7

                         

                        Directory of C:\Program Files\Common Files\Adobe\Plug-Ins\CS4\File Formats

                         

                        08/20/2011  05:58 PM        14,228,432 Camera Raw.8bi

                                       1 File(s)     14,228,432 bytes

                         

                        Directory of C:\Program Files (x86)\Adobe\Photoshop Elements 5.0\Plug-Ins\File Formats

                         

                        07/02/2009  08:53 PM        10,379,264 Camera Raw.8bi

                                       1 File(s)     10,379,264 bytes

                         

                        Directory of C:\Program Files (x86)\Adobe\Photoshop Elements 5.0\Plug-Ins\File Formats\save

                         

                        09/14/2006  07:56 AM         5,337,088 Camera Raw.8bi

                                       1 File(s)      5,337,088 bytes

                         

                        Directory of C:\Program Files (x86)\Common Files\Adobe\Plug-Ins\CS4\File Formats

                         

                        08/20/2011  05:57 PM        11,632,592 Camera Raw.8bi

                                       1 File(s)     11,632,592 bytes

                         

                             Total Files Listed:

                                       4 File(s)     41,577,376 bytes

                        • 9. Re: Problem with thumbnails in Bridge CS4
                          Noel Carboni Level 7

                          Well, unless somehow one of those other folders is in your path, having the wrong version of Camera Raw doesn't seem to be the issue.

                           

                          It wouldn't hurt to start Bridge, then go into Edit - Preferences, and check to see what version of Photoshop is associated with Pentax Camera Raw (.pef) files.

                           

                          -Noel

                          • 10. Re: Problem with thumbnails in Bridge CS4
                            beckynbart Level 1

                            If I look at Preferences > File Type Association, I see that Pentax Camera Raw (.pef) is associated with Adobe Photoshop CS4.

                             

                            I've tried to think what may have happened to cause all this.  I did get a new camera recently. It is a Nikon 5100.  There is no version of camera raw for CS4 that will work with its raw files. I did not notice this at first (about a month ago) and tried to run an update with a camera raw version that would only work with CS5.  It looked like the update tried to work and then gave me a message that the version was wrong.  I wonder if it might have done something first. This might have messed up my Bridge and when I purged the cache to try and fix the problem with Bridge crashing, it just could not rebuild it.  I kind of think that the Bridge crashing problem was because I was trying to look at too many files at once.  I had selected show files from subfolders in my 2011 folder.  Since the new camera takes much larger photos, I think I might have been trying to look at too much.  Since not looking at so many files at once, I have not had any crashing problems.

                             

                            I wonder if I should just reinstall Photoshop.  I'm just scared to make the situation worse.

                            • 11. Re: Problem with thumbnails in Bridge CS4
                              Noel Carboni Level 7

                              Outside of installing the wrong version somewhere it's hard to imagine how just trying to install a Camera Raw update that can't go in should have messed anything up, but I don't have your environment to test with (I have CS5), so I'm guessing a little here.

                               

                              Have you tried any other raw file types (e.g., download a .CR2 from the web or something)...  It would be interesting to know whether it works for that file type.  It could be a bug with .PEF format, specifically.

                               

                              -Noel

                              • 12. Re: Problem with thumbnails in Bridge CS4
                                beckynbart Level 1

                                You are so nice to keep helping me.

                                 

                                I did download a nef file from a D40 camera that I found online.  It shows a different icon in bridge, but does not show a thumbnail.  I can open that D40 file in camera raw and edit it so I know it is a good file.

                                 

                                I will mention that when I look at the directory in windows explorer, I see thumbnails for the pef files as well as the jpg files.  I just don't see thumbnails in Bridge.  I don't see thumbnails in explorer for the nef file.

                                • 13. Re: Problem with thumbnails in Bridge CS4
                                  Level 4

                                  Do not rely on the global Purge Cache command.

                                   

                                  In Bridge, go to Tools > Cache… and purge the cache for the offending folder(s)—one by one.

                                   

                                   

                                  ____________

                                  Wo Tai Lao Le

                                  我太老了

                                  • 14. Re: Problem with thumbnails in Bridge CS4
                                    beckynbart Level 1

                                    Tai Lao wrote:

                                     

                                    Do not rely on the global Purge Cache command.

                                     

                                    In Bridge, go to Tools > Cache… and purge the cache for the offending folder(s)—one by one.

                                     

                                     

                                     

                                    ____________

                                    Wo Tai Lao Le

                                    我太老了

                                     

                                    Thanks.

                                     

                                    I have tried this and every way that I can think of to purge the cache.

                                    • 15. Re: Problem with thumbnails in Bridge CS4
                                      beckynbart Level 1

                                      After trying everything that I could possibly think of and everything that was suggested I gave up.  I backed up my data, reformatted my hard drive and reinstalled Windows Vista.  I've finally gone through all the Windows updates and reinstalled most of my software that I actually use - it is nice to pare down. I reinstalled Photoshop and checked my thumbnails.  I am again seeing thumbnails for my (Pentax K100d) PEF files.  I updated my camera raw to version 5.7 and things are still fine.  I only see icons for my (Nikon 5100) NEF files, which is to be expected. I am back to where I was before I messed things up.

                                       

                                      Thanks to everyone who offered help.