3 Replies Latest reply on Dec 12, 2012 9:33 AM by Veni, Vidi, Scripsit

    jfserver.ini not being updated in Win2008\Central 5.7

    21730023687244 Level 1

      Hello, I have a fresh VM install of Adobe Output 5.7 on Win 2008 Ent R2 64bit.

      When I make changes to the settings in 'Configuration' - 'Configure Central and Agents' - 'Central Process" - 'File Locations' the changes are not reflected in the jfserver.ini file in that instance.

      Does anyone know why that would be?

        • 1. Re: jfserver.ini not being updated in Win2008\Central 5.7
          Paul.Triffitt Level 1

          I think I saw something similar recently doing an install for a customer.  I didnt get to the bottom of it, but I

          thought it was due to security settings in W2008 - i'd check the security permissions on the .ini files in general to see if you spot anything unusual.  The users involved with Central that could be conflicting are a) the account used for the install, b) the account running the windows service, and c) the account you logged in with to do the admin.




          • 2. Re: jfserver.ini not being updated in Win2008\Central 5.7

            I had the same issue on Windows 2008 server but I was trying to version Central version 5.6. I had to run the application as administrator which allowed me to modify the different configurations.

            • 3. Re: jfserver.ini not being updated in Win2008\Central 5.7
              Veni, Vidi, Scripsit

              Yeah, this is old, but I have just gone through this.


              Specifically the bug, err, feature here in 2008 Server R2 is UAC, User Account Control.  Any admin account that isn't the built in one is locked from making changes to the filesystem.  So if you are either in Output Server making configuration changes, or manually editing j*****.ini, you cannot save changes.  The app will act like you made a change, but when your run, or go back in the change is gone.  You cannot physically save changes to the .ini file you have open.


              The issue, background, etc, is located here:           http://support.microsoft.com/kb/2526083


              The fix is to disable part of it temporarily, or the entire UAC depending on how you use your servers.


              Disable "Admin Approval Mode" in UAC for the administrators group. For the Built-in Administrator account it is disabled by default, but enabled for the administrators group.

              • Start > Administrative Tools > Local Security Policy > Local Policies > Security Options.
              • Then find (third from the bottom) "User Account Control: Run all administrators in Admin Approval Mode", right-click, properties, Disable.

              You can see it disabled for the Built-in Admin account a few above (10 from bottom).


              In regards to permanently disabling, read the KB article, you will see why they implemented it, and when they consider it a hindrance.