5 Replies Latest reply on Oct 23, 2012 4:35 AM by Stavros F.

    Does PRE9 work with Mac OS X Lion?

    Stavros F.

      Does anyone use, together, Mac OS X Lion and Adobe Premiere Elements 9? Do they work well together? I am using Mac OS X Snow Leopard and Adobe Premiere Elements 9, and I am thinking of making the upgrade from Snow Leopard to Lion, but since in the webpage http://www.adobe.com/products/premiereel/systemreqs/ mentions "Mac OS X v10.5.8 through v10.6" (on 2011-08-25, 08:25 Greek-time) I was wondering if the work well together.