5 Replies Latest reply on Feb 7, 2012 4:31 AM by Dee McDee

    New patch, new bug

    Adam-C Level 2

      Hi all


      Having had a bunch of clients on my back for a month demanding I deliver Lion compatibility in my Director-based products, I was much relieved when Adobe released the 11.5.9 patch that fixes the embedded font bug under Lion (whereby embedded fonts were ignored). So imagine my frustration when I then discovered that this patch has knocked all of my Flash-based FLV video playback objects to hell - they won't work under and OS!!


      I'm using embedded SWF objects as video players; These objects contain a standard FLV playback component and a bunch of Actionscript (AS2) for loading and controlling videos, and for communicating back-and-forth with Director. Director passes a "file:///" URL location for the video (they're always on the local file system), and the SWF loads attaches this URL to the FLV Playback component.


      This arrangement has served me well for years, and worked just fine in 11.5.8, but under 11.5.9 my players can't connect to the files I specify.


      Initially I thought the problem may be that I was using AS2, so I did a quick AS3 test and encountered the exact same problem. So I worked the problem some more and discovered that if the video was located at the same path-level as the Director movie or a subpath thereof then the player would happily load these videos so long as I provided a relative URL. However, it won't load videos from absolute URLs (even if the videos are within Director's _movie.path), and won't load movies from relative URLs which use back-step navigation (I.E. "../aDifferentPath").


      "Ah-ha" I thought "something to do with sandbox security perhaps", but all the Flash security settings are as expected, and Director's Flash player's sandbox type is "localTrusted" as one would expect.


      To add insult to injury, the hopeless and not-updated-for-years Director section of Adobe's support site doesn't provide links to download earlier hotfixes, so I can't even roll-back my installation to 11.5.8 and tell my clients that Lion compatibility is a no-no for the time being.


      I'm at a loss - any help or suggestions much appreciated.


      (I can provide a bare-bones movie that demonstrates the problem if anyone wants to get their teeth into this one...)


      Thanks all!