1 Reply Latest reply on Sep 1, 2011 7:12 AM by AnayRaj

    Disable the confirmation dialog "This document is trying to access the following database"

    AnayRaj

      Hello Everyone,


      I have a adobe form developed in Adobe LiveCycle ES 8.2 and Adobe reader 8.1. The form is accessing a MDB database and populating some field on load. It is using OLEDB data source for accessing the MDB database.

       

      Whenever I am opening my form, it is prompting a pop up to allow access of the database saying "This document is trying to access the following database:" then there is info about my Data Connection. It ask you to "Do you want to allow this access?" yes or no.

       

      Does anyone know how to stop the prompt.


      I could just click yes and tick remember this choice. But that will work for me and annoy other users. Some of my form are having more than one data connection and the message prompts once for each connection. It is very annoying for end user.

       


      Is there something I have to set in form to not show warnings or this warning in particular?

       

      Thanks,

      Anay

        • 1. Re: Disable the confirmation dialog "This document is trying to access the following database"
          AnayRaj Level 1

          Hello Everyone,

           

          I am adding some finding which may help anyone out there to get a perfect resolution of the above issue.

           

          While doing research I found out that Adobe generates a file called DBConnects.sav inside "C:\Documents and Settings\.....\Application Data\Adobe\Acrobat\8.0" which remebers the data connection. If I am making an entry of my data connection (eg. Provider=MSDASQL;Persist Security Info=False;Data Source=eDocMDB;) in this file then for all the forms which are having the same data connection is not asking any confirmation for allowing the data connection. Adobe made the same entry even If you check the checkbox "Remeber this choice" in the database confirmation dialog.

           

          Now the problem which I am facing is for Adobe Reader 9.4 version. Adobe 9.4 is also making an entry in DBConnects.sav file but now it is form dependent. It is appending an unique string before the actual data connection string. It is making an entry like "9805AD51FFFF1FFF0A002FF1FFE03028, Provider=MSDASQL;Persist Security Info=False;Data Source=eDocMDB;" in DBConnect.sav. Now even the other form is also using the same connection string, it is asking me to allow the connection at least once for each form. If I checking the remember choice at least once for each connection of each form, it works fine. Myforms are dynamic and they change everyday for every user.

           

          Please let me know if any one is having any idea so that Adobe 9.4 do not append the unique string before makning entry into DBConnects.sav.

           

          Thanks,

          Anay