1 2 Previous Next 46 Replies Latest reply on Oct 13, 2016 10:00 PM by its_byron

    Cross Dissolve NOT Smooth

    DanielFrick

      I've been having this issue since I first started with Premiere Pro (cs5) and it has kept me from using any dissolve transitions or the program altogether:

       

      Dissolve transitions (specifically Cross Dissolve) will not end smoothly - there is always a jump at the last, seemingly, 10% or so of the transition. In other words, the dissolve goes from 100% opacity to 10% opacity of the previous clip. This is not a result of me having set those parameters in the effects controls. As well, it is not a playback quality/speed issue as you can advance frame by frame and see the problem. It also shows up in all timeline renders and final exports.

       

      I've been hard pressed to find an answer anywhere. I had come across an OLD Creative Cow post with what I thought was my identical problem. In that thread it mentioned manually adjusting opacity keyframes with bezier controls. That was not the solution and the thread was left answer-less. It is a very noticeable difference in dissolve smoothness compared to After Effects or Final Cut and is not professional-looking.

       

      Extending the length of the dissolve is no fix either. The problem persists in both Hardware Accelerated Mercury Extreme playback AND Software-Only settings. However, I have found intermittent success with Software-Only. BUT, that's kind of useless as editing without the Hardware Acceleration is a much larger step backward (absolutely a must when working with RED footage, DSLR or higher bitrate/resolution material).

       

      I pray someone has had this issue too and can shed some light on a solution.

       

      Some of my specs:

       

      8 Core 2.8Ghz Xeon Mac Pro (early 2008 - 3,1)

       

      12GB Ram

       

      Geforce GTX 285 Mac Edition

       

      RAID for video (there is no bottle neck here)

       

      OSX 10.6.8

       

      Premiere Pro CS5

       

       

      Thanks for your time!

        • 1. Re: Cross Dissolve NOT Smooth
          SFL46 Level 3

          Have you tried rendering a agement to see if the problem carries over to the export?  The preview monitor is not the best way to judge.

          • 2. Re: Cross Dissolve NOT Smooth
            the_wine_snob Level 9

            Just to rule this out, am I correct, that you have adequate Handles for the Dissolves? The only reason that I ask, is that depending on what the first Frames of the next scene, can appear, if the Handles are not quite long enough. This is NOT an Opacity issue, which is what your sounds like, but lack of Handles can cause a little glitch, right at the end of a Dissolve. Again, this is just to rule that out as a possibility.

             

            Good luck,

             

            Hunt

             

            PS - there was an Opacity Bug (was that CS 3, or CS 4?), where just adding an Opacity Keyframe (though not making any change - just adding that Keyframe) fixed the issue. Had not heard of that in CS 5 / 5.5.

            • 3. Re: Cross Dissolve NOT Smooth
              DanielFrick Level 1

              Hi,

               

              @SFL46:

               

              Thanks for your response. Yes, this issue appears in final renders. Here is a link for an old video where you can see the un-smoothness at work. The jumps in the last 10%ish of dissolves are not a streaming issue (just FYI) - they are in my un-web-compressed versions too. I'll try getting a more recent clip up on my server for anyone to have a gander at.

               

              http://vimeo.com/14536285

               

               

              @Bill Hunt

               

              Thanks for hoping in on this thread! Yes, I have adequate handles on clips with the dissolve. You can see on the video above that it even happens when fading text.

               

               

              Thanks!

              • 4. Re: Cross Dissolve NOT Smooth
                Colin Brougham Level 6

                The only solution is to not use hardware MPE (GPU acceleration), and while rendering/exporting with software mode, be sure you don't use Maximum Render Quality. Both scenarios enable 32-bit linear color, which results in the stepwise dissolves (along with other issues) that you're seeing.

                • 5. Re: Cross Dissolve NOT Smooth
                  DanielFrick Level 1

                  Thanks Colin,

                   

                  It's a shame that the solution is a work-around. Thanks a lot for your input. I didn't know that the color space is altered and is affecting something like dissolves. I'll definitely be using this method in the meantime.

                   

                   

                  I'm still open to any other ideas for fixes people may have!

                  • 6. Re: Cross Dissolve NOT Smooth
                    the_wine_snob Level 9

                    Daniel,

                     

                    I assumed that you did, but wanted to get rid of that possibility early on.

                     

                    I'll be reading this thread, as I think I might learn something too.

                     

                    Good luck,

                     

                    Hunt

                    • 7. Re: Cross Dissolve NOT Smooth
                      Colin Brougham Level 6

                      It's not a workaround. That's just The Way It Is. There are no other solutions to this in Premiere Pro CS5 and beyond.

                       

                      A feature request for more flexibility in deciding what is processed in linear color while still maintaining the other benefits of hardware MPE/GPU acceleration may eventually pay dividends, but for now, this is what we're forced to accept.

                       

                      Ask for it here: Adobe Feature Request/Bug Report Form

                      • 8. Re: Cross Dissolve NOT Smooth
                        DMH79 Level 2

                        DanielFrick wrote:

                         

                        I've been having this issue since I first started with Premiere Pro (cs5) and it has kept me from using any dissolve transitions or the program altogether:

                         

                        Dissolve transitions (specifically Cross Dissolve) will not end smoothly - there is always a jump at the last, seemingly, 10% or so of the transition.

                         

                        Okay so I realize this thread is old, but I can't stand how normal cross dissolves (I tend to keyframe all opacity changes) have this unsmooth/abrupt start/finish.

                         

                        His video in the original post is exactly what I was experiencing all weekend. Coming from FCP, the same basic cross dissolve is smooth with no jumps. I ended up going into every single one of the disolves and selecting EASE IN and EASE OUT for each and every opacity keyframe. With a huge project and tons of dissolves this took over an hour.

                         

                        Is there anyway around having to do this manually one by one to every keyframe? Like is there a way to set it to always default as EASE IN or EASE OUT? I realize the above work around was to turn off maximum render quality during export. Not sure if that helps, but I don't like the idea of sacrificing export quality for simply having smooth transitions. Plus, its a year later and maybe CS6 has a better way now to handle cross dissolves so they don't come out so crappy. (I'm on a 2011 27" i7 iMac with 16gb ram and the AMD 6970M card)

                        • 9. Re: Cross Dissolve NOT Smooth
                          shooternz Level 6

                          Are you saying that you are not using the Cross Dissolve Effect ?

                           

                          ie. you are creating all your cross dissolves manually using opacity keyframes?

                          • 10. Re: Cross Dissolve NOT Smooth
                            DMH79 Level 2

                            shooternz wrote:

                             

                            Are you saying that you are not using the Cross Dissolve Effect ?

                             

                            ie. you are creating all your cross dissolves manually using opacity keyframes?

                             

                            Yes.

                            • 11. Re: Cross Dissolve NOT Smooth
                              shooternz Level 6

                              So what happens if you use the  Cross Dissolve Effect?

                              • 12. Re: Cross Dissolve NOT Smooth
                                DMH79 Level 2

                                shooternz wrote:

                                 

                                So what happens if you use the  Cross Dissolve Effect?

                                It's hard to say. I only did it that way a few times. Looking at it now, those (using the effect instead of keyframes) don't look quite as bad.  Not quite as smooth as ease in/out but more smooth than the linear cross dissolve using keyframes. Just wondering I guess if there's way to always have it ease in and out without having to individually click on each keyframe and adjust. A keyboard shortcut? A plug in? Anything.

                                • 13. Re: Cross Dissolve NOT Smooth
                                  Jim_Simon Level 8

                                  is there a way to set it to always default as EASE IN or EASE OUT?

                                   

                                  Already done.

                                   

                                  http://forums.adobe.com/thread/1010578?tstart=60

                                  • 14. Re: Cross Dissolve NOT Smooth
                                    shooternz Level 6

                                    I would be interested in seeing a video of your manual cross dissolve and the Effect Cross Dissolve.

                                     

                                    I have never found issue with the FX Cross Dissolve but can understand how one could get issues with a manual one.  (Apart from how time consuming it is and how messy the timeline must get - how do you manage the clip overlap?)

                                     

                                     

                                    Can you post a screen grab of your Key frame window?

                                    • 15. Re: Cross Dissolve NOT Smooth
                                      DMH79 Level 2

                                      Jim Simon wrote:

                                       

                                      is there a way to set it to always default as EASE IN or EASE OUT?

                                       

                                      Already done.

                                       

                                      http://forums.adobe.com/thread/1010578?tstart=60

                                       

                                      Thanks Jim! Two Questions:

                                       

                                      1) Exactly how is this Film Fade Preset different than the current Film Dissolve? How is it different than Cross Dissolve? Does it incorporate a smoother start/finish (eg. ease in/out)?

                                       

                                      2) I see in that thread its set to default at 1 second? Can I change that to two seconds somehow by default? If not, its not a big deal as I can just manually adjust, just curious.

                                       

                                      Thanks!

                                      • 16. Re: Cross Dissolve NOT Smooth
                                        Jim_Simon Level 8

                                        The preset is based on keyframing the Opacity, Tint and Levels effects.  It is designed to emulate an optical fade with real film, during which you will see the darker areas fade to black quicker than the highlights.  Similarly, you will see the highlights appear first, with the rest of the image following, during a fade in.

                                         

                                        Currently those keyframes do not Ease Out or In because I didn't feel it was necessary, but you can always change that and save new Presets.

                                        • 17. Re: Cross Dissolve NOT Smooth
                                          DMH79 Level 2

                                          Jim Simon wrote:

                                           

                                          Currently those keyframes do not Ease Out or In because I didn't feel it was necessary, but you can always change that and save new Presets.

                                          That's awesome. How would I go about changing and saving new presets? Never done that before.

                                          • 18. Re: Cross Dissolve NOT Smooth
                                            Jim_Simon Level 8

                                            Change it, then right click on it.

                                            • 19. Re: Cross Dissolve NOT Smooth
                                              DMH79 Level 2

                                              I was able to create my own preset fades with the ease-in/out. Thank you for the advice. Now is there ANY way to create a cross dissolve preset (that can span accross two clips when they are back to back on the same track like the cross dissolve effect can) or can I somehow adjust the current cross dissolve so that it eases in/out? The current cross dissolve and film dissolve effects aren't bad, its just not as smooth at the start and end as if you put tracks on top of each other and eased in/out. 

                                              • 20. Re: Cross Dissolve NOT Smooth
                                                DMH79 Level 2

                                                shooternz wrote:

                                                 

                                                I would be interested in seeing a video of your manual cross dissolve and the Effect Cross Dissolve.

                                                 

                                                I have never found issue with the FX Cross Dissolve but can understand how one could get issues with a manual one.  (Apart from how time consuming it is and how messy the timeline must get - how do you manage the clip overlap?)

                                                 

                                                 

                                                Can you post a screen grab of your Key frame window?

                                                Looking closer the cross dissolve does have the same abrupt start and end that you see in the original post's sample seen here: http://vimeo.com/14536285

                                                I originally said that it was better than linear opacity keyframing one track on top of another, but after a few tests its not. Hopefully you can see in his video what happens on these fades. After you see a few in a row I really start to notice the first and last 10% clip in/out unless its bezier or even better ease in/out.

                                                 

                                                But like I said in my previous post, I've now got a preset for ease in/out fades but its a keyframe preset. Is there a way to adjust the cross dissolve effect with ease in/out or create a new cross dissolve effect that you can drop on top of two clips back to back on one track?

                                                • 21. Re: Cross Dissolve NOT Smooth
                                                  Jim_Simon Level 8

                                                  Now is there ANY way to create a cross dissolve preset

                                                   

                                                  Not as such, no.  You can use what you have with an A/B type edit, but not if the clips are on the same track.

                                                  • 22. Re: Cross Dissolve NOT Smooth
                                                    shooternz Level 6

                                                    Thanx for posting.

                                                     

                                                    I agree ...your cross dissolves are "ugly" and as you described...seem to go weird over final 10%

                                                     

                                                    Never seen that  "issue"  before... in my work.

                                                     

                                                    Are these butt cut clips on a single video layer?

                                                    • 23. Re: Cross Dissolve NOT Smooth
                                                      DMH79 Level 2

                                                      shooternz wrote:

                                                       

                                                      Thanx for posting.

                                                       

                                                      I agree ...your cross dissolves are "ugly" and as you described...seem to go weird over final 10%

                                                       

                                                      Never seen that  "issue"  before... in my work.

                                                       

                                                      Are these butt cut clips on a single video layer?

                                                      I don't know because they aren't my clips. The original poster was someone different from a year ago but my clips look the same and yes I tested them butted up against each other and also on top of each other using the cross dissolve with the same results. Its not as noticable if the two clips are similar except in areas of high contrast. The presets I made with ease in/out are helpful for the stacked track editing I just wish I could apply it to the seqences that have all the video clips on one track (eg. multicam) with ease. No pun intended.

                                                       

                                                      But according to Jim's recent response its not possible. Bummer.

                                                      • 24. Re: Cross Dissolve NOT Smooth
                                                        shooternz Level 6

                                                         

                                                        http://www.youtube.com/watch?v=nZ3y7LxOdew&feature=plcp

                                                         

                                                        Here are some standard cross dissolves in a little example of my work.

                                                        • 25. Re: Cross Dissolve NOT Smooth
                                                          DMH79 Level 2

                                                          shooternz wrote:

                                                           

                                                           

                                                          Here are some standard cross dissolves in a little example of my work.

                                                          Great. Now I'm hungry.

                                                           

                                                          Well, I watched that about 10 times and I think because its got a lot going on in each clip and because there isn't that much difference in contrast on a clip by clip basis this issue is not really noticable. I had to watch it 10 times to even pick up on possibly one instance...the last fade between the open can and what looks like a pill. That one seems to clip out quickly perhaps.

                                                           

                                                          The thing is, not every cross dissolve is that noticable. Some just really stand out more than others. Not totally sure what causes it to be more noticable (maybe something light fading into a more dark shot I don't know) but its definitely there. If there's no way to adjust it to ease in more, I'll just stick with editing stuff on top of each other and use my custom presets that I made that ease in/out. Would be nice to adjust the effects that go on one track though for things like multicam, etc. Oh well.

                                                          • 26. Re: Cross Dissolve NOT Smooth
                                                            shooternz Level 6

                                                            Do a simple test.

                                                             

                                                            Cross dissolve between a 70% grey card and a 10 % grey card. eg Mattes.

                                                            • 27. Re: Cross Dissolve NOT Smooth
                                                              DMH79 Level 2

                                                              I did that. Not quite as obvious as when real clips are used. So maybe its not light to dark issue, I don't know. Like I said though, sometimes its less noticable and sometimes its very noticable like that guy's video. I know earlier in this thread someone suggested to the guy to not select max render quality upon export. Well, I'd rather not do that for 2 reasons: 1) That sucks to have to take away the "benefits" of selecting that box for the sake of cross dissolves  2) The effect can be seen in the actual timeline as well...although admittedly its much more noticable upon export.

                                                              • 28. Re: Cross Dissolve NOT Smooth
                                                                Magnus Allgurén Level 2

                                                                Love the video!

                                                                now...just want to chime in. This video was exported using GPU acceleration I assume? I noticed quite a few opacity jumps in the beginning and ending of the dissolves. I have experienced the same issues ever since the mercury engine was introduced.

                                                                Generally what I do, is to have the GPU on during work and turn it off, using software mercury engine upon mastering/exporting. That is the only way I have found working 100% of the time.

                                                                • 29. Re: Cross Dissolve NOT Smooth
                                                                  shooternz Level 6

                                                                  I think that viewing the video I posted is displaying streaming and/or compression issues...that I dont see in the original or the sequence.

                                                                  • 30. Re: Cross Dissolve NOT Smooth
                                                                    Magnus Allgurén Level 2

                                                                    I suppose you'd be right! lol

                                                                    • 31. Re: Cross Dissolve NOT Smooth
                                                                      shooternz Level 6

                                                                      FWIW

                                                                       

                                                                      When  I do this test:

                                                                       

                                                                      Create 2 second: Cross dissolve between a 70% grey card and a 30 % grey card. eg Mattes

                                                                       

                                                                       

                                                                      ....and I check it out in the waveform monitor..by stepping through every frame with the arrow keys

                                                                       

                                                                      The luminance increments are exactly the same ...totally linear...through out the transition.

                                                                       

                                                                      Tested with and without Mercury Hardware.

                                                                       

                                                                      A Film Dissolve is not so linear

                                                                       

                                                                      An Additive Dissolve is not linear and displays as to be expected from Add.

                                                                       

                                                                      A Non Additive Dissolve ..does nothing on this material.

                                                                      • 32. Re: Cross Dissolve NOT Smooth
                                                                        DMH79 Level 2

                                                                        Thank you very much for all your input. Unfortunately, even though I have the latest iMac Adobe has yet to support its card (AMD 6970M) for hardware acceleration. Even more unfortunate, I don't  really know how to use waveform so I couldn't test the footage in my timeline. Sigh. Still, linear should be linear and consistent and I'm not sure what the exact cause is of the issue. In FCP, I never had to ease in/out. Their linear was smooth all the time. This is all very strange to me.

                                                                        • 33. Re: Cross Dissolve NOT Smooth
                                                                          Danielpremiere

                                                                          I have only recently upgraded at Premiere CS6 (from CS3) using PC. I am experiencing this problem with cross dissolves not being smooth with the hardware MPE GPU Acceleration (CUDA) enabled. It was one of the first things which I noticed when I started using CS6. The problem goes away when the MPE software only is used. Are other users still experiencing this problem, and is there any hope of an improvement from Adobe?

                                                                           

                                                                          Many thanks

                                                                          Daniel

                                                                          • 34. Re: Cross Dissolve NOT Smooth
                                                                            DMH79 Level 2

                                                                            Danielpremiere wrote:

                                                                             

                                                                            I have only recently upgraded at Premiere CS6 (from CS3) using PC. I am experiencing this problem with cross dissolves not being smooth with the hardware MPE GPU Acceleration (CUDA) enabled. It was one of the first things which I noticed when I started using CS6. The problem goes away when the MPE software only is used. Are other users still experiencing this problem, and is there any hope of an improvement from Adobe?

                                                                             

                                                                            Many thanks

                                                                            Daniel

                                                                             

                                                                            I still experience this problem with every single cross dissolve. It's more noticeable on certain contrasting shots that and I hardly notice the issue until I export and view the video outside of Premiere. But yeah, its still a crappy problem and who knows if it's gonna get fixed ever. The THIRD post in this thread has a great example from another user what the issue looks like. I do not have GPU acceleration enabled and I still have the issue so I don't think that's related, but that's interesting that it appears to go away when you disable that. If you export the video with and without CUDA enabled, do you notice a difference? Care to post it here?

                                                                             

                                                                            Either way, I ended up creating my own opacity preset for fading in and one for fading out and had the keyframes NOT be linear which is the issue. Instead, I went with EASE IN and EASE OUT for each keyframe in my preset. I guess just plain old "bezier" would have been okay too but I took it a step further with EASE IN/OUT. Good luck! Oh, and fill out a "bug report" on this HERE.

                                                                            • 35. Re: Cross Dissolve NOT Smooth
                                                                              RyanGV Level 1

                                                                              Looks like this is still an issue in Premiere Pro CC (over 2 years after the intial post).  I don't notice it when using a cross dissolve between 2 clips, but it's very noticeable if I try to fade out a title.  For example if there's footage on track V1, title text on V2 and a cross dissolve transition dropped on the end of the title, it doesn't fade out completely. Looks like it jumps from 10% to 0%.  This happens both with the default transition and if I try to keyframe the opacity from 100 to 0.  The fix mentioned by another poster about switching mercury playback engine to software only works for me, but It's pretty annoying to have to keep turning it off and on.

                                                                              • 36. Re: Cross Dissolve NOT Smooth
                                                                                RyanGV Level 1

                                                                                For reference here are stills of the last frame of the cross dissolve with each MPE option (white text on black background):

                                                                                 

                                                                                Mercury Playback Engine GPU acceleration

                                                                                http://imgur.com/GBtte8q

                                                                                 

                                                                                Mercury Playback Engine software only

                                                                                http://imgur.com/KOjK7q0

                                                                                • 37. Re: Cross Dissolve NOT Smooth
                                                                                  Jim_Simon Level 8

                                                                                  It's not an issue, it's by design.

                                                                                   

                                                                                  One new feature of Premiere Pro CC is that you can turn off Linear Color in the sequence settings, without disabling GPU acceleration altogether.

                                                                                  • 38. Re: Cross Dissolve NOT Smooth
                                                                                    Danielpremiere Level 1

                                                                                    Hi. I have simply left the hardware MPE GPU Acceleration (CUDA) disabled and purely used the MPE software only.

                                                                                     

                                                                                    It is unfortunate as everything has to be rendered, but it least it has the desired effect. Given that the two states (MPE hardware on or off) give different results, I don't understand why it is by design, rather than an issue.

                                                                                     

                                                                                    I find it difficult to believe what I am seeing with the MPE hardware on is really what Adobe intended - and why did the look change from CS3, when there was no "option" but the dissolve looked like it does now with the MPE hardware off.

                                                                                     

                                                                                    I will try and find the time to post a video with both types so you can see the difference.

                                                                                    • 39. Re: Cross Dissolve NOT Smooth
                                                                                      Jim_Simon Level 8

                                                                                      Given that the two states (MPE hardware on or off) give different results, I don't understand why it is by design, rather than an issue.

                                                                                       

                                                                                      Because Adobe designed it that way.  Software processes it one way, and hardware another way.

                                                                                       

                                                                                       

                                                                                      I will try and find the time to post a video with both types so you can see the difference.

                                                                                       

                                                                                      No need.  I'm well aware.

                                                                                      1 2 Previous Next