6 Replies Latest reply on Dec 8, 2011 11:05 AM by Sonimage AV Productions

    ACR not using .xmp files after 03/09/2011

    aikane Level 1

      I'm using ACR 6.4.1.145 and Bridge CS5 on a Windows 7 x64 Pro machine. Canon S95 and G12 CR2 files created before 04/09/2011 behave exactly as they should: changes aved in .xmp files are recognized and applied in Bridge thumbnails and when the image is re-opened in ACR.

       

      Images created on 04/09/2011 and any later date (tested by altering the file dates) have their changes saved in an .xmp file, but this file is not applied to the thumbnail in Bridge, the Bridge thumbnail does not indicate the .xmp file exists, and the .xmp changes are not applied when the image is reopened unless the .xmp file is loaded manually.

       

      I have purged the cache, restarted Bridge, and restarted Windows. I've moved the images to a different directory, then a different drive. I've loaded the images from the SD card several times now. The problem persists.

       

      All assistance appreciated.

        • 1. Re: ACR not using .xmp files after 03/09/2011
          Noel Carboni Level 7

          Where do you have Camera Raw configured to store the data, the central database or the .XMP sidecar files?

           

          In Photoshop, choose Edit - Preferences - Camera Raw..., then look here:

           

          CameraRawDatabaseLocation.jpg

           

          -Noel

          • 2. Re: ACR not using .xmp files after 03/09/2011
            aikane Level 1

            Thanks for the reply, Noel. I should have mentioned that I was using sidecar files.

             

            I'm not sure what to make of this. I tested on another computer and everything worked as it should. I went to bed last night and when I woke up this morning, everything worked. I have no idea why, except that the date changed. I didn't restart Bridge, didn't move the files, didn't change a thing.

             

            I've debugged a lot of computer problems for a lot of people over the years, and I hate it when I'm told, "I didn't change anything!"... but I didn't. I hate problems like this because who knows when it will pop up and bite me.

             

            Thanks again for trying to help.

            • 3. Re: ACR not using .xmp files after 03/09/2011
              Thomas Knoll Level 2

              Only think I can think of is if the .cr2 files contain embedded XMP, and there is also a sidecar XMP file, then Camera Raw/Lightroom needs ot look at the modification dates of the two files to figure out which XMP data to use (the newer file wins).  So if the .CR2 file is newer than the matching .XMP file, and it contains XMP data inside it, then the sidecar XMP file will be ignored.

              • 4. Re: ACR not using .xmp files after 03/09/2011
                Noel Carboni Level 7

                Thomas, can you please add a setting in a future version of the software that will FORCE the use of external storage (XMP or central database) for storage of settings metadata?

                 

                Such a setting would be useful in a situation like this, or for people who never want metadata written back into image files because of the way they choose to organize their work.

                 

                Thank you.

                 

                -Noel

                • 5. Re: ACR not using .xmp files after 03/09/2011
                  aikane Level 1

                  Thanks Thomas.

                   

                  I am pretty sure the CR2 files don't contain any .xmp data. For one thing, the problem only occurs on my installation. If I use another computer, everything works as it should.

                   

                  The problem has returned, however. I just tried to make changes in ACR to images created today, and although ACR saves the .xmp, it does not recognize it when I open the image again. I have to load the .xmp manually.

                   

                  I will bet that tomorrow, the problem has gone away. That would make it somehow time/date dependent. More important to you and anyone else trying to help, it seems to happen only on my installation of CS5. Something has gotten corrupted, I think. If the problem persists, I will probably try a re-install, but I hate the patching proces that follows.

                  • 6. Re: ACR not using .xmp files after 03/09/2011
                    Sonimage AV Productions

                    I do have axact the same problem with CS5-Adobe Camara RAW. Since  early september 2011 xmp files are not shown anymore in the windows explorer and in the bridge ( with show hiden files ON).

                    Making changes in ACR and select READY does create a xmp file, but of course with the changed settings! 

                    Reinstallation of CS5/Bridge did not help.

                    Who can give a solution for this?

                    H.Benning

                    Sonimage AV Productions

                    OS: Windows Vista Business