2 Replies Latest reply on Sep 12, 2011 6:05 AM by G-Black

    Error #0 and inability to do anything

    G-Black Level 1

      Hello!

      So, I'm going to describe the problem right away. I'm on Windows 7. I recently tried installing a small flash game with Adobe AIR, but recieved an error message about being unable to install(I don't remember the exact text) and it said "Error #0" at the bottom. This was with Adobe AIR 1.5.3.9120, the version I still have, but more on that a bit later. When installing the game, Adobe AIR wanted me to update to the newest version, 2.1.7, in fact it would have done that automatically. However, there was that Error #0. Afterwards I tried updating Adobe AIR myself(by manually downloading the update from this website), but I recieved this message:

      "An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.".

      Needless to say, I am the administrator, and Adobe AIR has premission to do whatever it likes. I still haven't solved the problem, so that's the message I still get.

       

      First I tried uninstalling Adobe AIR via Programs and Features, but that failed - I was given the same message as the one before.

      Then I tried going to the location of the update file in the command prompt and writing AdobeAIRInstaller -uninstall, upon which I received the following: Uninstalling Adobe AIR (all versions) failed (consult log).

      Luckily, I have made a log, and here it is:

       

      UI SWF load is complete
      UI initialized
      starting user confirmation
      Version of this installer: 1.5.3.9120
      Newest installed version: 1.5.3.9120
      Installation type: patchSame
      starting elevated install
      subinstaller: starting uninstall
      subinstaller: Beginning install
      subinstaller: Uninstalling product w/ GUID {A2BCA9F1-566C-4805-97D1-7FDC93386723}
      subinstaller: Error occurred; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      subinstaller: Rollback due to error complete
      subinstaller: error during install: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      Failed during elevated install: error 0 1612
      runtime install entering error state: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1612" errorID=0]
      begin quitting

       

      My hard disk is partitioned, so I went to the other partition, used by another person, and because I know that my C:\ drive is F:\ there, tried installing the game, and it worked. The game then worked on my partition too. Recently, however, a patch came out and I installed in the same way, but now I get this message on my partition(it works fine on the other one): "The installation of this application is damaged. Try re-installing or contacting the publisher for assistance."

       

      I also defragmented my C:\ drive, which didn't help either.

      So, how to fix this?