5 Replies Latest reply on Sep 20, 2011 7:18 AM by ahess24

    Subclipse error

    awQQ

      Hi everyone,

      I have a problem installing subclipse for flash builder 4.5. I get error code:

      ------------------------------------------------------------

      An error occurred while collecting items to be installed
      session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
      No repository found containing: osgi.bundle,com.adobe.flash.codemodel.core,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flash.codemodel.osgi,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flash.profiler,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flash.profiler.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.launching.multiplatform.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.launching.multiplatform.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.multiplatform.android.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.multiplatform.android.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.multiplatform.ios.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.multiplatform.ios.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.project.multiplatform.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flashbuilder.project.multiplatform.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.DCDService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.DCDService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.ajaxbridge,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.ajaxbridge.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.as.editor,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.as.editor.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.axis2,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.axis2.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.codemodel,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.codemodel.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.crimson,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.crimson.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.css.editor,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.css.editor.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.dcrad,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.dcrad.derived,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.dcrad.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.e33,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.ui.actions,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.ui.e36,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.debug.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.designview,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.designview.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.editorcore,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.editorcore.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.editors.derived,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.editors.derived.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.exportimport,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.exportimport.nl1,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexbuilder.feature.core,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexbuilder.feature.core.nl1,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexbuilder.feature.standalone,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexbuilder.feature.standalone.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flashbridge,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flashbridge.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flex,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flexunit,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flexunit.derived,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.flexunit.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.help,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.help.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.importartwork,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.importartwork.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.json,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.launching.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.launching.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.monitors.network,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.monitors.network.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.multisdk,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.mxml.editor,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.mxml.editor.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.mxmlmodel,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.project,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.project.e35,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.project.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.project.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.project.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.BlazeDSService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.CFService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.CFService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.HTTPService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.HTTPService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.J2EEService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.J2EEService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.LCDSService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.PHPService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.PHPService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.StaticContentService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.StaticContentService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.WEBService,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.WEBService.derived,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.services.WEBService.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.standalone,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.standalone.e36,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.standalone.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.tengine,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.tengine.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.ui,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.ui.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.utils.osnative,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexbuilder.utils.osnative.win,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.amt,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.as.core,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.as.core.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.communityhelp,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.communityhelp.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.css.core,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.css.core.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.designitems,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.editorcore,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.editorcore.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.editors.derived.e35,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.embeddedplayer,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.exportimport,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.exportimport.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.externaleditors,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.externaleditors.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.fcproject,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.fcproject.nl1,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexide.feature,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexide.feature.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.fonts,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.launching,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.launching.multiplatform,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.launching.multiplatform.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.launching.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.multiplatform.android,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.multiplatform.android.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.multiplatform.ios,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.multiplatform.ios.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.multisdk.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.mxml.core,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.mxml.core.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.nativelibs,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.playerview,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.project.multiplatform,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.project.multiplatform.nl1,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.refactoring.core,4.5.0.308971
      No repository found containing: osgi.bundle,com.adobe.flexide.refactoring.core.nl1,4.5.0.308971
      No repository found containing: org.eclipse.update.feature,com.adobe.flexide.utils.feature,4.5.0.308971

      ------------------------------------------------------------

       

      I am pretty confident that nobody will help me as always, but still maybe anyone has any intelligent guess what is the problem? Because I am not really good at solving eclipse or flash builder problems.


      By the way, I don't want to reinstall and try again, takes too much time.

       

      Regards,

       

      awQQ

        • 1. Re: Subclipse error
          ahess24 Level 1

          Having the same problem.  Were you ever able to resolve it?  I'll post anything I find.

          • 2. Re: Subclipse error
            Ansury Level 3

            Not sure if it'll help, but try and older or newer version of Subclipse - could be Eclipse compatibility issues with the version FB is built on.  Or you could try another SVN client (Subversive I think is one?), can't say how good they are though.

            • 3. Re: Subclipse error
              ahess24 Level 1

              Noob mistake.  Uninstalled and reinstalled, worked no problem.  It was strange because the same thing happened to another developer on our team.  We were both upgrading to 4.5 and got the same error when trying to load the Subclipse plugin.  Ansury - thanks for the suggestion though.

              • 4. Re: Subclipse error
                awQQ Level 1

                Yea but if I reinstall will I use another license number? Because my company bought like 15 standart licenses and we are 10 developers so we used 10, but now if I reinstall will I use the 11th license?

                • 5. Re: Subclipse error
                  ahess24 Level 1

                  No, when I reinstalled I just used the same license.  Uninstalling will free up the license you were using.  Just make sure and reboot after you uninstall and before you reinstall.

                  1 person found this helpful