10 Replies Latest reply on Sep 13, 2011 2:27 PM by Erakon

    Importerredserver.exe failure

    Erakon

      Hey Premiere CS5 Users,

       

      I have been reading a few forums in search a solution to the importerredserver.exe failure. This problem is extremely frustrating, and a solution is required immediately or I am goign to have to get my money back from Adobe, if that is even possible.

       

      So specs on my machine

       

      CPU: AMD ATHLON 6400+

      Video Card: asus Nvidia 480gtx

      Ram: 8gigs ddr2

       

      I am running an external nexstar raid (0) box via esata, and using this as my work drive.

       

      I started a new red project recently, and it was working relatively well until a day or two ago, when everytime I tried to open the project I woudl get the importerredserver.exe failure, and even though it said all media was loaded, everything is offline.

       

      Yesterday, I reinstalled the driver for my video card, and then reinstalled premiere. Opened the project, and wow it worked again, sweet. Maybe somethign got corrupted some how who knows. Today, turned the computer on, opened the project, Boom!, importerredserver.exe failure. What the heck?

       

      The footage I am editing was shot on the Redone MX, at Redcode 28, 3k, 2:1, at 60fps. I also have some footage in there that is 2k, 2:1, at 120fps.

       

      Anybody else have this issue, and find a solution. ADOBE! Do you have any ideas! Does this problem exist in 5.5? If not I want a free upgrade, because the pitch for the software was edit red footage natively. Thats waht I am trying to do, and its not working. Class action anyone? I hate to bring negative vibes to the forums, but when the software is failing to do what I bought it for, and with no solution in sight, I can't help but get frustrated.

       

      Thanks in advance for any help you guys can provide.

        • 1. Re: Importerredserver.exe failure
          Harm Millaard Level 7

          What you are trying to do resembles towing a 40 ton load uphill, using your granny's old bicycle.

           

          Your system is way underspecced for the material you try to edit. Get a new PC.

          • 2. Re: Importerredserver.exe failure
            Erakon Level 1

            Hey Harm,

             

            I know I am not running the hotest box, but I have cut Redcode 36 4khd stuff with no problems in the past. Do you really believe this is a hardware issue?

             

            If I upgrade my CPU to a 6 core amd Phenom, is that going to help? I recently upgraded my graphics card, to a 480gtx, and I must say even with the hack, see little improvement in performance, but I have not done extensive tests. The CPU is the next to go up, but if you think I need a whole new PC then maybe I should save the 200 bucks I was going to spend on that, and save up for a new motherboard, ram, and CPU.

             

            I just don't understand why the importerredserver.exe fails on opening the project. Slow playback, I can deal with, low resolution playback, fine, but not even being able to see my clips, and have the media offline, just doesn't seem right, regardless of my hardware setup.

             

            I have read other posts from people suffering with this problem, and they had way hotter hardware than what I have, and that scares me to think that even if I throw money at the problem it is going to persist.

             

            Any other ideas?

            • 3. Re: Importerredserver.exe failure
              Harm Millaard Level 7

              Unfortunately I have no experience with Red material, so I can't help on that issue and I understand that is the most pressing issue.

               

              My other remarks were purely about the hardware. AMD is just not good enough for any difficult codec like Red. This is just a guess but maybe the lacking SSE 4.1+ support, that severely hamper AMD CPU's, can also cause the importer problem. If you want to edit difficult material from the Red, your best option is to go i7 and that basically means a new PC, new memory etc.

              • 4. Re: Importerredserver.exe failure
                Wil Renczes Adobe Employee

                You haven't mentioned which version of PPro you're running.  It sounds like an old bug that was fixed in one of the RED SDK drops - if you download & install the latest RED plugin from Adobe Labs: http://labs.adobe.com/technologies/redepic_importer/, I think that'll solve your problem. (Note that this version requires CS 5.5)

                • 5. Re: Importerredserver.exe failure
                  Colin Brougham Level 6

                  I'm guessing he's using CS5, since he asked if the "fix" was to purchase CS5.5...

                  • 6. Re: Importerredserver.exe failure
                    Erakon Level 1

                    Hey Guys,

                     

                    I am running CS 5. I was cutting RED footage redcode 36 with CS4 prior, on a 32bit OS with the same hardware, minus the new video card, and had no importerredserver.exe error.

                     

                    Wil, is Adobe no longer supporting CS5. Is there no updated plugin for CS5?

                     

                    I did try the trial version of 5.5 when it was released. I wonder if there is a residual red plugin lingering that is causing a conflict with the CS 5 one. I will look into that.

                     

                    Until a solution is found, thanks for all the help.

                    • 7. Re: Importerredserver.exe failure
                      Todd_Kopriva Level 8

                      As Wil said, make sure that you have the most recent updates. The CS5 (5.0.2) update had a lot of fixes for RED media.

                       

                      What exact version are you running?

                      • 8. Re: Importerredserver.exe failure
                        Erakon Level 1

                        Hey Guys,

                         

                        I may have solved my problem. I have been running 5.03 since it came out.

                         

                        Here is what I think may have happened, but anyone who knows better may prove me wrong, and if this is the case please let us all know, but at this time I believe the cause was installing the trial version, not that there is anyhting wrong with that.

                         

                        What I believe happened, was that I created the current project I am having problems with in CS5.5. When I opened it in CS5, a convert project box appear that said the project was saved from a previous version, and must be converted. ( I may have originally created the project in CS4 many moons ago and then opened it in the trial version of cs5.5 afterthat, I know I have delt with that convert project box many times).

                         

                        So I created a new sequence, and imported the footage, and everyhting is working very well now. I even made a couple of layer adjusted speed and opacity and the play back was sluggish, but there, and all without any rendering, thank you MPE? Anyways it is working well now.

                         

                        I did a test though to see if the old problematic project would mess things up for the importerredserver.exe. So without exiting Premiere, I opened the problematic project, and sure enough, the pop up error importerredserver.exe showed up. I closed the error window, and premiere however was still functional, however when I then tried to open the new project that was working only a few minutes prior, there was no error message, but the footage would not link up, due I assumed to the importerredserver.exe still malfunctioning. So I relaunched premiere, and opened the new project no problem, everything linked up, playback was fine, and I am editing again.

                         

                        To others that have the importerredserver.exe failure problem, I would suggest a possible solution is to make sure that the project you are trying to open did not come from a previous version of premiere pro, or a later version for that matter, and start a new project and try bringing in the footage you were having problems with.

                         

                        Thanks for the help, and I hope this helps others. I will report back to this thread if the error pops up again in my new project.

                         

                        Cheerio.

                        • 9. Re: Importerredserver.exe failure
                          Wil Renczes Adobe Employee

                          Yeah, that's a recipe for disaster.  Back porting projects from a newer version of Premiere is not supported or recommended.  The app is only designed to be able to import older project versions into newer versions;  the reverse is simply not supported.  In your case, due to of a lot of changes to the data structures to support RED EPIC & improved color support, feeding that updated data into CS 5.0 is what's causing the server to crash.

                           

                          If you absolutely need to bring a cutlist over from a newer version of Premiere, you're safer using something like FCP XML to get the cutlist across.  Yes, you'll lose any RED color settings, etc, but at least it's a safe translation of the cuts.

                           

                          Even better, upgrade the 5.0 version to 5.5.  That's the simplest route, at any rate.

                          • 10. Re: Importerredserver.exe failure
                            Erakon Level 1

                            To others that have the importerredserver.exe failure problem, I would suggest a possible solution is to make sure that the project you are trying to open did not come from a previous version of premiere pro, or a later version for that matter, and start a new project and try bringing in the footage you were having problems with.

                             

                            If the importerredserver.exe error stops, then the next step I guess is to try to bring in a sequence from that project, and see if it brings back the error, EDIT: I just tried and sure enough, the importerredserver.exe error came back. I deleted the imported sequence, and all is working once again.) If your edit is near completion, or start over is not possible, I would suggest taking Wils advice and upgrading, and or trying an xml.