2 Replies Latest reply on May 22, 2012 5:00 PM by Marko Pelovic

    Flash Builder 4.5 Fails to Start

    tvp_82

      Folks,

      I have just installed Flash builder 4.5 on a windows vista machine. When I launch the flash builder, I get the message"Failed to create Java Virtual Machine" and flash builder doesn't start. In the past, I have installed, Flex Builder 3 in the same machine earlier and used it without any issues. can some one help me!!!

      Flex.JPG

      Thanks

      Tvp

        • 1. Re: Flash Builder 4.5 Fails to Start
          MarioVieira.net

          Hiya,

           

          Having same problem in a Mac... Did you find any solutions for it?

           

          Would be very pleased to know

           

          Thanks in advance

          • 2. Re: Flash Builder 4.5 Fails to Start
            Marko Pelovic

            Hello guy's.

             

            About this error I know that comes from the ini configuration file that is in Flash Builder default folder:
            (in my case)

            C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\FlashBuilder.ini

            so those 4 parameters are like - how many RAM you want to use to create the Java Virtual Machine (JVM).

             

            My default parameters are:

            -Xms384m

            -Xmx512m

            -XX:MaxPermSize=256m

            -XX:PermSize=64m

             

            also I have 16GB RAM, i5 processor and x64 bit machine... so, when I duplicate those values here I get the same error like tvp_82 has.

            It seems that Xms and Xmx cannot be bigger from (Xms512m,  Xmx1024m).

             

            Just for a record ... there are another config files inside the "sdks" folders with the same parameters for the JVM:
            (in my case)

            C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\sdks\4.5.1\bin\jvm.config

            C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\sdks\4.5.0\bin\jvm.config

            C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.5\sdks\3.6.0\bin\jvm.config

             

            Inside those files there is only 1 parameter (java.args=-Xmx384m -Dsun.io.useCanonCaches=false)

            And be sure that your FlashBuilder.ini ... and those jvm.config files are with same value (like in my case - Xmx384m)

             

            IMPORTANT:
            Howewer I know this because when I start using Flash Builder everything works perfect until my project grows up.

            Now I am so close to my first release of my project and I cannot compile the "Release Build"... I can create only "Standard Build" and "Fast Package build"
            I get this error when I try to create IPA build for iOS devices:

            http://forums.adobe.com/thread/948366

            http://forums.adobe.com/message/4171044

             

            Like you see, already spent a month, but still nothing from Adobe... or just to give me directions what's happen with this error.

            So.. the errorcan be result of my project code, or by JVM small memory.

            Howewer I need to know what is the problem before I do changes in my code.

            Anyway I don't have time to recode my app... if I am not sure that - my code is the problem for this error.

             

            So please if you are familiar with something like this... post me.

            Thank you guy's and I think that I help you with your issue.

             

            Regards