0 Replies Latest reply on Sep 15, 2011 1:49 AM by kesasar

    ant mxmlc under sdk 4.5.1 multiple problems

    kesasar Level 1

      Dear all,

      I am using Ant 1.8.2 running in verbose mode
      I have copied flexTasks.jar into Ant lib dir

      I experience multiple problems

      When I run [build-flex-src] it seems to build the swf correctly
      but the only line I have in the output saying that it loads flex-config.xml and the task ends

      When I run [3:Create-Deliverables] the task never ends and seems stuck
      I never echos anything
      It prompts
      but never package the war even if the package war works perfectly when removing the
      depends="[build-flex-src],


      Any ideas ?
      Any way to find what the compiler does ?
      Any alternative ?
      Are you using the ant task ?

      <target name="[build-flex-src]" depends="[build-flex-wrapper]" description="Compile flex sources">

                      <flex:mxmlc file="${flex.src.dir}/${flex.app.name}.mxml" output="${webapp-source.dir}/client/${flex.app.name}.swf" keep-generated-actionscript="false">
                              <target-player>10.2.0</target-player>
                              <locale>en_US</locale>                       
                              <load-config filename="${FLEX_HOME}/frameworks/flex-config.xml" />
                              <source-path path-element="${flex.src.dir}/assets/locale/{locale}" />
                              <source-path path-element="${FLEX_HOME}/frameworks" />
                              <compiler.include-libraries dir="lib_flex" append="true">
                                      <include name="Cairngorm.swc" />
                                      <include name="ExtendedTabBar.swc" />
                                      <include name="KapInspect.swc" />
                              </compiler.include-libraries>
                      </flex:mxmlc>
      </target>

      <target name="[3:Create-Deliverables]" depends="[build-flex-src],setup">
              some echo
              some prompt
              package war
      </target>