3 Replies Latest reply on Sep 30, 2011 11:53 AM by mjurach

    Adobe Acrobat X Pro problem with 10.1.1 MSP

    heatfan2012

      I have an AIP for Adobe Acrobat X Pro and applied the 10.1.1 MSP to it yesterday.

       

      When I attempt to deploy through Group Policy, I receive:

       

      Error 1334:  The file 'acidviewobj.tx' cannot be installed because the file cannot be found in cabinet file Data1.cab

       

      I expanded Data1.cab and the file is definitely not there.

       

      I have built this package using the following:

       

      Downloaded AcrobatPro_10_Web_WWEFD.exe (10.0.0)

      Ran -nos_o -nos_ne commands to extract

      Created MST using Customization Wizard X

      Applied 10.1.1 MSP patch

       

      Am I doing something wrong?

        • 1. Re: Adobe Acrobat X Pro problem with 10.1.1 MSP
          Ankit_Jain Adobe Employee

          Hi,

           

          Since, your issue deals with Adobe Acrobat could you please post your issue in the Adobe Acrobat forum.

           

          Anyhow, from the look of things it looks like you have created the AIP incorrectly using the following command:

          msiexec /a "path to extracted 10.0.0 MSI" /p "path to 10.1.1 msp"

           

          The correct command(s) to create an AIP for 10.1.1 are:

          msiexec /a "path to extracted 10.0.0 MSI" [This would prompt you for a location to create the AIP. Provide any location say C:\AIP]

          msiexec /a "path to MSI in the newly created AIP folder i.e. C:\AIP\AcroPro.msi" /p "path to 10.1.1 MSP"

           

          This would ensure that a correct AIP is created which would install correctly.

          Hopefully this should work.

           

          Ankit

          • 2. Re: Adobe Acrobat X Pro problem with 10.1.1 MSP
            mjurach

            I'm having the same problem with the same error message. Installation gets almost to the end before this error comes up and all changes are rolled back.

             

            I've tried:

             

            • Re-expanding my Admin Install Point, which includes data1.cab (didn't help)
            • Regenerating my .mst Transform file (didn't help)
            • Applying the AcrobatUpd1011.msp update directly to the original 10.0.0 AcroPro.msi installer package (didn't help)
            • 3. Re: Adobe Acrobat X Pro problem with 10.1.1 MSP
              mjurach Level 1

              OK, figured it out.

               

              My problem was that I was reusing AIPs, which Adobe discourages in their Enterprise Admin Guide.

               

              For every quarterly update, you have to recreate the AIP, then apply the new quarterly patch. I don't feel this is adequately explained in the guide, but it's the only series of steps that worked for me.

               

              So:

               

              1. Create a new 10.0.0 AIP
                msiexec /a C:\Acrobat\AcroPro.msi (where AcroPro.msi is an unmodified, original 10.0.0 package. Re-extract from the 10.0.0 installer if you only have patched versions left)
                choose a unique subfolder for this AIP, something like C:\Acrobat\AIP_1011\
              2. Patch this new AIP with your quarterly patch
                msiexec /a C:\Acrobat\AIP_1011\AcroPro.msi /p AcrobatUpd1011.msp
              3. Now you can push out installs with this new, patched AcroPro.msi in your new AIP folder
                msiexec /i C:\Acrobat\AIP_1011\AcroPro.msi TRANSFORMS=C:\Acrobat\transform.mst REINSTALLMODE=vomus REINSTALL=all REBOOT=reallysuppress /qb

               

              For more details, see: http://secunia.com/community/forum/thread/show/9808/update_10_10_will_not_install