3 Replies Latest reply on Sep 20, 2011 8:27 AM by codexplorer

    Proper workflow for interlaced footage editing?

    codexplorer Level 1

      I have searched the forum (via Google) for an answer to my question, but haven't been able to come up with a simple answer.

      As I have documented elsewhere in this forum, I am unable to edit AVCHD footage generated by my cameras (Sony CX550V and HX5V) natively in Premiere Pro with my iMac (mid-2011 21.5" i7 12GB RAM, 1TB 7200 internal, 1TB 7200 FW800 external), so I resorted to transcoding it using the DNxHD codec from Avid (trying to keep the best quality).

      For my first attempt, I obtained disappointing results after exporting my sequences to QT H.264 and figured that at some point in the process, Premiere (or AME) must have de-interlaced my footage. I would have no issue with that if the results were great, but that is not the case. I visibly lost half of my vertical resolution. Note that my sequences are all 1080i60 so that they should have the proper setting for what I want to do. My intent was to use JES Deinterlacer for the deinterlacing step, as it has a reputation to do a better job than most default from other software (e.g. FCP).

      For my second attempt, I decided to try editing with the transcoded footage, and at the end, replace all clips by their AVCHD originals, and without trying to playback the whole thing, exported it to QT H.264 again. But there again, the result was a poorly de-interlaced sequence. The export settings for QT H.264 seem to be those for a 60i interlaced footage as shown here:

      Screen Shot 2011-09-19 at 7.36.37 AM.png

      The bottom-line though, is that the resulting footage is not interlaced.

      How do I know that? There is one part in my sequence where an object crosses the frame rapidly, and the original clearly shows the comb effect characteristic of interlaced footage. When I check my output, I play it back at full resolution on my 1920x1080 screen and look for the comb effect in that part of the clip. If I see it, then the output is interlaced, if not, it has been deinterlaced.

      I then tried exporting using MPEG2 >> HDTV 1080i 29.97 High Quality, boosting the quality to the maximum of 5 and increasing the bitrate to 25 Mbps (which is the maximum my original footage is encoded at). This results in a mpg file that interestingly cannot be played by MPEG Streamclip but is playable by QT.

      This footage *IS* interlaced !

      Now the problem is that, like Streamclip, JES Deinterlacer does not recognised this format. So I have to export it from Quicktime using the "For Mac & PC" option (there is absolutely no options I am aware of), resulting in a .mov file which can now be opened and deinterlaced (nicely) by JES Deinterlacer. The problem I have with this step is that the file appears significantly smaller than AME's output (by a factor of 2-3), which I interpret as being due to a more aggressive compression by the MPEG2 codec (hence quality loss).


      Overall, this is not a deal killer, but it seems to me that my workflow is unduly complex.

      Can anybody point to an alternate path (please dispense with the easy "switch to PC" answer :-)?

        • 1. Re: Proper workflow for interlaced footage editing?
          codexplorer Level 1

          Hmmm... I may have worked too late yesterday, as exporting another project using QT H.264 (as described above) resulted in an interlaced video this time. I am currently deinterlacing it with JES Deinterlacer (without conversion, since the .mov file is readable by JES Deinterlacer). Not sure what happened the first time around, except that I realized that my DNxHD settings were wrong (30 fps instead of 29.97 fps - I have to be careful about this feature of PP or any other Adobe products according to which if you drag your cursor over a modifiable value, it will change that value).

          My sequences are of the correct format (interlaced 29.97 fps) in both projects, and, in both projects, I did not use the transcoded footage for export. Moreover, the transcoded footage for both projects looks interlaced.


          The bottom line is that my initial workflow appears to be working:


          - transcode to DNxHD 1080i

          - edit with the transcoded footage

          - before export, replace the footage with the original AVCHD one

          - export to QT H.264 1080i

          - deinterlace with JES Deinterlacer.


          Luckily all these processes seem to be taking advantage of the 8 cores of my iMac, so this does not take a redhibitory long time.

          • 2. Re: Proper workflow for interlaced footage editing?
            Ann Bens Adobe Community Professional & MVP

            Interlaced HD footage is always Upper Field first.

            2 people found this helpful
            • 3. Re: Proper workflow for interlaced footage editing?
              codexplorer Level 1

              I see! I suppose I may have changed that without noticing it (probably the mouse feature I was commenting about). Thanks!