10 Replies Latest reply on Dec 30, 2014 11:43 AM by Chilbear

    I am unable to open a .idml file

    beebs46

      I created this in Indesign CS5.5, had two different people export it as .idml file. At home I was not able to open the .idml file- it has a screen that says 'opening file', and the blue bar as it is importing content- ie logo.ai. At some point the blue bar stops moving and Indesign crashes.

       

      I try to open the .idml file on CS4 at work and I am able to open it and work on it, but I do not have the image links or necessary fonts there. So I save as an Indesign file to try to open at home.

       

      At home, the indesign file saved from the .idml begins to open, but eventually also crashes.

       

      In Indesign I have gone to Help->Updates and run the available updates. I am able to open other files without it crashing.

       

      Am I missing something? Is there anything I can do to make this work?

        • 1. Re: I am unable to open a .idml file
          Peter Spier Most Valuable Participant (Moderator)

          This sounds like a problem on the home machine, perhaps a font issue. Do you get any sort of error message or a crash log? What's the OS? Do you run a font manager?

          • 2. Re: I am unable to open a .idml file
            beebs46 Level 1

            Its OS X 10.6.8

             

            I have FontExplorer X Pro

             

            In my old machine I used to have a problem related to fonts and it would always crash as well. On this (relatively) new machine it does not ever say anything in relation to fonts, but it also crashes so I wouldn't be surprised if it was the same thing.

             

            I do get a crash log and here is the beginning of it:

             

            Process:         Adobe InDesign CS4 [1108]

            Path:            /Applications/Adobe InDesign CS4/Adobe InDesign CS4.app/Contents/MacOS/Adobe InDesign CS4

            Identifier:      com.adobe.InDesign

            Version:         6.0.6.622 (6060)

            Code Type:       X86 (Native)

            Parent Process:  launchd [89]

             

            Date/Time:       2011-09-24 10:05:55.873 -0400

            OS Version:      Mac OS X 10.6.8 (10K549)

            Report Version:  6

             

            Interval Since Last Report:          15852 sec

            Crashes Since Last Report:           26

            Per-App Interval Since Last Report:  4741 sec

            Per-App Crashes Since Last Report:   20

            Anonymous UUID:                      8547924E-DD1D-406F-8D0D-88CF71CFC8CA

             

            Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

            Exception Codes: KERN_INVALID_ADDRESS at 0x000000006e676973

             

             

            Is there something that can be done? Thank you for your help.

            • 3. Re: I am unable to open a .idml file
              Peter Spier Most Valuable Participant (Moderator)

              John is pretty good at analyzing the crash logs, but you haven't given quite enough. You can put the whole thing on Pastebin.com and then link to it here (don't attempt topate the entire thing here), or giv it a go yourself withteh help of this article: Guide to Interpreting InDesign Crash Reports | InDesignSecrets

              • 4. Re: I am unable to open a .idml file
                beebs46 Level 1

                Thank you I will take a look at the article, but here is the link for the entire crash log:

                 

                http://pastebin.com/6Dw6ikrq

                • 5. Re: I am unable to open a .idml file
                  John Hawkinson Level 5

                  Good morning.

                   

                  Indeed, the full log is much better. It's somewhat ironic that your abbreviated post stopped with line 19; the first useful part of the log begins on line 22 with the meat on 24:

                   

                  1   AdobePDFL                          0x2671982c CosDocEnumEOFs + 27326
                  2   AdobePDFL                          0x26717bab CosDocEnumEOFs + 20029
                  3   AdobePDFL                          0x26719fea CosDocEnumEOFs + 29308
                  4   AdobePDFL                          0x26627a26 ASTextIsEmpty + 1146
                  5   AdobePDFL                          0x264d1a1f PDFontPSFlushIncrGlyphList + 65853
                  6   AdobePDFL                          0x264d1be6 PDFontPSFlushIncrGlyphList + 66308
                  7   AdobePDFL                          0x264d4213 PDFontPSFlushIncrGlyphList + 76081
                  8   AdobePDFL                          0x264d6d66 PDFontPSFlushIncrGlyphList + 87172
                  9   AdobePDFL                          0x264bbda6 PDFLPrintDoc + 6322
                  10  AdobePDFL                          0x26586f50 PDSetHostEncoding + 2412
                  11  AdobePDFL                          0x265870a6 PDSetHostEncoding + 2754
                  12  AdobePDFL                          0x264bf13a PDFLInitFriends + 2122
                  13  AdobePDFL                          0x264bec48 PDFLInitFriends + 856
                  14  com.adobe.InDesign.PDF             0x2627dfe6 GetPlugIn + 1086038
                  

                   

                  So, the crash is in the Adobe PDF Library (AdobePDFL), in a function called CosDocEnumEOFs.

                  I would tend to assume you have a placed PDF in your document, and that is somehow the cause of the problem.

                   

                  I would try moving aside whatever PDF file is linked from the document [I realize this might be tricky to determine!].

                   

                   

                  I'm not sure what CosDocEnumENOFs. It's presumably "something enumerate document end-of-file-markers", though Cos. is probably not Cosine, but maybe it is.

                   

                  There is certainly something about fonts, since PDFontPSFlushIncrGlyphList() is called. Presumably that is "PDF: Flush the Incremental Glyph List associated with a PostScript Font." So it would be a good idea to disable your font management software and remove all non-system fonts and see

                  if the problem still occurs.

                   

                  Looking further down, it appears that the problematic PDF is perhaps part of a group that is affected by transparency...

                   

                  If this is a short-term need, you might consider installing a 30-day free trial of CS5.5.

                   

                  Have you tried opening the IDML at home, rather than the INDD saved from it?

                   

                  Good luck!

                  • 6. Re: I am unable to open a .idml file
                    beebs46 Level 1

                    John,

                     

                    Thank you so much for your help. I can't begin to tell you how thankful I am- I have spent so many hours doing everything I could think of and nothing worked, but at last it has opened! I deleted all pdfs related to the file (didn't really need them, had the eps) and deactived all fonts (some 18,000!, don't know how so many came to be active).

                     

                    Enjoy the rest of your weekend!

                    • 7. Re: I am unable to open a .idml file
                      beebs46 Level 1

                      Thank you as well Peter!

                      • 8. Re: I am unable to open a .idml file
                        Chilbear

                        I am now having same issues importing  IDML CS6 Mac into CS5 Mac. All windows work until it finds two missing links, I hit OK and then the task bar goes to 1/2 way and then hangs. I have deleted prefs and the like but nothing after trying for 1.5 hours. Any solutions? The application has not crashed just hangs so no crash log is available other than the one Apple wants to be sent to them. I used cmd+escape to break the hang - I had let it run for 30 minutes but nothing either.

                        • 9. Re: I am unable to open a .idml file
                          BobLevine MVP & Adobe Community Professional

                          Could be corrupt. Try exporting it from CS6 again.

                          • 10. Re: I am unable to open a .idml file
                            Chilbear Level 1

                            Wish I had the original - I requested and received a PDF already. Thanks for the reply - I guessed at corrupt already.