3 Replies Latest reply on Sep 28, 2011 7:16 AM by AbhigyanModi

    Windows installer error 1642 when loading patch for Reader 10

    bi88283

      Intermittently, I get this error when loading the latest security patch for Reader 10 - a.k.a. version 10.1.1. Reader 10 is already loaded (version 10.0.0).  Windows installer returns error code 1642, and the text of the pop-up window is as follows:

      "The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

      The same thing happens when I attempt to load the previous patch - version 10.1.0.

       

      I have already uninstalled and reinstalled Reader 10 base package with no problems, but the patch will still not load.  On some boxes I do not have this problem.

        • 1. Re: Windows installer error 1642 when loading patch for Reader 10
          AbhigyanModi Adobe Employee

          10.1.1 can be applied only on a 10.1 installation.

          On the systems where you are seeing a failure, can you double check the existing Reader version?

           

          -abhigyan

          • 2. Re: Windows installer error 1642 when loading patch for Reader 10
            bi88283 Level 1

            Abhigyan, that's the impression I got from reading various blog posts.  However, I've had multiple scenarios where I've attempted to load version 10.1.1 on top of version 10.1.0, and still gotten that error stating that I do not have a correct version. In addition, I have also seen this when attempting to apply 10.1.0 (previous patch) on top of version 10.0.0 or 10.0.1. It seems to be related to something that is getting dropped into the registry that the installation is seeing.  It may only happen on boxes that previously had version 9.0, and on which version 10.0 was installed without first uninstalling 9.0, but I'm not sure if that is the exact scenario.

             

            The way I was able to fix the problem I described above was to load the full exe of 10.1.1 (on top of 10.1.0), then uninstall Reader using Control Panel, and reload the SMS packages.  I am able to successfully load base version 10.0.0 and then add on patch 10.1.1, without incrementing to 10.0.1 or 10.1.0 along the way.

            • 3. Re: Windows installer error 1642 when loading patch for Reader 10
              AbhigyanModi Adobe Employee

              yes, a fresh install of 10.1 or 10.1.1 should take care of the problem. As you have figured, the double dot quarterly releases of Reader X are cumulative, so need to apply only the latest one.