24 Replies Latest reply on Sep 17, 2013 8:36 PM by bilglas

    Can't make font bold, shortcut stopped working

    bernst@fastline.com Level 1

      In the last week or so a few of our users have no longer been able to use the keyboard shortcut to make some fonts bold even though you can go select the bold from the type menu so obviously the bold version is installed and active. After talking with others in our group, some of them have had this happen in the past and then things resolved on their own.  I researched this and found the thread here

      http://forums.adobe.com/message/2653026#2653026

      which mentioned that some fonts don't contain the data to indicate that they contain a bold version, but that theory doesn't seem to apply in our situation. We use a set of corporate fonts that have not changed and the same version of the fonts are installed on all our computers, which are all cloned off a single image so set up is identical. Some users can make the fonts bold using shortcuts and others cannot, so I don't think it has anything to do with the font itself not containing the proper data or it wouldn't work on any of the computers. Also, if I switch to a different user on the same computer I am able to use the shortcut keys so again. Could there be any other reason why the shortcut keys would simply stop working? I've tried replacing InDesign's preference files and that does not work either. We are running CS4 on OS X 10.5.8.

        • 1. Re: Can't make font bold, shortcut stopped working
          Peter Spier Most Valuable Participant (Moderator)

          Any other keyboard oddities on these machines?

           

          It sounds like either a second language has been installed and theuser has switched languages without noticing so the keyboard has re-mapped, or maybe there is a second set of Keyboard Shorcuts in use and that set does not include the bold shortcut.

           

          If neither of those is true, then I would try this: Replace Your Preferences

          • 2. Re: Can't make font bold, shortcut stopped working
            bernst@fastline.com Level 1

            Hi Peter,

             

            No other keyboard complaints that I've heard. It's weird because it works for some fonts and not for others on the same computer. For instance I can make Times bold, but not Helvetica. I would think if the keyboard was remapped it wouldn't work at all. We did try replacing the InDesign preferences and I just tried again following your directions for doing it at launch and manually. That didn't make a difference either.

            • 3. Re: Can't make font bold, shortcut stopped working
              Peter Spier Most Valuable Participant (Moderator)

              Move everything out of the InDesign Folder in the user library and restart ID, see if that helps.

              • 4. Re: Can't make font bold, shortcut stopped working
                bernst@fastline.com Level 1

                We tried that the other day and it didn't have any effect either. Not sure where to go from here.

                • 5. Re: Can't make font bold, shortcut stopped working
                  bernst@fastline.com Level 1

                  Think I have answered my own question. After two days of extensive testing on one computer where I basically pulled every file from my problem user's library over to a new test user account a few at a time and tested to see if I could duplicate the issue. I narrowed it down to a problem with the Suitcase vault feature. Suitcase by default copies any added fonts to their vault. I normally have this feature turned off because early on we had problems when using the vault.

                   

                  Occasionally Suitcase starts acting flakey and our normal solution is to trash the preferences and start clean. When you do this Suitcase defaults back to using the vault and if you don't change it the fonts all go into the vault. When this happens you cannot use the shortcut keys on some fonts in InDesign to make them bold. If you use the setting to leave fonts in place and then add your fonts, shortcuts work fine. If I notice the setting is wrong when I'm working on a computer I will change it, but you cannot change the setting after you have already added the fonts because it appears to only apply to fonts added after the setting is changed not before. So if you already have fonts loaded that aren't working you will need to remove them from your library and then add them back after changing the setting. I was able to duplicate this on a couple of our computers just to verify my theory and I've let Suitcase know as well. Apparently something in their vault is preventing InDesign (and Photoshop) from utilizing the shortcuts on some fonts.  If I hear anything back from them on why this is happening I'll post back.

                  • 6. Re: Can't make font bold, shortcut stopped working
                    bernst@fastline.com Level 1

                    Just wanted to follow-up. I have been in contact with Extensis regarding this issue and they were able to replicate it with several of our fonts. The very nice representative I've been working with said that the issue would be passed on to their product managers to review for a possible fix in a future release. Until then if you add your fonts in place rather than into the fontvault, your shortcuts keys in InDesign should work fine.

                    • 7. Re: Can't make font bold, shortcut stopped working
                      Sya Nara

                      bernst@fastline.com wrote:

                       

                      Just wanted to follow-up. I have been in contact with Extensis regarding this issue and they were able to replicate it with several of our fonts. The very nice representative I've been working with said that the issue would be passed on to their product managers to review for a possible fix in a future release. Until then if you add your fonts in place rather than into the fontvault, your shortcuts keys in InDesign should work fine.

                       

                      I'm having this issue on the latest version of InDesign. At first I thought it was related to Suitcase, but after updating Suitcase to the latest version, trashing all my prefs and FontVault, re-adding all my fonts, and clearing all my system's font caches, the problem still happens.

                       

                      Then I realized it's not related to Suitcase at all, but to certain font families. I'm not sure what causes it, maybe it's because these families have a Roman, Regular, Bold, Extra Bold, Black, Condensed, Bold Condensed, etc. and it just doesn't know which one to pick, so it does nothing? It should at least toggle between Roman and Bold, though!

                       

                      This is a very frustrating problem. Anyone know how to fix it? I even tried making a character style called "Bold" and setting a shortcut for it, but any keys I press to set the shortcut, it just beeps at me and nothing happens! Argh!

                      • 8. Re: Can't make font bold, shortcut stopped working
                        bernst@fastline.com Level 1

                        Sya, I know you said you trashed your FontVault, but are you still letting Suitcase use it to store the fonts when you re-add them? Simply trashing the FontVault itself doesn't work because by default this is where Suitcase wants to store added fonts, so it recreates the FontVault. To bypass using the FontVault you have to change the preference in Suitcase to "Add fonts leaving them in place" before you re-add your fonts. Haven't had this issue since we started doing that. (knock wood) We are now using CS5 and Suitcase 15.0.5 on OS X 10.7.5.

                        • 9. Re: Can't make font bold, shortcut stopped working
                          Sya Nara Level 1

                          Bernst- I did not let Suitcase use the FontVault at all to store fonts. I have *always* had my fonts stored outside of the FontVault.

                           

                          If it was Suitcase's fault, then why does deactivating Suitcase not fix the problem? Why does the problem still happen when the fonts are in my /Library/Fonts area?

                           

                          For example I have Helvetica LT Std which is from Adobe Font Folio 11. It's an OTF font. I deactivated the font from Suitcase, quit the Suitcase FontCore, removed the Suitcase auto-activation plug-in from InDesign, and then copied the whole font folder into the /Library/Fonts area. Then I restarted InDesign and it still has the same issue.

                           

                          Yet on most of my other fonts, the bold hotkey still works: Arno Pro, for exaple, works fine. Adobe Garamond Pro works fine now. But Helvetica LT Std doesn't work with the bold hotkey!

                           

                          I think this is definitely a bug in InDesign. For some reason it's not recognizing that the Regular and Bold are two versions of each other on some fonts.

                          • 10. Re: Can't make font bold, shortcut stopped working
                            Sya Nara Level 1

                            WHAT THE HELL why can't I use the bold hotkey? I completely disabled Suitcase AND THE PROBLEM STILL HAPPENS. WTF ADOBE? THESE ARE YOUR OWN FONTS. WHY IS THIS BROKEN?!

                            • 11. Re: Can't make font bold, shortcut stopped working
                              Peter Spier Most Valuable Participant (Moderator)

                              Saya,

                               

                              Which version of ID are you using, and which platform? On Mac, there are some known issues that system shortcuts or shortcuts used by other programs are interfering with some shorcuts in ID, Cmd Shift L, for example. You can turn these off in system prefs to restore the functionality in ID.

                               

                              As far as not being able to assign a shorcut to your character styles, style shortcuts are restricted to using a modifier key and a key on the numpad.

                              • 12. Re: Can't make font bold, shortcut stopped working
                                petewilder

                                I'm having the same problem in InDesign CCv9 as above and have disabled the Apple system shortcuts. Ranged left now working but bold, italic etc not. Not using Suitcase just Fontbook Please help!

                                • 13. Re: Can't make font bold, shortcut stopped working
                                  Steve Werner Adobe Community Professional & MVP

                                  What font(s) are you having a problem with bold and italic shortcuts? Do they work in an earlier version of InDesign?

                                   

                                  In order for Cmd/Ctrl + Shift + B (toggle bold) or Cmd/Ctrl + Shift + I (toggle italic) to work the font has to be designed with those shortcuts enabled. Most Adobe fonts do, but not all third party fonts do. It's up to the font designer to enable that feature.

                                   

                                  Also, sometimes the designer makes Cmd/Ctrl + Shift + B toggle between the regular and semibold weights.

                                  • 14. Re: Can't make font bold, shortcut stopped working
                                    onigame

                                    I'm having the same problem.  I'm using InDesign CS6 on Windows 8, and the font "Adobe Garamond Pro" doesn't do anything with the Ctrl + Shift + B shortcut.  I do not use Suitcase or FontVault (I don't even know what those are) and do not own any earlier versions of InDesign.

                                    • 15. Re: Can't make font bold, shortcut stopped working
                                      Steve Werner Adobe Community Professional & MVP

                                      It could be a Windows 8 problem, or it could be something particular to your setup.

                                       

                                      On my Mac, using either CS6 or CC, Cmd+Shift+B switches between Adobe Garamond Pro Regular and Adobe Garamond Pro Semibold.

                                       

                                      I'd start by restoring your preferences. Here's how:

                                       

                                      • 16. Re: Can't make font bold, shortcut stopped working
                                        onigame Level 1

                                        I was a bit skeptical that resetting my preferences would work since this is the very first document I've worked on in InDesign.  But I figured it couldn't hurt since I didn't have any customizations.

                                         

                                        Anyway, I reset my preferences as detailed in the URL.  No effect, Ctrl+Shift+B still doesn't do anything with Adobe Garamond Pro.  (Does stuff with other fonts.)  Yes, I tried it in a fresh new document with nothing but some text in it as well.

                                        • 17. Re: Can't make font bold, shortcut stopped working
                                          bernst@fastline.com Level 1

                                          This is just a stab in the dark since I am using a Mac and not Windows. How new are the fonts you are using? Is it possible that there are updated versions of the font available from Adobe? Or you may even try an older version if this is the latest font that came with CS6. We had an issue at one time with Adobe's Helvetica not changing styles using shortcuts and I had to load a different version of the font to get the shortcuts to work properly. If I'm remembering correctly, I had to get an older version of the font from an earlier install of CS.

                                          • 18. Re: Can't make font bold, shortcut stopped working
                                            Steve Werner Adobe Community Professional & MVP

                                            It could be a Windows 8 bug. A new OS can cause bugs sometimes because it hasn't been tested as much.

                                            • 19. Re: Can't make font bold, shortcut stopped working
                                              BobLevine MVP & Adobe Community Professional

                                              On Win 8 with ID CC using Adobe Garamond Pro regular, ctrl+shift+b gives me the semi bold weight.

                                              • 20. Re: Can't make font bold, shortcut stopped working
                                                MW Design Level 4

                                                Just tried it on a Win8 laptop and yes, like Bob I get the semibold and if I actually want the bold variant, I need to select it specifically. I would make a character style and assing it a hot key.

                                                 

                                                Mike

                                                • 21. Re: Can't make font bold, shortcut stopped working
                                                  onigame Level 1

                                                  Ah.  It's possible that I would get the Semibold if it existed on my computer, but my computer only has Roman, Italic, Bold, and Bold Italic.  I guess it's not smart enough to realize that it should go to Bold if Semibold doesn't exist on the computer.

                                                   

                                                  Anyway, for the record, I have Adobe Garamond Pro, Version 2.111;PS 2.000;hotconv 1.0.67;makeotf.lib2.5.33168.  The file timestamp is January 26, 2012.

                                                  • 22. Re: Can't make font bold, shortcut stopped working
                                                    Steve Werner Adobe Community Professional & MVP

                                                    It's quite possible that the style association for Ctrl/Cmd + Shift + B is hard-wired to Adobe Garamond Semibold.

                                                     

                                                    Follow Mike's advice in posting #20.

                                                    • 23. Re: Can't make font bold, shortcut stopped working
                                                      petewilder Level 1

                                                      Yes, I think that's the case - I re-started, validated all fonts in Fontbook, stripped out the red one's and (touch wood) and started with a new document and it`'s working – with the exception of Adobe Garamond!

                                                      • 24. Re: Can't make font bold, shortcut stopped working
                                                        bilglas Level 1

                                                        I'm using Win7 with InDesign CC. A partial answer to this is, it's an issue with Adobe Garamond Pro. Ctrl+Shift+B switches from Regular to Bold using Minion Pro, Arno Pro, Myriad Pro ... but with Adobe Garamond Pro, Regular switches to Semibold. This same problem also happens with ITC Stone Sans Std, so even though it's the font's "fault" ... it isn't unique to Adobe Garamond Pro. It would seem to me that a script could be written that would resolve this, but I know nothing about writing scripts ... wish I did.