4 Replies Latest reply on Oct 2, 2011 12:19 PM by Gary1

    How Do You Re-Start CF Admin? / Service Stopped, Won't Re-Start

    Gary1 Level 1

      CF Admin suddently stopped, and won't re-start.  Have been using CF9 on Win7/x64 for months with no problems.  Was trying to install a Teradata JDBC driver.  After copying the .jar file to the C:\ColdFusion9\lib folder, I went into Services and tried to STOP and RE-START the Cold Fusion Application Server.  While Windows was trying to stop the service, got an error that it was unable to stop the service, and it locked up.  Unable to stop or start service.

       

      After re-booting PC, Services showed all CF services started normally, but can't run CF Admin, and can't access any data sources or run any .CFM programs.  It appears to be stuck.  I tried stopping and re-starting all ColdFusion services, which stopped and re-started fine, but still get error when trying to run CF Admin.  Appears something is hung-up.  Appreciate any advice on how to get the service re-started.  Can't run any .CFM programs as all DSNs are unavailable.  Below is error message when trying to access CF Admin:

       

      Error Occurred While Processing Request 

      The DataSource service is not available. 

      This exception is usually caused by service startup failure. Check your server configuration. 

       

      The error occurred in Application.cfm: line 88

      Called from Application.cfm: line 76

      Called from Application.cfm: line 4

      Called from Application.cfm: line 1

       

      -1 : Unable to display error's location in a CFML template.

       

      Thank you,

      Gary

        • 1. Re: How Do You Re-Start CF Admin? / Service Stopped, Won't Re-Start
          BKBK Adobe Community Professional & MVP

          Quite likely a failed installation then. Here follows a ritual I used to follow when the installation of JARs in ColdFusion got troublesome.

           

          First, stop ColdFusion in Services. Set the ColdFusion start-type to Manual or to Disabled (a temporary measure to prevent an automatic service start), then reboot.

           

          Check Services to verify that the ColdFusion service didn't start. Remove the Teradata JAR file from the lib directory. You should now be back to ColdFusion's previous settings. Start ColdFusion in Services. Can you now run the Administrator and CFM pages? If you cannot, let us know.

           

          Assuming you can, then stop ColdFusion, and set the start-type as before to Manual or Disabled. Reboot. Again, verify that ColdFusion didn't start.

           

          Copy the JAR file back to the lib directory. In Services, set ColdFusion's start-type to Automatic. Reboot (in the hope that Windows will start ColdFusion automatically). The problem should now be solved.

          • 2. Re: How Do You Re-Start CF Admin? / Service Stopped, Won't Re-Start
            Gary1 Level 1

            Thank you for taking the time to reply.  Actually, thanks to some Google-ing, was able to find and fix the problem.  The problem began when I tried to install and verify a Teradata JDBC driver.  When I tried to stop and re-start the service, it locked up.  Then would not start again. 

             

            I discovered the SERVER.LOG file should tell you exactly what the error is, and it did.  It showed an invalid character in 4 places in the neo-datasource.xml file (in the C:\ColdFusion9\lib folder).  So my options were to either remove the invalid characters, or replace the neo-datasource.xml file with the last good working backup.

             

            When this file goes corrupt, the .BAK version is used, and then it goes corrupt when you try to stop-restart the service, and you're left with no backup (.BAK) file. Fortunately, I had another working version of the file on another computer (configured same as this one).  So I copied it to my computer, and replaced the bad one, then re-booted (could have stopped and re-started the service, but decided to re-boot, which does the same thing).

             

            The CF Admin started normally.  I was then able to correctly install the Teradata JDBC driver.  The cause of the problem was that I had failed to also list the tdgssconfig.jar file in the JVM section of CF Admin (even though the instructions I had said the Class 4 driver did not require this file, and that CF would ignore it).  But apparently, it is needed.

             

            Anyway, after all this, the Teradata JDBC drivers verified successfully.  My CF test server is now connecting with the corporate data warehouse in Houston, over 1,000 miles away, using the newly installed JDBC drivers.  And queries and .CFM files are running normally.  Thank goodness.

             

            Anyway, thanks again for the reply.  Much appreciated.  If anyone else has a problem getting CF Admin to start, after tinkering with installing new DSNs, remember to ALWAYS MAKE A BACKUP of your neo-datasource.xml file before you begin.  Better safe than sorry.  Regards,

             

            Gary

            • 3. Re: How Do You Re-Start CF Admin? / Service Stopped, Won't Re-Start
              -==cfSearching==- Level 4

              Glad everything is running again and thanks for posting the resolution for others.

               

               

              ... in the JVM section of CF Admin...

              Also, when modifying the jvm settings, it never hurts to make a backup of jvm.config too. It has certainly saved me more than once.. The location varies based on installation type, but the default is:  C:\ColdFusion9\runtime\bin\jvm.config.

               

               

              -Leigh

              1 person found this helpful
              • 4. Re: How Do You Re-Start CF Admin? / Service Stopped, Won't Re-Start
                Gary1 Level 1

                Thanks, didn't know about that one.  Do now.  Much appreciated.

                 

                Gary