6 Replies Latest reply on Oct 17, 2011 11:07 AM by MetalWolf68k

    Flash Player installer doesn't think I'm an admin

    MetalWolf68k

      I've got 2 system running Windows 7, one running Pro and the other Home. On both I have the only account and thus an admin level account.

      Up until today and this latest update for the player update to 10.3.183.10 the update installer always worked fine.

      Today when I restarted my Win7Pro system it says "You must have administrative privileges to install Adobe Flash Player. Please log on with administrative privileges and try again."

      The only way I could make it work was to create a short cut on the desktop and add the '-update plugin' to the end of the Target line, then right-click it and select 'run as admin'

      I restarted my Win7Home system and it installed and updated just fine.

       

      Ideas anyone?

        • 1. Re: Flash Player installer doesn't think I'm an admin
          chris.campbell Adobe Employee

          Could you post back with your installer log?  It might give us additional details on what's going on.

           

          Where do I find the Flash Player installation log on Windows?

           

          Thanks,

          Chris

          • 2. Re: Flash Player installer doesn't think I'm an admin
            MetalWolf68k Level 1

            Here is everything from the 9/29 part of the log

             

            =O====== M/10.3.183.7 2011-09-29+20-40-19.113 ========

            0000 [I] 00000010 "C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10w_Plugin.exe"

            0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0002 [E] 00001039

            =X====== M/10.3.183.7 2011-09-29+20-40-23.625 ========

             

            =O====== M/10.3.183.7 2011-09-29+20-41-03.863 ========

            0000 [I] 00000010 "C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10w_Plugin.exe" -update plugin

            0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0002 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0003 [I] 00000011 1

            =X====== M/10.3.183.7 2011-09-29+20-41-11.968 ========

             

            =O====== M/10.3.183.10 2011-09-29+20-41-11.971 ========

            0000 [I] 00000010 "C:\Users\XXX\AppData\Local\Temp\6F3.dir\InstallFlashPlayer.exe" -iv 0

            0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0002 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0003 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2

            0004 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0005 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0006 [W] 00001036 Software\Opera Software/Plugin Path 2

            0007 [W] 00001036 Software\Opera Software/Plugin Path 2

            0008 [I] 00000014 C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll

            0009 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10x_Plugin.exe

            0010 [I] 00000017 C:\Windows\SysWOW64\Macromed\Flash

            0011 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0012 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0013 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl 183

            =X====== M/10.3.183.10 2011-09-29+20-41-23.273 ========

             

            =O====== M/10.3.183.10 2011-09-29+20-47-00.606 ========

            0000 [I] 00000010 "C:\Users\XXX\AppData\Local\Temp\install_flash_player.exe" -dlm -install

            0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0002 [F] 00001041

            =X====== M/10.3.183.10 2011-09-29+20-47-00.659 ========

             

            =O====== M/10.3.183.10 2011-09-29+20-47-08.881 ========

            0000 [I] 00000010 "C:\Users\XXX\AppData\Local\Temp\install_flash_player.exe" -dlm -install

            0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

            0002 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2

            0003 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0004 [W] 00001036 Software\Opera Software/Last CommandLine 2

            0005 [W] 00001036 Software\Opera Software/Plugin Path 2

            0006 [W] 00001036 Software\Opera Software/Plugin Path 2

            0007 [I] 00000014 C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll

            0008 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10x_Plugin.exe

            0009 [I] 00000017 C:\Windows\SysWOW64\Macromed\Flash

            0010 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0011 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

            0012 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl 183

            =X====== M/10.3.183.10 2011-09-29+20-47-09.184 ========

             

             

             

            Off topic question:

            How in the heck is Wolf68k already taken?

            Unless I have a second account that I forgot about and/or made on accident.

             

            Message was edited by: MetalWolf68k

            • 3. Re: Flash Player installer doesn't think I'm an admin
              pwillener Level 8

              MetalWolf68k wrote:

               

              Off topic question:

              How in the heck is Wolf68k already taken?

              Unless I have a second account that I forgot about and/or made on accident.

              There is no account with that name; see http://forums.adobe.com/people/Wolf68k

              • 4. Re: Flash Player installer doesn't think I'm an admin
                MetalWolf68k Level 1

                OK well for some reason the forums wouldn't let me use it.

                 

                Anyway, back on topic....

                What's the story on the log? Is there something in that can answer the problem?

                • 5. Re: Flash Player installer doesn't think I'm an admin
                  Zodman

                  I had the same issue on my Windows 7 machine.

                   

                  Looking at the last entry in the log reveals where it's trying to install from (in your post it's at C:\Users\XXX\AppData\Local\Temp\install_flash_player.exe).

                   

                  If you open that folder and run it manually as an administrator it should work.

                  • 6. Re: Flash Player installer doesn't think I'm an admin
                    MetalWolf68k Level 1

                    Yes but that's the last line of the log, that is after I had created a shortcut on my desktop which was set to run as admin.

                    Plus which that is a temperary file which will be deleted later.

                    Both things will not fix the problem of when Flash goes to auto-update.

                     

                    Here is the log of what happens when I force it run normally; in this case running this "C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10x_Plugin.exe -update plugin" from the Run line.

                    =O====== M/10.3.183.10 2011-10-17+17-55-38.877 ========

                    0000 [I] 00000010 "C:\Windows\SysWOW64\Macromed\Flash\FlashUtil10x_Plugin.exe" -update plugin

                    0001 [W] 00001036 SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System/EnableLUA 2

                    0002 [E] 00001022

                    =X====== M/10.3.183.10 2011-10-17+17-55-41.333 ========