3 Replies Latest reply on Oct 10, 2011 11:56 PM by Willam van Weelden

    WebHelp for multiple content categories doesn't include index_csh.html

    Just Mary Level 1

      RoboHelp 9

       

      I used to create output for a WebHelp layout with only one content category, with a start page of index.html.  The output folder would include two additional, RH-generated files, index_csh.html and index_rhc.html.  Within context-sensitive topics in the output, I sometimes linked to additional topics using the format

      <a  href="<path>/index_csh.html#topicid=<topic ID>,withnavpane=false...>, which opened the linked topic within the tri-pane help window.

       

      I've just created another layout that uses multiple categories, with a start page of index.html for the default category, and now those additional files are not part of the output (neither at the root level nor in a category or subcategory folder). It wouldn't matter so much if the index_csh.html file was in a different or multiple locations; I still would be able to simply change the link path.  But now there is no such file, and I'm not sure how to make my links work.  Anyone know anything about this, or have any suggestions?  There is next to no documentation about Content Categories in Adobe's help....

        • 1. Re: WebHelp for multiple content categories doesn't include index_csh.html
          Willam van Weelden Adobe Community Professional & MVP

          Hi,

           

          The _csh file is still there, but is has a different name. The start file of your content categorie is the name of the content categorie. In the content categorie with the name Content the start file is named content.htm and so there also is a content_csh.htm. As long as your content categorie is called Index, it should work. But that is a problem with multiple categories.

           

          There are two viable solutions I can think of:

          • Identify all your links using the CSH and replace them with direct links to the topics. This is the only real solution to the problem.
          • The correct start page is available in the topic through JavaScript. I may be able to devise a JavaScript that gets the correct _csh file for the content categorie and replaces any links to the index_csh.htm with a link to the correct topic. This isn't a real solution, it's more of a workaround so your links keep working until you can create direct links to topics.

           

          Greet,

           

          Willam

          • 2. Re: WebHelp for multiple content categories doesn't include index_csh.html
            Just Mary Level 1

            Hi,

             

            Thanks for the info.  I found those files, and what I've done is to just change my links to point to the _csh file in one of the categories that will be included in all builds/output (for example, to /category1/category1_csh.htm instead of to index_csh.htm), and that seems to work fine.  It feels a little random to be pointing to a (any) subdirectory, but it works for now.  I may replace the links with direct links at some point.

             

            Cheers,

              Mary

            • 3. Re: WebHelp for multiple content categories doesn't include index_csh.html
              Willam van Weelden Adobe Community Professional & MVP

              Does that work correctly with TOC syncing etc? I can imagine this giving problems when you use CBT inside the topics. One CC may include the conditional text while another may not include the conditional text. As long as it works for you.

               

              Greet,

               

              Willam