9 Replies Latest reply on Oct 19, 2011 7:57 AM by SSchwa

    Flow - progress 'clicking on buttons' sporadic

    Simmy_renicks

      Hi,

       

      I am new to Captivate 5 and although manage to handle most of the basics I have run into some trouble when I try combining some items. For example navigating between slides is no problem but when I add a yes no question I'd like to disply the feed back, correct or incorrect and continue navigating using my main interface buttons to go onto the next slide. Sometimes this works but at other times it seems as though I have to click a few times before it works.

       

      Any help would be much appreciated as it holding up delivery of an otherwise completed project.

       

      Thanks,

       

      Simpson

        • 1. Re: Flow - progress 'clicking on buttons' sporadic
          Lilybiri MVP & Adobe Community Professional

          Hello,

           

          Are you using a True/False question slide for that purpose? If yes: question slides have their own logic, and you cannot add interactive objects like buttons to them. I suppose you mean buttons by 'my main interface buttons'. If you are not using question slides but construct your own slide with standard objects you'll be able to control everything.

           

          Lilybiri

          1 person found this helpful
          • 2. Re: Flow - progress 'clicking on buttons' sporadic
            Simmy_renicks Level 1

            Hi Lilybiri,

             

            Thank you for your quick response.

             

            Initially I was importing from a true/false template that I had created in Flash AS2 into the trial of Captivate 4 and it worked well. We then purchased CP5 so that we could start producing our courses earnest, but soon discovered that it only supports AS3, another thing I am a complete novice at, and so, then replicated the question on the slide using CP objects.

             

            It seems to work on some slides but on others my logic fall over, even though they are a direct copy of previous slides. I thought it was to do with having to dismiss the feedback before proceeding, but sometimes it takes several clicks to proceed.

             

            Would you mind having a look at the code? I sure it is simply my unfamiliarisation with the product but it is holding my repid progress with the otherwise excellent tool.

             

            Regards,

             

            Simpson

            • 3. Re: Flow - progress 'clicking on buttons' sporadic
              Lilybiri MVP & Adobe Community Professional

              Are you using advanced actions or AS? I can help with advanced actions, but for AS you'll need another user that is an expert programmer.

               

              Lilybiri

              • 4. Re: Flow - progress 'clicking on buttons' sporadic
                Simmy_renicks Level 1

                Hi,

                 

                Sorry, I should have said cptx file instead of code. I've had to abondon flash as I'm not up on AS3 and advanced actions are, as yet, beyond me. How do people normally send you their cptx files. I zipped it and put it onto a web server. can I email you the URL?

                 

                Regards,

                 

                Simpson

                • 5. Re: Flow - progress 'clicking on buttons' sporadic
                  Lilybiri MVP & Adobe Community Professional

                  Hello,

                   

                  I'm looking at your file but have a bunch of questions....

                   

                  First of all: are you on CP5 or 5.5? I'm asking this because I see that you are using the button widget all the time, and in CP5.0 this widget has a pausing point, in CP5.5 it has not. Both are static widgets, that is why you could use them also on the question slides. But it would have been a lot easier to put them on a master slide (just a tip) instead of copying them all the time.

                   

                  None of the questions are added to the Total score (have a look at the Advanced Interaction view - F9). Contrary to what you answered, you do use Question slides for the T/F but added a lot of objects to them, would like to know why? I looked at the first question slide: slide 3. This slide is paused at 1,5sec, because it is a question slide. You did extend this slide to 600secs???? This has no sense at all, because it pauses at 1,5sec. I tried recently to explain the behavior of question slides: Question Question slides perhaps that could help you understand.

                   

                  You kept the Submit button, all the feedback messages, which pop up after clicking on the Submit button. Normally the second step is to click on the slide or press Y, which will release the playhead (that is still paused at 1,5secs). Better not put the Next button there, but just an image (to have the same look) of it: the click box covers up all the slide, so clicking on the image of the button will release the playhead and you could even configure the behavior to go to the next slide instead of continue (actions On Success/After Last attempt in the Action accordion of the Quiz Properties) so you see that there is no need whatsoever to have a slide of 600secs because you only use something like 2secs.

                   

                  Had a look at your Quiz Settings, and there you will have troubles. Please do not choose the option 'Required, the user must....' as Required. You do not allow Backward movement, but why do you have a Back button on the slide? This is again a widget, but will cause conflicts with your Quiz settings.

                   

                  I opened your file in CP5.5 on a laptop i7 with 12GB RAM and a dedicated graphics card (1GB) and your file is 'slow', even blocking CP at some moments, had to restart several times. It is not due to the filesize but suppose to those weird combinations of question slides with a lot of widgets.

                   

                  You have an advanced action, that will never be functional (but you do not use it). Strings are not included in "" in Captivate. So it should have been:

                  Assign rdcmndPause with 1

                   

                  This should pause the movie, the same way like the Pause button on a playbar. To restart the movie you'll need another system variable. Explained all this here:

                   

                  Custom Pause/play button

                   

                  Hope you understand that I'm only a user like you. Could you answer my question about the version and the other questions?

                   

                  Lilybiri

                  • 6. Re: Flow - progress 'clicking on buttons' sporadic
                    Simmy_renicks Level 1

                    Wow that is a magnificent response - sorry to be so distruptive and cause you so much trouble. Thank you.

                     

                    Please see comments below in red

                     

                     

                     

                     

                     

                    Date: Fri, 7 Oct 2011 07:15:16 -0600

                    From: forums@adobe.com

                    To: simpson_renicks@hotmail.com

                    Subject: Re: Flow - progress 'clicking on buttons' sporadic Flow - progress 'clicking on buttons' sporadic

                     

                     

                     

                     

                     

                     

                     

                    Re: Flow - progress 'clicking on buttons' sporadic created by Lilybiri in Getting Started - View the full discussion

                     

                     

                     

                    Hello,

                     

                    I'm looking at your file but have a bunch of questions....

                     

                    First of all: are you on CP5 or 5.5? I'm asking this because I see that you are using the button widget all the time, and in CP5.0 this widget has a pausing point, in CP5.5 it has not. Both are static widgets, that is why you could use them also on the question slides. But it would have been a lot easier to put them on a master slide (just a tip) instead of copying them all the time.

                     

                     

                    It is definetly CP5 - I think I did initially put the buttons on the Master slide but then run into some problems hideing and displaying them. But I appreciate the concept and will attempt to correct this.

                     

                     

                    None of the questions are added to the Total score (have a look at the Advanced Interaction view - F9). Contrary to what you answered, you do use Question slides for the T/F but added a lot of objects to them, would like to know why? I looked at the first question slide: slide 3. This slide is paused at 1,5sec, because it is a question slide. You did extend this slide to 600secs???? This has no sense at all, because it pauses at 1,5sec. I tried recently to explain the behavior of question slides: Question Question slides perhaps that could help you understand.

                     

                     

                    The questions are not scored and are simply used to chek the users understanding - There are seperate tests that each type of user much complete once they have completed the scenarios. These are SCORM 1.2 and work in Moodle - although I have had some performance issuses - as you touch on later.

                     

                    The only excuse I can give for odd/non logical settings was me experimenting with the product and then forgeting settings/changes I had made. I had 18 of these size files to create in 2 weeks and NO real experience of Captivate.

                     

                     

                    You kept the Submit button, all the feedback messages, which pop up after clicking on the Submit button. Normally the second step is to click on the slide or press Y, which will release the playhead (that is still paused at 1,5secs). Better not put the Next button there, but just an image (to have the same look) of it: the click box covers up all the slide, so clicking on the image of the button will release the playhead and you could even configure the behavior to go to the next slide instead of continue (actions On Success/After Last attempt in the Action accordion of the Quiz Properties) so you see that there is no need whatsoever to have a slide of 600secs because you only use something like 2secs.

                     

                     

                    I think this is the explanation that I've been looking for but will need to try and follow - please bear with me

                     

                     

                    Had a look at your Quiz Settings, and there you will have troubles. Please do not choose the option 'Required, the user must....' as Required. You do not allow Backward movement, but why do you have a Back button on the slide? This is again a widget, but will cause conflicts with your Quiz settings.

                     

                     

                    If I can avoid using the quiz slide I will - the back button is used throughout the course and I've simply called this file NOBack in an attempt to correct my performance issuses

                     

                     

                    I opened your file in CP5.5 on a laptop i7 with 12GB RAM and a dedicated graphics card (1GB) and your file is 'slow', even blocking CP at some moments, had to restart several times. It is not due to the filesize but suppose to those weird combinations of question slides with a lot of widgets.

                     

                    I see - I will percivere with the buttons simply on the master slide and learn to hide and seek.

                     

                    You have an advanced action, that will never be functional (but you do not use it). Strings are not included in "" in Captivate. So it should have been:

                    Assign rdcmndPause with 1

                     

                     

                    Again I was experimenting and had not making much progress  thanks for pointing this out

                     

                     

                    This should pause the movie, the same way like the Pause button on a playbar. To restart the movie you'll need another system variable. Explained all this here:

                     

                    Custom Pause/play button

                     

                    Hope you understand that I'm only a user like you. Could you answer my question about the version and the other questions?

                     

                    Lilybiri

                     

                    Thank you for your help  I'll attempt to apply your ideas now - I couldn't have got things more mixed up if I tried - sorry

                     

                    Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: Re: Flow - progress 'clicking on buttons' sporadic

                    To unsubscribe from this thread, please visit the message page at Re: Flow - progress 'clicking on buttons' sporadic. In the Actions box on the right, click the Stop Email Notifications link.

                    Start a new discussion in Getting Started by email or at Adobe Forums

                    For more information about maintaining your forum email notifications please go to http://forums.adobe.com/message/2936746#2936746.

                    • 7. Re: Flow - progress 'clicking on buttons' sporadic
                      Lilybiri MVP & Adobe Community Professional

                      You can have more than one master slide, make one without the button(s) to apply where you need it.  I would even think about putting the image that you use behind the question (with red/white/red stripes) on the master slide that you'll use for those slides.

                       

                      If you do not use the question slides, you'll have to use advanced actions and the radiobuttons widget. Have several blog posts (do not curse me, started blogging out of laziness to avoid having to repeat the same answer over and over again about constructing custom question slides. Certainly if you do not need to report the score or do you want to show it to the user?

                       

                      Widgets and custom questions - source list

                       

                      Lilybiri

                      • 8. Re: Flow - progress 'clicking on buttons' sporadic
                        Simmy_renicks Level 1

                        Thanks again for your 'totaly make sense' sugestions as well as sharing your vast knowledge.

                         

                        I don't need to keep a score in the scenarios or show to the users how they are doing as they are given instant feedback - i.e. correct of incorrect and then go on regardless to a fuller explanation on the next slide.

                         

                        They have to complete a sepertate SCO which contain a quiz created in CP5 which displays the score at the end and updates the LMS.

                         

                        I'll check out you blogs as soon as I've implemented some of you other, more straight forward ideas.

                         

                        Regards,

                         

                        Simpson

                        • 9. Re: Flow - progress 'clicking on buttons' sporadic
                          SSchwa Level 1

                          In reading this post, I was hoping someone might have a suggestion for what I'm trying to do.

                          I'm trying to create a project that allows the user can to view a demo or practice steps on their own, switching between the two whenever they want to. Lilybiri, I actually found a posting of your's where you explained using a knockout slide with button widgets, which seemed to be exactly what I wanted. However, I would have that I would have been able to easily add buttons that could link to either the start of the demo or the start of the try me portion. But it seems that  the buttons are pausing the project, so when I click to go to the demo portion, the project pauses and doesn't continue with the demonstration... I guess because the buttons are on the page? Which is kind of confusing because I don't see any options to pause the project as part of the button properties? I would have thought the demonstration would continue until the user decided to click a button to return to the begin of the demonstration, or move to the try me portion.

                           

                          Any help would be greately appreciated. Thank you!