4 Replies Latest reply on Nov 10, 2006 7:40 AM by SteelcaseMark

    Import Not Importing .swf file

    SteelcaseMark Level 1
      When I import the .htm file, the .htm, the skin, and a file called standard.js are imported. The .swf file is not. Using Explorer to copy the .swf file into the same folder as the .chm file does nothing. The captivate .swf file does not play.

      Thanks in advance for any assistance you can offer.
        • 1. Re: Import Not Importing .swf file
          Captiv8r Adobe Community Professional & MVP
          Hi SteelcaseMark

          Sounds like you are trying to insert a Captivate 2 file. Here's the thing. When you aim RoboHelp at a Captivate 2 file, you are probably pointing at the HTML file. Because the HTML file references the standard.JS file and the skin.SWF file, RoboHelp knows to bring these in. But this leaves the main .SWF file that consists of the actual movie. RoboHelp is unaware it should bring it along for the ride because it is only referenced from the "skin" .SWF file. So RoboHelp ignores it.

          So what to do?

          You have two (maybe more) choices in how you handle this.

          1. You can manually ensure you copy the main .SWF file and add it to RoboHelp Baggage as a manual process.

          OR

          2. You can create a single .SWF file from Captivate by clicking Project > Skin... > Borders tab and DE-selecting the "Show Borders" option. Note that if you do this, the playback controls will be moved up on top of your main movie. You can overcome this by first noting how many pixels the skin is adding to the height of the movie, then resiizing the movie to make it taller in order to reserve room for the playback controls.

          Hopefully this helps... Rick
          • 2. Re: Import Not Importing .swf file
            SteelcaseMark Level 1
            Rick,
            Thanks for the suggestions! However, they did not produce the desired results. I tried option one and that did not work. I tried opton two and that did not work. I tried combining option one and option two and that did not work.

            When I click on the link to run the captivate movie, the following message appears.
            "Internet Explorer cannot open the Internet site mk:@MSITStore:driveletter\foldername\foldername\filename.chm::/captivatefielname.htm. Access is denied."

            A Google serach of "mk:MSITStore" suggested that the hhctrl.ocx file was not up to date. It is.

            The RoboHTML project is edited, compiled and saved on a netwrok drive. I publish the Captivate movie to the same folder as the project. Should I do everything on my local drive?

            Thanks again in advance for your assistance.

            Mark
            • 3. Re: Import Not Importing .swf file
              SteelcaseMark Level 1
              When I click the link in RoboHelp to the Captivate2 movie, the following message appears in my browser:

              "To help protect your security, Internet Explorer has restricted this file from showing active content that coiuld access your computer. Click here for options."

              I click and select "Allow blocked content."

              I get a warning and choose OK.

              The browser tries to access mk:@MSITstore blah blah blah and a blank screen appears.

              I have stoppped my popup blocker and reset my security to download signed and unsigned Active X controls.
              • 4. Re: Import Not Importing .swf file
                SteelcaseMark Level 1
                I have discovered that CP2 creates the HTM file with a call to a javascript that tries to access macromedia for a flash download. CP1 creates the HTM file without the javascript.

                When I cut and paste the CP1 generated HTML into the CP2 generated HTML, I still get prompted that IE is blocking active content, but when I allow the blocked content, the project runs like a champ!

                So, what is the setting to let CP2 generate HTML without the javascript?