2 Replies Latest reply on Sep 9, 2012 4:17 PM by code_away

    Getting a ReferenceError: Error #1065 at application start

    CRon_007

      Hi all,

      I'm getting the following error at the start of my application:

       

      ReferenceError: Error #1065: Variable mx.messaging.config::ConfigMap is not defined.

      at _ABC_FlexInit$/init()

                at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::kickOff()

                at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::preloader_completeHandler()

                at flash.events::EventDispatcher/dispatchEventFunction()

                at flash.events::EventDispatcher/dispatchEvent()

                at mx.preloaders::Preloader/timerHandler()

                at flash.utils::Timer/_timerDispatch()

                at flash.utils::Timer/tick()

       

      I have gone through a lot of posts on various forums. Most of them say that this error usually occurs in cases like:

      • not declaring classes as 'public'
      • trying to refer something that isn't there
      • syntax error

       

      When i run my application, it actually runs just fine. When i try to run the swf that is generated from maven install on my application, that is when this error occurs. So i can safely say that the above mentioned cases are not the reason for this error. So why is my maven built swf throwing this error. Any help would be much appreciated.

       

      Thanks.