0 Replies Latest reply on Oct 8, 2011 2:15 PM by nalply

    rtmps over port 80 not being tried?

    nalply

      My team is deploying an SSL-only application. Port 443 is reserved for https. I am experimenting with port 80 as a replacement port for rtmps. But it seems not to work. I am using url "rtmps://host:80/app" to no avail. Port 81 works, also does port 443, but both are not ideal. 81 is not a common port to be open at firewalls and 443 is already used.

       

      I watched the ports on the client machine with lsof which tells me the connection attempts. Ports 81 and 443 are tried by the flash player, but not port 80.

       

      I am using Flash Builder 4 and Flex 4.5. Code:

       

      var nc:NetConnection = new NetConnection();

      nc.addEventListener(NetStatusEvent.NET_STATUS, function(e:NetStatusEvent):void {

          trace(e.info.code);

      });

      nc.connect("rtmps:://host:80/app");

       

      gives:

       

      NetConnectionConnect.Failed

       

      but it seems the Flash Player did not even try to connect. Does someone else also have this behavior? rtmps over port 80 not being tried? If yes, is there a workaround (like setting up a specific NetLoader)?