3 Replies Latest reply on Oct 10, 2011 8:07 PM by TimeRemapper

    Bezier Redraw So Slow

    Marc Trzepla Level 1

      Why is the redraw of bezier curves in After Effects so darned so?  If all I do is make a closed shape on a solid, go so far as to make the solid 0%, the mask None and the antialiasing quality 'off' the redraw of moving points or reshaping handles is for the birds.  Where's the consistency with other Adobe apps like Photoshop and Illustrator where the response of paths on the same machine is fluid and un-noticeable? 

       

      OpenGL is on - tried it off too - in After Effects CS 5.0 on Windows 7, 64 bit, etc etc etc.   ATI Mobility Radeon HD 5850

       

      Anyone else miserable with After Effects paths?

       

      Thanks

        • 1. Re: Bezier Redraw So Slow
          Rick Gerard Adobe Community Professional & MVP

          They're very snappy for me, even on a zillion year old MacBook... Never seen them slow. Have they always been this way??? There's got to be something wrong with a driver somewhere. Have you tried trashing your prefs?

           

          • 2. Re: Bezier Redraw So Slow
            Marc Trzepla Level 1

            Yeah, it's always been this way.   Multiple machines over time, many versions of After Effects.    AND I've experienced this on Mac Pro towers too, not just my Windows laptops.  I think I just finally snapped tonight, doing a lot of roto under the gun and screaming for the shapes to be the way I want them to be.

             

            Your video smacks of the same performance I get in Photoshop and Illustrator, even on large canvases (Photoshop) or with high rez placed images that I'm tracing (Illustrator).

             

            I'll do the toss-the-prefs but again, this has been a thorn in my side for a long, long time.

             

            Thanks Rick.

            • 3. Re: Bezier Redraw So Slow
              TimeRemapper Level 4

              Try making sure that you've disabled the OpenGL enhancements for drawing panels as well as for Previews and Renders (it's called hardware acceleration for panels, or something to that effect). Do you have any third party input devices enabled (wacom, intellipoint, etc...)? Their drivers may be problematic if not updated.