3 Replies Latest reply on Oct 12, 2011 2:29 AM by MurrayFurtado

    Installing flashplayer 11 on Linux 64 bit - error while loading shared libraries: libX11.so.6

    MurrayFurtado Level 1

      I've downloaded the flashplayer_11_sa_debug.i386.tar.gz file and extracted it on my RHEL box. When I run ./flashplayerdebugger I get the following error:

       

      ./flashplayerdebugger: error while loading shared libraries: libX11.so.6: wrong ELF class: ELFCLASS64

       

      This lib is found in /usr/lib64/libX11.so.6 on this machine.

       

      It is my understanding that flashplayer has native 64 bit support on Linux and therefore should be compatible with lib64 libaries, so why I am I seeing this error? I've been told it's because it's a 32 bit version of the player....

       

      I also see this error if I install the flashplayer_11_sa.i386.tar.gz projector instead of the debugger version.

       

      There don't seem to be any specific 64bit versions of the flashplayer from the download page: http://www.adobe.com/support/flashplayer/downloads.html, yet there seem to be beta releases of a 64 bit Linux player which are no longer available.

       

      Can anyone help me with this? Where can I get a 64bit v11 flashplayer for Linux?

       

      Thanks