0 Replies Latest reply on Nov 8, 2006 4:34 PM by emmatomita

    troubles with HTTPService

    emmatomita
      HI, i need do a connection using httpservice to an ASP page: this is my services-config.xml file
      <?xml version="1.0" encoding="UTF-8"?>
      <services-config>
      <services> <service-include file-path="proxy-config.xml" /> </services>
      <channels>
      <channel-definition id="my-http" class="mx.messaging.channels.HTTPChannel">
      <endpoint uri=" http://localhost:8700/flex/messagebroker/http" class="flex.messaging.endpoints.HTTPEndpoint"/>
      </channel-definition>
      </channels>
      </services-config>
      And this is my proxy-config.xml file:

      <?xml version="1.0" encoding="UTF-8"?>
      <service id="proxy-service"
      class="flex.messaging.services.HTTPProxyService"
      messageTypes="flex.messaging.messages.HTTPMessage,flex.messaging.messages.SOAPMessage">

      <properties>
      <connection-manager> <max-total-connections>100</max-total-connections> <default-max-connections-per-host>2</default-max-connections-per-host>
      </connection-manager>
      <allow-lax-ssl>false</allow-lax-ssl>
      </properties>

      <default-channels>
      <channel ref="my-http"/>
      </default-channels>

      <adapters>
      <adapter-definition id="http-proxy" class="flex.messaging.services.http.HTTPProxyAdapter" default="true"/>
      </adapters>

      <!-- This is my http destination -->
      <destination id="paleta">
      <properties>
      <url> http://167.157.38.9/flash/flex/asp/oracle.asp</url>
      </properties>
      </destination>
      </service>

      And this is my HTTP Service TAG:

      <mx:HTTPService id="userRequest" destination="paleta" showBusyCursor="true" useProxy="true" method="POST" fault="faultHandler(event)">
      <mx:request xmlns="">
      <codigoSIS>{txtCaja.text}</codigoSIS>
      <plan>188301</plan>
      </mx:request>
      </mx:HTTPService>

      My oracle.asp file has the next very simple code:
      <% cad = "<resultados>"
      cad = cad & "<resultado>"
      cad = cad & "<Apellido>Jordan Parrado</Apellido>"
      cad = cad & "<Nombre>franz manfred</Nombre>"
      cad = cad & "<Edad>34</Edad>"
      cad = cad & "<Sexo>Masculino</Sexo>"
      cad = cad & "</resultado>"
      cad = cad & "</resultados>"
      response.write(cad)
      %>

      When my application is running and i call to this service, only appears the clock icon and there is no result in the grid where the result would be appear.
      Some body could help me please???
      regards, franz