2 Replies Latest reply on Nov 9, 2006 5:25 PM by >Vee<

    scrollPane in the butt

    >Vee< Level 1
      I have a scrollPane that loads a swf into itself using: my_sp.contentPath = mySWF.swf;

      locally it works fine but when I post it to my site the scrollbars do not appear (but the file does load). The swf that gets loaded into my scrollpane has uses an XML file, which in turn triggers a loop with attachMovie to make the movieclips build across the stage. Again locally this works fine, is there a loading issue with this method not telling the scrollpane the actual dimensions of the stage?

      I should tell you that i made a really wide file and loaded it into my_sp and everything worked fine. I really dont want to set mySWF.swf's stage width to some artbitrary number just to make this work.
        • 1. Re: scrollPane in the butt
          Level 7

          ">Vee<" <webforumsuser@macromedia.com> wrote in message
          news:eith1q$i73$1@forums.macromedia.com...
          >I have a scrollPane that loads a swf into itself using:
          >
          > my_sp.contentPath = mySWF.swf;
          >
          > When I test this locally it works in my web browser as well as in the
          > player
          > window. Now when I post it on the server, the 'content' gets loaded into
          > my_sp
          > but it does not produce scrollbars. mySWF.swf uses XML to make it get
          > wider.
          > I'm thinking since it doesnt have the stages true width on opening that it
          > doesnt tell my_sp what the true size is. Is there any way to fix this.
          >
          > I should tell you that i made a really wide file and loaded it into my_sp
          > and
          > everything worked fine. I really dont want to set mySWF.swf's stage width
          > to
          > some artbitrary number just to make this work.
          >

          I had to respond becuase of your clever subject.

          Take a look at
          UIObject.redraw() and
          UIObject.invalidate()
          both of which are inherited by the ScrollPane class.



          • 2. scrollPane in the butt
            >Vee< Level 1
            Thanks for replying, Im glad someone thought it was funny.

            As you can see I tried that and refresh, both produced the same results after reseting my cache. I get no scroll bars the first time i load the content but when i use the browsers refresh button the content and the scrollbars load correctly. Am I doing something wrong? maybe its in the wrong place. Let me know if you need me to attach more of the listeners I have. I feel like i am missing something really obvious, this has to be a common thing.

            Heres how I implemented it: