6 Replies Latest reply on Oct 20, 2011 8:38 AM by Nlwest

    Linked Adobe Tagged Text files importing without styles

    Nlwest User Group Manager

      I have several data-heavy weekly publications where suddenly, the link to all Adobe Tagged Text format files have the proper paragraph styles and character styles stripped on being placed.  I'm aware of the default settings issue, where you deselect all and make sure the character styles is none, and that does not seem to be the issue. Specifics are


      • Working in CS 5 (Version 7.0.4)
      • The Adobe Tagged Text format files are exported from Excel spreadsheets
      • The InDesign documents have links to the Adobe Tagged Text format files, and Update Link is used inside InDesign to update the text when the file is exported from the spreadsheet.
      • When the publications are opened on my workstation, ALL files linked to Adobe Tagged Text files are not imported correctly, they revert to the Basic Paragraph style.
      • These are not new documents I'm designing or new Adobe Tagged Text files, this is part of a production process that has worked without issue for years.
      • When the same documents are opened on another workstation, and Update Links used, they come in perfectly, so it doesn't seem to be a document or file corruption problem, but a problem with my environment or ID settings.
      • It's not one specific document or file, it is every single document that has a link to an Adobe Tagged Text file (and we have lots, I tried several!)
      • I've opened the text files in the text editor to check them, but as I mentioned: same document, same files, I'm the only one who can't update without stripping out the styles.

      Thanks! Nancy

        • 1. Re: Linked Adobe Tagged Text files importing without styles
          Peter Spier Most Valuable Participant (Moderator)

          Are these REALLY "Tagged Text," meaning the output from Excel has a header section and tags for each paragraph telling ID what the styling is supposed to be, or is it some sort of plain text/.csv file?


          It's entirely possible to link text files, just as you can link images, but the formatting is controlled by the text file. If you make edits in ID after placing, then update the text file, anychanges you made in ID will be lost.

          1 person found this helpful
          • 2. Re: Linked Adobe Tagged Text files importing without styles
            Joel Cherney Level 5

            Hi Nancy,


            It's notable that you don't point out that you've set up your workstation with Create Links When Placing Text or Spreadsheet Files. That means you're not placing them, you're just updating the links, right? Does that mean that you've also not seen this window in a while?



            The only suggestions I can think of are:


            1) Place a tagged text file (with Show Import Options checked) to reassure yourself that Remove Text Formatting isn't checked by default on your workstation




            2) If everyone else's machine is behaving correctly, perhaps your install of InDesign is borked. First try replacing your preferences; if that doesn't work, reinstall.


            Of course there's always


            3) Hopefully someone who knows more about InDesign tagged text shows up and posts in your thread.


            Edit: Okay, maybe Peter is acting as option no. 3 above.

            • 4. Re: Linked Adobe Tagged Text files importing without styles
              Nlwest User Group Manager

              Hi, Peter! Thanks for the response. Yes, it's really Tagged Text. See below. After exporting from the spreadsheet and database, opening the document in InDesign, and selecting update link, we do no editing in InDesign after the fact because everything is already setup exactly as we want it with the Tagged Text format.


              I have literally hundreds of these among several different documents, updated weekly, mainly dealing with prices and numbers. Every one of the links to Tagged Text format files in every publication now strips out the Tagged Text paragraph style and character style formatting on Update Link on my workstation only. On my other two workstations, the links update without issue, and everything is correct in the final document.


              So I'm beginning to think I need to look at rebuilding something, maybe as Joel said, replacing preferences. I keep looking for a workstation or ID option that might effect this.




              <dps:Pnl Comp\:Pnl Comp \$Numbers=<Nextstyle:Pnl Comp\:Pnl Comp \$Numbers>>

              <dps:Pnl Comp\:Pnl Comp Bold \$Numbers=<BasedOn:Pnl Comp\:Pnl Comp \$Numbers><Nextstyle:Pnl Comp\:Pnl Comp Bold \$Numbers>>

              <dps:Pnl Comp\:Pnl Group \$Numbers=<BasedOn:Pnl Comp\:Pnl Comp \$Numbers><Nextstyle:Pnl Comp\:Pnl Group \$Numbers>>

              <pstyle:Pnl Comp\:Pnl Comp Bold \$Numbers> $302 $302 $278

              <pstyle:Pnl Comp\:Pnl Group \$Numbers> 203 202 211

              <pstyle:Pnl Comp\:Pnl Group \$Numbers> 456 458 393

              • 5. Re: Linked Adobe Tagged Text files importing without styles
                Nlwest User Group Manager

                Joel, thanks for the reply. You are correct, I haven't seen that window in ages, since it only appears when I first place and link the files. Actually, you might be on to something, because last week, I was having to troubleshoot a problem with data merge into a document, and was using place. I faintly remember having an issue similar to this one before, and it was hard to troubleshoot because I could not find a way to easily review what the current detault Tagged Text import setting was, because I almost never place tagged text files, I just set up permanent links. I wish there was an option setting where you could review and change it. I'm going to check it right now.

                • 6. Re: Linked Adobe Tagged Text files importing without styles
                  Nlwest User Group Manager

                  Yes, that was it exactly, Joel, thank you! I'm adding that one to my troubleshooting checklist, I completely forgot that Import Options window that disappears and I never see again. Problem solved!