1 Reply Latest reply on Nov 13, 2006 12:21 PM by ntsiii

    URLLoader TypeError: #1010

    mmesarina Level 1
      Hi,
      I am using URLLoader() for doing HTTP requests to a server that returns XML data.
      When I run my program, I get an error that the URLLoader.data is "undefined". However, this only happens every so often.
      I checked that the server is sending valid XML, with a third program that just sends http requests to the server and prints the results, and this program just works fine.
      Does anyone have an idea of what is going on or how i can debug the problem better. The http status is always 200 OK, so that is not the problem. It is not an IO problem either because my ioerrorhandler does not give any notification.

      Here is the error output:

      httpStatusHandler: 200
      httpStatusHandler: 200
      In PerfXmlLoaded Data: undefined
      Inside getPerfDataFromQueryResults
      TypeError: Error #1010: A term is undefined and has no properties.
      at Telescope/getPerfDataFromQueryResult()[C:\Documents and Settings\malena\My Documents\Flex Builder 2\Telescope\Telescope.mxml:127]
      at Telescope/PerfXmlLoaded()[C:\Documents and Settings\malena\My Documents\Flex Builder 2\Telescope\Telescope.mxml:220]
      at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at flash.net::URLLoader/flash.net:URLLoader::onComplete()

      thank you in advance.

      -Malena
        • 1. Re: URLLoader TypeError: #1010
          ntsiii Level 3
          You are doing the URLLoader work in a function right? There is a bad example out ther that does the work in the script block outside any function. It always fails though.

          Consider using HTTPService for getting xml data. I have seen a lot of folks having trouble with URLLoader.

          Tracy