6 Replies Latest reply on Dec 5, 2011 6:41 AM by kasq

    using OOTB video component

    efish11

      I was able to follow the instructions on the link (http://dev.day.com/docs/en/cq/current/wcm/default_components/VideoComponents.html)

      ) to get the video component working after downloading the FFMPEG windows executable on my windows machine.

       

      I amtrying to achive the same on solaris environment, The instructions on the link are only for windows and mac environments. I cannot seem to

      find a compiled binary of ffmpeg for solaris on the http://ffmpeg.org/ site.

       

      Environment: CQ 5.4, solaris 5.10

        • 1. Re: using OOTB video component
          G. Walt Adobe Employee

          To install ffmpeg on solaris, you'll need to checkout  the sources from the ffmpeg git repository and compile them yourself.

           

          Basically, without being able to test it on Solaris, this should look something like that:

          git clone git://git.videolan.org/ffmpeg.git ffmpeg

           

          Then follow the ffmpeg instructions in the INSTALL file:

          http://git.videolan.org/?p=ffmpeg.git;a=blob_plain;f=INSTALL;hb=refs/heads/master

           

          Once compilation and installation is successful, ffmpeg will need to be in PATH so that CQ5 can pick it up via command line.

           

          That's basically it, so the biggest challenge is to get ffmpeg running on Solaris, there really is not much needed from the CQ5 side.

          1 person found this helpful
          • 2. Re: using OOTB video component
            Sham HC Level 7

            Agree with G. Walt response. Providing an alternative  approach by using Pkgutil is the new way of installing Solaris packages

             

            • In the terminal enter below (when it will prompt for installing all depeendency say all and yes)

            pkgadd -d http://get.opencsw.org/now

             

            • After Pkgutil is installed set the envirnoment variable path

            PATH=$PATH:/opt/csw/bin

            export PATH

             

            • Install ffmpeg by entering below in terminal and say yes for installing all dependency

            pkgutil -i CSWffmpeg

             

            • Make sure ffmpeg to be in PATH & CQ5 will pick it up
            1 person found this helpful
            • 3. Re: using OOTB video component
              kasq Level 3

              Hi All,

               

              I have problem with using Video Component. I just tried enable it on my local CQ 5.4 repository installed and started on Windows. I have installed FFMPEG codes for Windows as it was sugested in the documentation.

              and prepared test for component on my local CQ repository to check if it is working fine and I found some problem with configuration of "High Quality H.264" DAM VIDEO PROFILE which is used to create mp4 rendition for video file uploaded in to the DAM.

               

              I downloaded the latest version of FFmpeg codecs and when I tried to upload one simple flv file to the DAM the rendition mp4 has not been created for this file - rendition for video profiles "Flash 7+ low quality" and "Firefox HQ ogg" was created without problems.

               

              After checking logs from local repository I found something like this:

               

              1. 30.11.2011 11:07:17.124 *INFO* [Thread-2232] com.day.cq.dam.handler.ffmpeg.FFMpegWrapper FFMPEG Exec: Unknown encoder 'libfaac'

               

              After some investigation I found that from the libfaac codec has been removed from FFmpeg for licensing reasons. At this situation I have question how we should configure "High Quality H.264" video profile to enable a creating for a website mp4 rendition of a video file.

               

              And the last thing - question to efish - which version of FFMPEG codes you installed - I'm couris becuase when I installed the latest version I have problem described above.

               

              Thanks in advance for any advice

              • 4. Re: using OOTB video component
                efish11 Level 1

                Sorry for the late reply, if you havent found this - please try the below

                 

                 

                Either rebuild ffmpeg to allow libfaac or change to use "acc" instead of "libfacc" and then add "-strict experimental" to the command line options. You can change these setting by editing the "High Quality H.264" video profile under "Tools > DAM > Video Profiles".

                • 5. Re: using OOTB video component
                  kasq Level 3

                  Hi EFish,

                   

                  I have changed video configuration like you sugessted by replacing libfacc with acc and adding "-strict experimental" to the command line options.

                   

                  I have made some test and in the logs I have following error message:

                   

                  05.12.2011 14:12:35.561 *INFO* [Thread-580] com.day.cq.dam.handler.ffmpeg.FFMpegWrapper FFMPEG Exec: Unknown encoder 'acc'

                  05.12.2011 14:12:35.569 *ERROR* [JobHandler: /etc/workflow/instances/2011-12-05/model_266528348440629:/content/dam/ucfoundation/testNe w.flv/jcr:content/renditions/original] com.day.cq.dam.video.FFMpegTranscodeProcess Process exited with an error: 1(Exit value: 1) java.io.IOException: Process exited with an error: 1(Exit value: 1)

                      at com.day.cq.dam.handler.ffmpeg.FFMpegWrapper.transcode(FFMpegWrapper.java:523)

                      at com.day.cq.dam.handler.ffmpeg.FFMpegWrapper.transcode(FFMpegWrapper.java:459)

                      at com.day.cq.dam.video.FFMpegTranscodeProcess.processVideo(FFMpegTranscodeProcess.java:83)

                      at com.day.cq.dam.video.AbstractFFMpegProcess.execute(AbstractFFMpegProcess.java:90)

                      at com.day.cq.workflow.impl.job.HandlerBase.executeProcess(HandlerBase.java:172)

                      at com.day.cq.workflow.impl.job.JobHandler.process(JobHandler.java:122)

                      at org.apache.sling.event.jobs.JobUtil$1.run(JobUtil.java:272)

                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

                      at java.lang.Thread.run(Unknown Source)

                   

                  I'm using in my PC Windows 7 and I have installed and started CQ 5.4. I also created a ticket to ADOBE and they suggested to install some earlier version of FFMPEG codes.

                   

                  Honestlly I don't know if I can rebuild ffmpeg and to add libfacccodec, becuase in case when it is lincesed I can't use it for commercail website.

                  If it is possible please tell me which version of ffmpeg you are using and if you checked with your version this workaround suggested by you.

                   

                  Thanks in advance,

                  Adam

                  • 6. Re: using OOTB video component
                    kasq Level 3

                    Sorry for the spam, but I found another solution. Instead of using libfaac and the workarounds which you suggested, I replaced in the configuration of video profile "libfaac" with "libvo-aacenc", codec which was enabled in the latest build of ffmpeg for Windows. Now everything is working fine on my local repository of CQ 5.4 on Windows 7.

                     

                    Honestlly I don't know what is the quality difference between "libfaac" and "libvo-aacenc", but for me the most imporant is that now encoding works.

                     

                    Thanks a lot for support.